gom-devel-0.3.3-lp150.1.6.x86_64.rpm


Advertisement

Description

gom-devel - Development files for the GObject Data Mapper

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package name gom-devel
Package version 0.3.3
Package release lp150.1.6
Package architecture x86_64
Package type rpm
Installed size 157.14 KB
Download size 23.84 KB
Official Mirror widehat.opensuse.org
This is a DataMapper for GObject.

Alternatives

Package Version Architecture Repository
gom-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libgom-1_0-0 = 0.3.3
pkgconfig(gobject-2.0) -
python3-gom = 0.3.3
typelib-1_0-Gom-1_0 = 0.3.3

Provides

Name Value
gom-devel = 0.3.3-lp150.1.6
gom-devel(x86-64) = 0.3.3-lp150.1.6
pkgconfig(gom-1.0) = 0.3.3

Download

Type URL
Binary Package gom-devel-0.3.3-lp150.1.6.x86_64.rpm
Source Package gom-0.3.3-lp150.1.6.src.rpm

Install Howto

Install gom-devel rpm package:

# zypper install gom-devel

Files

Path
/usr/include/gom-1.0/
/usr/include/gom-1.0/gom/gom-adapter.h
/usr/include/gom-1.0/gom/gom-autocleanups.h
/usr/include/gom-1.0/gom/gom-command-builder.h
/usr/include/gom-1.0/gom/gom-command.h
/usr/include/gom-1.0/gom/gom-cursor.h
/usr/include/gom-1.0/gom/gom-error.h
/usr/include/gom-1.0/gom/gom-filter.h
/usr/include/gom-1.0/gom/gom-repository.h
/usr/include/gom-1.0/gom/gom-resource-group.h
/usr/include/gom-1.0/gom/gom-resource.h
/usr/include/gom-1.0/gom/gom-sorting.h
/usr/include/gom-1.0/gom/gom.h
/usr/lib64/libgom-1.0.so
/usr/lib64/pkgconfig/gom-1.0.pc
/usr/share/gir-1.0/Gom-1.0.gir

Changelog

2017-09-13 - dimstar@opensuse.org
- Split out python3-gom: the python/gi binding were wrongly
packaged as part of the -devel package.
- Run spec-cleaner: adds pkgconfig-BuildRequires.
2017-09-08 - jengelh@inai.de
- Update summaries an RPM groups. Trim non-telling parts of
descriptions.
2017-07-20 - zaitor@opensuse.org
- Temp disable meson_check while we figure out why it randomly
fails on x86_64.
2017-06-22 - zaitor@opensuse.org
- Update to version 0.3.3:
+ Replace hardcoded values in pkg-config file.
+ Add a JavaScript example.
+ Remove i18n support, as there are no user-visible strings.
+ Replace autotools build system with meson.
- Add meson BuildRequires and switch autotools macros configure,
make, make test and makeinstall to meson, meson_build, meson_test
and meson_install following upstream switch to Meson build
system.
- Add explicit python3-gobject BuildRequires to workaround
build-fail, upstream expects everyone to have moved to python3 as
default python.
- Drop intltool BuildRequires: No longer needed.
- Following the above, drop lang subpackage and macros handling
translations, and drop gom-lang Recommends and gom Provides from
libgom-1_0-0 subpackage. Add gom-lang Obsoletes to ease updates.
2015-12-27 - damjanovic.ivo@gmail.com
- Updated to version 0.3.2:
+ Add missing annotation for repository object.
+ Support ordering queries.
+ Add support for creating new tables in a version.
+ Fix memory leak in GomResource.
+ Bindings:
- Add missing annotation for repository object.
- Add a working Python example.
- Make ResourceGroup a sequence in Python bindings.
2015-04-29 - zaitor@opensuse.org
- Update to version 0.3.1:
+ Support g_autoptr() for all gom object types.
+ Add IS NULL and IS NOT NULL filters.
+ Add gom_resource_group_delete_[a]sync functions.
+ Fix crash on 64-bit systems with some compiler/compiler flags.
+ Fix saving a modified resource a second time.
+ Fix setting ID after calling gom_resource_group_write_*.
- Add a %check section and pass %{__make} test to it. Actually run
the already enabled tests. This adds quite a bit to build time,
but all testing we can get is good.
2015-02-17 - dimstar@opensuse.org
- Update to version 0.3.0:
+ Update COPYING to LGPL 2.1+ to match headers.
+ Add support for batched writes.
+ Support the GLOB operator.
+ Fix stacking of filters.
+ Fix possible crashes on exit.
+ Remove "adapter" property from GomResourceGroup.
+ Fix a bug in automatic migration.
+ Fix a number of bugs related to using GOM in bindings and in
multi-thread unsafe interpreters.
+ Make gdk-pixbuf an optional dependency.
2014-08-25 - zaitor@opensuse.org
- Initial packaging version 0.2.1

See Also

Package Description
gonvert-0.2.38-lp150.1.5.noarch.rpm Conversion utility that allows conversion between many units
goobox-3.4.2-lp150.1.8.x86_64.rpm CD Player and Ripper for GNOME
goobox-lang-3.4.2-lp150.1.8.noarch.rpm Translations for package goobox
goocanvas-devel-2.0.4-lp150.2.2.x86_64.rpm Development files for GooCanvas
goocanvas-lang-2.0.4-lp150.2.2.noarch.rpm Translations for package goocanvas
google-alegreya-fonts-1.003-lp150.1.4.noarch.rpm Serif Font for Literature
google-allerta-fonts-1.0-lp150.1.4.noarch.rpm Easily Readable Sans Serif Font
google-anonymouspro-fonts-1.002-lp150.1.4.noarch.rpm A Free Monospace Font
google-arimo-fonts-1.31.0-lp150.1.4.noarch.rpm Monospace Sans Serif Font
google-authenticator-libpam-1.03-lp150.1.6.x86_64.rpm Google Authenticator PAM module
google-authenticator-libpam-32bit-1.03-lp150.1.6.x86_64.rpm Google Authenticator PAM module
google-cabin-fonts-1.005-lp150.1.4.noarch.rpm Humanist Sans Serif Font
google-caladea-fonts-1.002-lp150.1.4.noarch.rpm Sans-serif Font Metrics-compatible with Cambria
google-cardo-fonts-1.04-lp150.1.4.noarch.rpm Serif Font for Classicists, Biblical Scholars, Medievalists, and Linguists
google-carlito-fonts-1.1.03.beta1-lp150.1.7.noarch.rpm Sans-serif Font Metrics-compatible with Calibri
Advertisement
Advertisement