gnuplot-5.2.2-lp150.2.21.x86_64.rpm


Advertisement

Description

gnuplot - Function Plotting Utility and more

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package name gnuplot
Package version 5.2.2
Package release lp150.2.21
Package architecture x86_64
Package type rpm
Installed size 3.80 MB
Download size 1.20 MB
Official Mirror widehat.opensuse.org
GNUplot is a command line driven interactive function plotting utility.
GNUplot supports many different types of terminals, plotters, and
printers (including many color devices and pseudodevices like LaTeX)
and can easily be extended to include new devices.

Alternatives

Package Version Architecture Repository
gnuplot-5.2.6-lp150.3.25.x86_64.rpm 5.2.6 x86_64 KDE Unstable
gnuplot-5.2.6-lp150.3.13.x86_64.rpm 5.2.6 x86_64 KDE 5
gnuplot - - -

Requires

Name Value
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.9)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Network.so.5()(64bit) -
libQt5Network.so.5(Qt_5)(64bit) -
libQt5PrintSupport.so.5()(64bit) -
libQt5PrintSupport.so.5(Qt_5)(64bit) -
libQt5Svg.so.5()(64bit) -
libQt5Svg.so.5(Qt_5)(64bit) -
libQt5Widgets.so.5()(64bit) -
libQt5Widgets.so.5(Qt_5)(64bit) -
libX11.so.6()(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libcaca.so.0()(64bit) -
libcairo.so.2()(64bit) -
libcerf.so.1()(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgd.so.3()(64bit) -
libgdk-x11-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgtk-x11-2.0.so.0()(64bit) -
liblua5.3.so.5()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libm.so.6(GLIBC_2.23)(64bit) -
libpango-1.0.so.0()(64bit) -
libpangocairo-1.0.so.0()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libreadline.so.7()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.8)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libwx_baseu-suse.so.3()(64bit) -
libwx_baseu-suse.so.3(WXU_3.0)(64bit) -
libwx_gtk2u_core-suse.so.3()(64bit) -
libwx_gtk2u_core-suse.so.3(WXU_3.0)(64bit) -

Provides

Name Value
gnuplot = 5.2.2-lp150.2.21
gnuplot(x86-64) = 5.2.2-lp150.2.21

Download

Type URL
Binary Package gnuplot-5.2.2-lp150.2.21.x86_64.rpm
Source Package gnuplot-5.2.2-lp150.2.21.src.rpm

Install Howto

Install gnuplot rpm package:

# zypper install gnuplot

Files

Path
/usr/bin/gnuplot
/usr/lib/gnuplot/
/usr/lib/gnuplot/5.2/gnuplot_qt
/usr/lib/gnuplot/5.2/gnuplot_x11
/usr/share/X11/app-defaults/Gnuplot
/usr/share/emacs/site-lisp/gnuplot-gui.el
/usr/share/emacs/site-lisp/gnuplot-gui.elc
/usr/share/emacs/site-lisp/gnuplot.el
/usr/share/emacs/site-lisp/gnuplot.elc
/usr/share/gnuplot/
/usr/share/gnuplot/5.2/colors_default.gp
/usr/share/gnuplot/5.2/colors_mono.gp
/usr/share/gnuplot/5.2/colors_podo.gp
/usr/share/gnuplot/5.2/gnuplot-fr.gih
/usr/share/gnuplot/5.2/gnuplot.gih
/usr/share/gnuplot/5.2/gnuplotrc
/usr/share/gnuplot/5.2/PostScript/8859-1.ps
/usr/share/gnuplot/5.2/PostScript/8859-15.ps
/usr/share/gnuplot/5.2/PostScript/8859-2.ps
/usr/share/gnuplot/5.2/PostScript/8859-9.ps
/usr/share/gnuplot/5.2/PostScript/aglfn.txt
/usr/share/gnuplot/5.2/PostScript/cp1250.ps
/usr/share/gnuplot/5.2/PostScript/cp1251.ps
/usr/share/gnuplot/5.2/PostScript/cp1252.ps
/usr/share/gnuplot/5.2/PostScript/cp437.ps
/usr/share/gnuplot/5.2/PostScript/cp850.ps
/usr/share/gnuplot/5.2/PostScript/cp852.ps
/usr/share/gnuplot/5.2/PostScript/koi8r.ps
/usr/share/gnuplot/5.2/PostScript/koi8u.ps
/usr/share/gnuplot/5.2/PostScript/prologue.ps
/usr/share/gnuplot/5.2/PostScript/utf-8.ps
/usr/share/gnuplot/5.2/js/README
/usr/share/gnuplot/5.2/js/canvasmath.js
/usr/share/gnuplot/5.2/js/canvastext.js
/usr/share/gnuplot/5.2/js/gnuplot_common.js
/usr/share/gnuplot/5.2/js/gnuplot_dashedlines.js
/usr/share/gnuplot/5.2/js/gnuplot_mouse.css
/usr/share/gnuplot/5.2/js/gnuplot_mouse.js
/usr/share/gnuplot/5.2/js/gnuplot_svg.js
/usr/share/gnuplot/5.2/js/grid.png
/usr/share/gnuplot/5.2/js/help.png
/usr/share/gnuplot/5.2/js/nextzoom.png
/usr/share/gnuplot/5.2/js/previouszoom.png
/usr/share/gnuplot/5.2/js/return.png
/usr/share/gnuplot/5.2/js/textzoom.png
/usr/share/gnuplot/5.2/lua/gnuplot-tikz.lua
/usr/share/gnuplot/5.2/qt/qtgnuplot_fr.qm
/usr/share/gnuplot/5.2/qt/qtgnuplot_ja.qm
/usr/share/texmf/tex/latex/gnuplot/gnuplot-lua-tikz-common.tex
/usr/share/texmf/tex/latex/gnuplot/gnuplot-lua-tikz.sty
/usr/share/texmf/tex/latex/gnuplot/gnuplot-lua-tikz.tex
/usr/share/texmf/tex/latex/gnuplot/gnuplot.cfg
/usr/share/texmf/tex/latex/gnuplot/t-gnuplot-lua-tikz.tex

Changelog

2018-02-15 - werner@suse.de
- Do not miss gpic and mif
- Even if pulled by other packages do explicite require for the build
* pkgconfig(freetype2)
* pkgconfig(libjpeg)
* pkgconfig(libpng16)
2018-02-12 - crrodriguez@opensuse.org
- Do not use xorg-x11-* as buildrequires
- Fix broken GD libs detection (gnuplot-gd.patch)
- Remove unneeded buildrequires.
2017-11-16 - werner@suse.de
- Update to gnuplot 5.2.2
* NEW splot ... with lines title at {beg|end}
* FIX allow mixed use of in-key plot titles and manually placed titles
* FIX prevent runaway iterations of the form   plot for [i=start:*] ...
* FIX handle in-line range limits for linked or nonlinear axes
* FIX restore pre-5.2 interpretation of logscaled tic increment as a multiplier
* FIX logscale tic placement is closer to that of versions before 5.2.0
* FIX recheck inrange/outrange points after spline or bezier smoothing
* FIX sampling on x2 if linked to x1;  e.g. plot sample [t=1:5:1] '+' axes x2y1
* FIX empty range on logscale y axis is handled by auto-extending the range
* FIX autoscaling xrange of stacked histograms
- Add now missed TEXDIR at configure time which now includes also
the sub path tex/latex/gnuplot/ below /usr/share/texmf/ (could
become removed with some of the next version updates?)
2017-11-08 - nico.kruber@gmail.com
- Update to gnuplot 5.2.1
* NEW set table separator {tab|comma|"char"} allows creation of csv files
* NEW hotkey for changing azimuth in 3D plots with mousing
* NEW titles for "splot .. with lines" can be placed at {beg|end} of plotted line
* NEW Rework gstrptime() to handle relative time formats tH tM tS
* NEW command 'set rgbmax <value>' controls interpretation of input RGB values
* CHANGE restore pre-5.2 interpretation of logscaled tic increment as a multiplier
* CHANGE allow mixed use of in-key plot titles and manually placed titles
* FIX autoscaling of plots with spline or bezier smoothing
* FIX autoscaling of plots with linked axes where data is plotted on x2 or y2
* FIX "with filledcurves below y=foo" mishandled the case of y value exactly = foo
* FIX [windows] repair breakage of stderr/stdout redirection to console
* FIX postscript terminal artifacts when drawing dot/dash circles
* FIX handle empty range on logscale y axis as a warning, not an error
2017-09-29 - werner@suse.de
- Add patch gnuplot-5.2.0-texi2info.patch as source to be avble
to patch the resulting gnuplot.texi
- Modify patches
* gnuplot-4.4.0-x11ovf.dif
* gnuplot-4.6.0-demo.diff
* gnuplot-4.6.0-fonts.diff
* gnuplot-4.6.0.dif
* gnuplot-QtCore-PIC.dif
* gnuplot-wx3.diff

See Also

Package Description
gnuplot-doc-5.2.2-lp150.2.21.noarch.rpm Documentation of GNUplot
gnuradio-3.7.12.0-lp150.1.9.x86_64.rpm GNU software radio
gnuradio-devel-3.7.12.0-lp150.1.9.x86_64.rpm Deveopment files for GNU Radio
gnuradio-doc-3.7.12.0-lp150.1.9.noarch.rpm GNU Radio documentation
gnuradio-examples-3.7.12.0-lp150.1.9.x86_64.rpm GNU Radio examples
gnuradio-examples-wxgui-3.7.12.0-lp150.1.9.x86_64.rpm GNU Radio wxgui examples
gnuradio-wxgui-3.7.12.0-lp150.1.9.x86_64.rpm Libraries for GNU Radio
gnuserv-3.12.6-lp150.3.1.x86_64.rpm Server and Clients for Emacs
gnusocialshell-1.2.0-lp150.1.4.x86_64.rpm Text-based GNU social client
gnustep-base-1.25.1-lp150.1.4.x86_64.rpm GNUstep Base library package
gnustep-base-devel-1.25.1-lp150.1.4.x86_64.rpm Devel package for the GNUstep Base Library
gnustep-make-2.7.0-lp150.1.4.x86_64.rpm GNUstep Makefile package
gnutls-3.6.2-lp150.3.2.x86_64.rpm The GNU Transport Layer Security Library
gnutls-guile-3.6.2-lp150.3.2.x86_64.rpm Guile wrappers for gnutls
go-1.9.4-lp150.1.1.x86_64.rpm A compiled, garbage-collected, concurrent programming language
Advertisement
Advertisement