gnome-software-3.26.7-lp150.4.1.x86_64.rpm


Advertisement

Description

gnome-software - GNOME Software Store

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package name gnome-software
Package version 3.26.7
Package release lp150.4.1
Package architecture x86_64
Package type rpm
Installed size 5.07 MB
Download size 3.11 MB
Official Mirror widehat.opensuse.org
AppStore like management of Applications for your GNOME Desktop.

Alternatives

Package Version Architecture Repository
gnome-software - - -

Requires

Name Value
fwupd -
iso-codes -
libappstream-glib.so.8()(64bit) -
libatk-1.0.so.0()(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libcairo.so.2()(64bit) -
libflatpak.so.0()(64bit) -
libfwupd.so.2()(64bit) -
libfwupd.so.2(LIBFWUPD_0.1.1)(64bit) -
libfwupd.so.2(LIBFWUPD_0.7.0)(64bit) -
libfwupd.so.2(LIBFWUPD_0.7.3)(64bit) -
libfwupd.so.2(LIBFWUPD_0.9.2)(64bit) -
libfwupd.so.2(LIBFWUPD_0.9.3)(64bit) -
libfwupd.so.2(LIBFWUPD_0.9.4)(64bit) -
libfwupd.so.2(LIBFWUPD_0.9.5)(64bit) -
libfwupd.so.2(LIBFWUPD_0.9.6)(64bit) -
libfwupd.so.2(LIBFWUPD_0.9.7)(64bit) -
libfwupd.so.2(LIBFWUPD_0.9.8)(64bit) -
libfwupd.so.2(LIBFWUPD_1.0.0)(64bit) -
libfwupd.so.2(LIBFWUPD_1.0.3)(64bit) -
libgdk-3.so.0()(64bit) -
libgdk_pixbuf-2.0.so.0()(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgmodule-2.0.so.0()(64bit) -
libgnome-desktop-3.so.12()(64bit) -
libgobject-2.0.so.0()(64bit) -
libgtk-3.so.0()(64bit) -
libgtkspell3-3.so.0()(64bit) -
libgudev-1.0.so.0()(64bit) -
libjson-glib-1.0.so.0()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libostree-1.so.1()(64bit) -
libostree-1.so.1(LIBOSTREE_2016.3)(64bit) -
libpackagekit-glib2.so.18()(64bit) -
libpango-1.0.so.0()(64bit) -
libpolkit-gobject-1.so.0()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
librpm.so.8()(64bit) -
libsecret-1.so.0()(64bit) -
libsoup-2.4.so.1()(64bit) -
libzypp-plugin-appdata -

Provides

Name Value
application() -
application(org.gnome.Software.Editor.desktop) -
application(org.gnome.Software.desktop) -
gnome-software = 3.26.7-lp150.4.1
gnome-software(x86-64) = 3.26.7-lp150.4.1
libgs_plugin_appstream.so()(64bit) -
libgs_plugin_desktop-categories.so()(64bit) -
libgs_plugin_desktop-menu-path.so()(64bit) -
libgs_plugin_dpkg.so()(64bit) -
libgs_plugin_dummy.so()(64bit) -
libgs_plugin_epiphany.so()(64bit) -
libgs_plugin_fedora-pkgdb-collections.so()(64bit) -
libgs_plugin_flatpak.so()(64bit) -
libgs_plugin_fwupd.so()(64bit) -
libgs_plugin_generic-updates.so()(64bit) -
libgs_plugin_hardcoded-blacklist.so()(64bit) -
libgs_plugin_hardcoded-featured.so()(64bit) -
libgs_plugin_hardcoded-popular.so()(64bit) -
libgs_plugin_icons.so()(64bit) -
libgs_plugin_key-colors-metadata.so()(64bit) -
libgs_plugin_key-colors.so()(64bit) -
libgs_plugin_modalias.so()(64bit) -
libgs_plugin_odrs.so()(64bit) -
libgs_plugin_os-release.so()(64bit) -
libgs_plugin_ostree.so()(64bit) -
libgs_plugin_packagekit-history.so()(64bit) -
libgs_plugin_packagekit-local.so()(64bit) -
libgs_plugin_packagekit-offline.so()(64bit) -
libgs_plugin_packagekit-proxy.so()(64bit) -
libgs_plugin_packagekit-refine.so()(64bit) -
libgs_plugin_packagekit-refresh.so()(64bit) -
libgs_plugin_packagekit-upgrade.so()(64bit) -
libgs_plugin_packagekit.so()(64bit) -
libgs_plugin_provenance-license.so()(64bit) -
libgs_plugin_provenance.so()(64bit) -
libgs_plugin_repos.so()(64bit) -
libgs_plugin_rewrite-resource.so()(64bit) -
libgs_plugin_rpm.so()(64bit) -
libgs_plugin_shell-extensions.so()(64bit) -
libgs_plugin_steam.so()(64bit) -
libgs_plugin_systemd-updates.so()(64bit) -
metainfo() -
metainfo(org.gnome.Software.Plugin.Epiphany.metainfo.xml) -
metainfo(org.gnome.Software.Plugin.Flatpak.metainfo.xml) -
metainfo(org.gnome.Software.Plugin.Fwupd.metainfo.xml) -
metainfo(org.gnome.Software.Plugin.Odrs.metainfo.xml) -
metainfo(org.gnome.Software.Plugin.Steam.metainfo.xml) -
metainfo(org.gnome.Software.appdata.xml) -
mimehandler(x-scheme-handler/appstream) -
mimehandler(x-scheme-handler/apt) -
mimehandler(x-scheme-handler/snap) -

Download

Type URL
Binary Package gnome-software-3.26.7-lp150.4.1.x86_64.rpm
Source Package gnome-software-3.26.7-lp150.4.1.src.rpm

Install Howto

Install gnome-software rpm package:

# zypper install gnome-software

Files

Path
/etc/xdg/autostart/gnome-software-service.desktop
/usr/bin/gnome-software
/usr/bin/gnome-software-editor
/usr/lib/gnome-software-cmd
/usr/lib/gnome-software-restarter
/usr/lib64/gs-plugins-11/libgs_plugin_appstream.so
/usr/lib64/gs-plugins-11/libgs_plugin_desktop-categories.so
/usr/lib64/gs-plugins-11/libgs_plugin_desktop-menu-path.so
/usr/lib64/gs-plugins-11/libgs_plugin_dpkg.so
/usr/lib64/gs-plugins-11/libgs_plugin_dummy.so
/usr/lib64/gs-plugins-11/libgs_plugin_epiphany.so
/usr/lib64/gs-plugins-11/libgs_plugin_fedora-pkgdb-collections.so
/usr/lib64/gs-plugins-11/libgs_plugin_flatpak.so
/usr/lib64/gs-plugins-11/libgs_plugin_fwupd.so
/usr/lib64/gs-plugins-11/libgs_plugin_generic-updates.so
/usr/lib64/gs-plugins-11/libgs_plugin_hardcoded-blacklist.so
/usr/lib64/gs-plugins-11/libgs_plugin_hardcoded-featured.so
/usr/lib64/gs-plugins-11/libgs_plugin_hardcoded-popular.so
/usr/lib64/gs-plugins-11/libgs_plugin_icons.so
/usr/lib64/gs-plugins-11/libgs_plugin_key-colors-metadata.so
/usr/lib64/gs-plugins-11/libgs_plugin_key-colors.so
/usr/lib64/gs-plugins-11/libgs_plugin_modalias.so
/usr/lib64/gs-plugins-11/libgs_plugin_odrs.so
/usr/lib64/gs-plugins-11/libgs_plugin_os-release.so
/usr/lib64/gs-plugins-11/libgs_plugin_ostree.so
/usr/lib64/gs-plugins-11/libgs_plugin_packagekit-history.so
/usr/lib64/gs-plugins-11/libgs_plugin_packagekit-local.so
/usr/lib64/gs-plugins-11/libgs_plugin_packagekit-offline.so
/usr/lib64/gs-plugins-11/libgs_plugin_packagekit-proxy.so
/usr/lib64/gs-plugins-11/libgs_plugin_packagekit-refine.so
/usr/lib64/gs-plugins-11/libgs_plugin_packagekit-refresh.so
/usr/lib64/gs-plugins-11/libgs_plugin_packagekit-upgrade.so
/usr/lib64/gs-plugins-11/libgs_plugin_packagekit.so
/usr/lib64/gs-plugins-11/libgs_plugin_provenance-license.so
/usr/lib64/gs-plugins-11/libgs_plugin_provenance.so
/usr/lib64/gs-plugins-11/libgs_plugin_repos.so
/usr/lib64/gs-plugins-11/libgs_plugin_rewrite-resource.so
/usr/lib64/gs-plugins-11/libgs_plugin_rpm.so
/usr/lib64/gs-plugins-11/libgs_plugin_shell-extensions.so
/usr/lib64/gs-plugins-11/libgs_plugin_steam.so
/usr/lib64/gs-plugins-11/libgs_plugin_systemd-updates.so
/usr/share/app-info/
/usr/share/app-info/xmls/org.gnome.Software.Featured.xml
/usr/share/applications/org.gnome.Software.Editor.desktop
/usr/share/applications/org.gnome.Software.desktop
/usr/share/dbus-1/services/org.freedesktop.PackageKit.service
/usr/share/dbus-1/services/org.gnome.Software.service
/usr/share/glib-2.0/schemas/org.gnome.software.gschema.xml
/usr/share/gnome-shell/
/usr/share/gnome-shell/search-providers/org.gnome.Software-search-provider.ini
/usr/share/gnome-software/featured-ardour-bg.png
/usr/share/gnome-software/featured-ardour.png
/usr/share/gnome-software/featured-blender.png
/usr/share/gnome-software/featured-builder-bg.jpg
/usr/share/gnome-software/featured-builder.png
/usr/share/gnome-software/featured-chess.png
/usr/share/gnome-software/featured-firefox.png
/usr/share/gnome-software/featured-gimp.png
/usr/share/gnome-software/featured-gnome-sudoku.png
/usr/share/gnome-software/featured-inkscape.svg
/usr/share/gnome-software/featured-maps-bg.png
/usr/share/gnome-software/featured-maps.png
/usr/share/gnome-software/featured-mypaint.png
/usr/share/gnome-software/featured-polari.svg
/usr/share/gnome-software/featured-transmission.png
/usr/share/gnome-software/featured-weather-bg.png
/usr/share/gnome-software/featured-weather.png
/usr/share/gnome-software/upgrade-bg.png
/usr/share/icons/hicolor/16x16/apps/org.gnome.Software.png
/usr/share/icons/hicolor/22x22/apps/org.gnome.Software.png
/usr/share/icons/hicolor/24x24/apps/org.gnome.Software.png
/usr/share/icons/hicolor/256x256/apps/org.gnome.Software.png
/usr/share/icons/hicolor/32x32/apps/org.gnome.Software.png
/usr/share/icons/hicolor/48x48/apps/org.gnome.Software.png
/usr/share/icons/hicolor/scalable/apps/org.gnome.Software-symbolic.svg
/usr/share/icons/hicolor/scalable/apps/software-installed-symbolic.svg
/usr/share/licenses/gnome-software/COPYING
/usr/share/man/man1/gnome-software-editor.1.gz
/usr/share/man/man1/gnome-software.1.gz
/usr/share/metainfo/org.gnome.Software.Plugin.Epiphany.metainfo.xml
/usr/share/metainfo/org.gnome.Software.Plugin.Flatpak.metainfo.xml
/usr/share/metainfo/org.gnome.Software.Plugin.Fwupd.metainfo.xml
/usr/share/metainfo/org.gnome.Software.Plugin.Odrs.metainfo.xml
/usr/share/metainfo/org.gnome.Software.Plugin.Steam.metainfo.xml
/usr/share/metainfo/org.gnome.Software.appdata.xml

Changelog

2018-04-20 - lnussel@suse.de
- require fwupd, gnome-software doesn't work without (boo#1090042)
2018-04-19 - sckang@suse.com
- Mark gnome-software-launch-gpk-update-viewer-for-updates.patch
as PATCH-FIX-OPENSUSE, as Leap 15 need it as well (boo#1090042).
2018-03-13 - sckang@suse.com
- Add gnome-software-launch-gpk-update-viewer-for-updates.patch:
Don't launch gnome-software when clicking the updates
notification. Launch gpk-update-viewer instead (bsc#1077332).
2018-03-02 - bjorn.lie@gmail.com
- Update to version 3.26.7:
+ Use less space on low resolution displays.
+ Hide invalid apps we don't know how to install.
+ Rate limit distro upgrade notifications once per week.
+ Make category name sorting case insensitive.
+ Add back install buttons to codec install view.
+ Update flatpak remote metadata when refreshing.
+ Remove fedora-tagger-usage plugin.
+ Various correctness and warning fixes.
+ Various fixes to the external appstream plugin.
+ Various fixes to the snap plugin.
+ Updated translations.
2018-02-08 - bjorn.lie@gmail.com
- Update to version 3.26.6:
+ Improve alignment on the updates page.
+ Do not show missing screenshot error for fonts that have
screenshots.
+ Fixes for third party repository handling in the sources
dialog.
+ Fix various issues on Ubuntu when purchasing apps.
+ Fix building with gtkspell support.
+ Fix an issue that led to duplicate categories appearing on the
overview page.
+ Various memory leak and correctness fixes.
+ Show package descriptions when installing packages through the
dbus API.
+ Revert a commit that broke repo package install.
+ Updated translations.
- Pass enable-gtkspell=true to meson, ensure we build gtkspell
support.
2018-01-19 - bjorn.lie@gmail.com
- Update to version 3.26.5:
+ Add missing locking to gs_plugin_cache_remove(), fixing a
possible crash.
+ Fix various memory leaks spotted by valgrind.
+ Fix a possible crash triggered by the fwupd plugin.
+ Do not emit critical warnings when reviewing OS Updates.
+ fwupd: Use the custom user-agent when downloading firmware.
+ overview page: Fix a crash when we have no featured apps.
+ packagekit: Implement repository enabling.
+ Fix hover CSS for "unknown" and "nonfree" license buttons.
+ Updated translations.
2018-01-08 - zaitor@opensuse.org
- Update to version 3.26.4:
+ Fix crashes in the repos plugin due to missing locking.
+ Work around Firefox deleting rpm/deb files downloaded to /tmp
when closing.
+ Do not require the user to keep clicking 'More reviews' after
each click.
+ Fix a critical when updating (flatpak) packages live.
+ fwupd: Prepend the vendor name to the device name if not
included.
+ Improve SPDX ID parsing when working out if it is 'free'.
+ packagekit: Do not crash when getting an invalid ID from
PackageKit.
+ Do not crash when closing the source dialog while it is
loading.
+ Updated translations.
- Drop gs-add-locking-to-the-repos-plugin.patch: Fixed upstream.
2017-11-26 - zaitor@opensuse.org
- Add gs-add-locking-to-the-repos-plugin.patch: Add locking to the
repos plugin so that we don't modify the priv->urls hash table
concurrently from multiple threads (rh#1516536).
- Run spec-cleaner, modernize spec, use autosetup macro, no longer
rm la files, not needed as we are using meson buildsystem.
- Drop update-desktop-files BuildRequires and no longer use
suse_update_desktop_file macro, no longer needed.
- Explicitly pass enable-ubuntuone=false to meson.

See Also

Package Description
gnome-software-devel-3.26.7-lp150.4.1.x86_64.rpm Development files for the GNOME software store
gnome-software-lang-3.26.7-lp150.4.1.noarch.rpm Translations for package gnome-software
gnome-sound-recorder-3.24.0.1-lp150.1.6.noarch.rpm Sound Recorder
gnome-sound-recorder-lang-3.24.0.1-lp150.1.6.noarch.rpm Translations for package gnome-sound-recorder
gnome-subtitles-1.3-lp150.1.6.x86_64.rpm Subtitle editor for GNOME
gnome-subtitles-lang-1.3-lp150.1.6.noarch.rpm Translations for package gnome-subtitles
gnome-sudoku-3.26.0-lp150.1.7.x86_64.rpm Sudoku Game for GNOME
gnome-sudoku-lang-3.26.0-lp150.1.7.noarch.rpm Translations for package gnome-sudoku
gnome-system-monitor-3.26.0-lp150.5.5.x86_64.rpm A process monitor for the GNOME desktop
gnome-system-monitor-lang-3.26.0-lp150.5.5.noarch.rpm Translations for package gnome-system-monitor
gnome-taquin-3.28.0-lp150.1.1.x86_64.rpm A computer version of the 15-puzzle and other sliding puzzles
gnome-taquin-lang-3.28.0-lp150.1.1.noarch.rpm Translations for package gnome-taquin
gnome-terminal-3.26.2-lp150.2.9.x86_64.rpm GNOME Terminal
gnome-terminal-lang-3.26.2-lp150.2.9.noarch.rpm Translations for package gnome-terminal
gnome-tetravex-3.22.0-lp150.2.2.x86_64.rpm Tetravex Game for GNOME
Advertisement
Advertisement