gnome-common-3.18.0-lp150.1.7.noarch.rpm


Advertisement

Description

gnome-common - Common Files to Build GNOME

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package name gnome-common
Package version 3.18.0
Package release lp150.1.7
Package architecture noarch
Package type rpm
Installed size 505.59 KB
Download size 114.87 KB
Official Mirror widehat.opensuse.org
Gnome-common includes files used by to build GNOME and GNOME applications.

Alternatives

Package Version Architecture Repository
gnome-common - - -

Requires

Name Value
autoconf -
autoconf-archive >= 2014.10.15
automake -
gettext-tools -
glib2-devel -
gtk-doc -
intltool -
libtool -
pkg-config -
yelp-tools -

Provides

Name Value
gnome-common = 3.18.0-lp150.1.7

Download

Type URL
Binary Package gnome-common-3.18.0-lp150.1.7.noarch.rpm
Source Package gnome-common-3.18.0-lp150.1.7.src.rpm

Install Howto

Install gnome-common rpm package:

# zypper install gnome-common

Files

Path
/usr/bin/gnome-autogen.sh
/usr/share/aclocal/gnome-code-coverage.m4
/usr/share/aclocal/gnome-common.m4
/usr/share/aclocal/gnome-compiler-flags.m4
/usr/share/doc/packages/gnome-common/ChangeLog

Changelog

2016-05-02 - mgorse@suse.com
- Update to GNOME 3.20  Fate#318572
2015-09-22 - dimstar@opensuse.org
- Update to version 3.18.0:
+ Bugs fixed: bgo#747920, bgo#748394, bgo#729406, bgo#729407,
bgo#741891, bgo#741558, bgo#729931, bgo#735416.
- Drop pgnome-doc-utils-devel BuildRequires: no longer needed.
2014-11-05 - dimstar@opensuse.org
- Add autoconf-archive Requires: the files ax_check_enable_debug.m4
and ax_code_coverage.m4 are now shipped by ac-archive and from
a GNOME perspective, those two files are mandatory to be present
for a bootstrap.
- Remove ax_check_enable_debug.m4 and ax_code_coverage.m4 from
gnome-common installation.
2014-09-22 - zaitor@opensuse.org
- Update to version 3.14.0:
+ macros2:
- Update links to macros in the autoconf-archive.
- Add support for APPSTREAM_XML macro (bgo#736497).
- Deprecate various obsolete macros.
+ build: Remove a non-existent file from EXTRA_DIST (bgo#735418).
+ compiler-flags: allow suppressing warnings.
+ code-coverage: Support lcov 1.11.
+ doc: Move doc/usage.txt to README and update.
+ make program_VERSION a local variable.
2014-03-24 - dimstar@opensuse.org
- Update to version 3.12.0:
+ Read the dirlist file unconditionally.
+ compiler-flags: Replace deprecated AC_HELP_STRING with
AS_HELP_STRING.
+ gnome-autogen.sh: Check for appdata-xml.m4 with APPDATA_XML.
+ Bugs fixed: bgo#726208, bgo#726892.
2013-11-23 - dimstar@opensuse.org
- Replace gnome-doc-utils Requires with gnome-doc-utils-devel:
gnome-autogen.sh wants gnome-doc-prepare to be present, which is
in gnome-doc-utils-devel.
2013-09-23 - dimstar@opensuse.org
- Update to version 3.10.0:
+ compiler-flags:
- Add a #serial line (bgo#707475).
- Add an optional second argument for custom warnings
(bgo#707475).
+ Run intltool before autoreconf so intltool.m4 is picked up by
aclocal (bgo#705365).
+ gnome-autogen.sh:
- run glib-gettexize if using GLib gettext.
- Check only for autoreconf; autoconf, automake, libtool,
gettext are already checked by autoreconf.
- Do not use sed to get the AC_CONFIG_MACRO_DIR directory.
- Create m4 directory if it doesnt exits.
- Add support for automake 1.14.
+ Add support for lcov 1.10.
+ Other bugs fixed: bgo#699943
2013-01-15 - dimstar@opensuse.org
- Update to version 3.7.4:
+ code coverage:
- Quiet lcov and add extra ignore patterns
- Relicense to LGPL-2.1+
+ Add more warnings to the default GNOME_COMPILE_WARNINGS
+ Add support for automake 1.13.
+ Finally and completely specify GPL-2.0+ as the license for
gnome-common (as a collection of GPL-2.0+ and LGPL-2.1+ files).
NOTE: the .spec file already used the previous assumption of
GPL-2.0+ being the right license.
2012-10-16 - dimstar@opensuse.org
- Update to version 3.6.0:
+ Add missing semicolons to omf_timestamp rule (bgo#685388).
2012-09-09 - zaitor@opensuse.org
- Update to version 3.5.91:
+ Add code coverage support (bgo#606720).

See Also

Package Description
gnome-contacts-3.26.1-lp150.1.8.x86_64.rpm Contacts Manager for GNOME
gnome-contacts-lang-3.26.1-lp150.1.8.noarch.rpm Translations for package gnome-contacts
gnome-control-center-3.26.2-lp150.4.1.x86_64.rpm The GNOME Control Center
gnome-control-center-color-3.26.2-lp150.4.1.x86_64.rpm Configuration panel for color management
gnome-control-center-devel-3.26.2-lp150.4.1.x86_64.rpm Header files for the GNOME Control Center
gnome-control-center-goa-3.26.2-lp150.4.1.x86_64.rpm Configuration panel for online accounts
gnome-control-center-lang-3.26.2-lp150.4.1.noarch.rpm Translations for package gnome-control-center
gnome-control-center-user-faces-3.26.2-lp150.4.1.x86_64.rpm Login manager user avatars
gnome-desktop-lang-3.26.2-lp150.2.2.noarch.rpm Translations for package gnome-desktop
gnome-desktop-sharp2-2.26.0-lp150.1.3.x86_64.rpm Mono bindings for libgnome-desktop
gnome-desktop-sharp2-devel-2.26.0-lp150.1.3.x86_64.rpm Development files for gnome-desktop-sharp2
gnome-desktop2-2.32.1-lp150.2.1.x86_64.rpm The GNOME Desktop API Library
gnome-desktop2-lang-2.32.1-lp150.2.1.noarch.rpm Translations for package gnome-desktop2
gnome-devel-docs-3.26.0-lp150.2.1.noarch.rpm GNOME Platform Documentation
gnome-devel-docs-lang-3.26.0-lp150.2.1.noarch.rpm Translations for package gnome-devel-docs
Advertisement
Advertisement