glfw2-devel-2.7.6-lp150.1.3.x86_64.rpm


Advertisement

Description

glfw2-devel - Portable framework for OpenGL application development

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Oss all
Package name glfw2-devel
Package version 2.7.6
Package release lp150.1.3
Package architecture x86_64
Package type rpm
Installed size 79.35 KB
Download size 29.89 KB
Official Mirror widehat.opensuse.org
GLFW is a free, Open Source, portable framework for OpenGL application
development. In short, it is a single library providing a powerful,
portable API for otherwise operating system specific tasks such as opening
an OpenGL window, and reading keyboard, time, mouse and joystick input.

Alternatives

Package Version Architecture Repository
glfw2-devel-2.7.6-lp150.3.5.x86_64.rpm 2.7.6 x86_64 Games
glfw2-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libglfw2 = 2.7.6
pkgconfig(gl) -
pkgconfig(x11) -
pkgconfig(xrandr) -

Provides

Name Value
glfw2-devel = 2.7.6-lp150.1.3
glfw2-devel(x86-64) = 2.7.6-lp150.1.3
pkgconfig(libglfw) = 2.7.4

Download

Type URL
Binary Package glfw2-devel-2.7.6-lp150.1.3.x86_64.rpm
Source Package glfw2-2.7.6-lp150.1.3.src.rpm

Install Howto

Install glfw2-devel rpm package:

# zypper install glfw2-devel

Files

Path
/usr/include/GL/glfw.h
/usr/lib64/glfw2/libglfw.so
/usr/lib64/pkgconfig/libglfw.pc
/usr/share/doc/packages/glfw2-devel/readme.html

Changelog

2015-03-12 - lnussel@suse.de
- revive 2.7.6 as glfw2 package
- add soname to shared library (glfw-2.7.6-soname.diff)
- drop static lib
- move .so to subdir to avoid conflict with libglfw3
2013-10-08 - lnussel@suse.de
- install COPYING.txt as well
2012-09-25 - adam@mizerski.pl
- update to 2.7.6
- spec improvement and cleanup
- updated license information
- changed "BuildRequires: package-name" into
"BuildRequires: pkgconfig(name)" (fixes Factory build)
- dropped glfw-force_sysctl_support.patch
- dropped glfw-rpmlintrc - there was nothing useful
2012-03-24 - jengelh@medozas.de
- Parallel build with %_smp_mflags; strip redundant spec sections
2011-11-07 - pascal.bleser@opensuse.org
- update to 2.7.2
- package shlib too
- shared library naming policy
- static lib moved to libglfw-devel-static
2007-06-14 - prusnak@suse.cz
- initial version (2.5.0)

See Also

Package Description
glib-networking-2.54.1-lp150.1.3.x86_64.rpm Network-related GIO modules for glib
glib-networking-32bit-2.54.1-lp150.1.3.x86_64.rpm Network-related GIO modules for glib
glib-networking-lang-2.54.1-lp150.1.3.noarch.rpm Translations for package glib-networking
glib-sharp2-2.12.41-lp150.1.3.x86_64.rpm Mono bindings for glib
glib-sharp3-2.99.4-lp150.1.4.x86_64.rpm Mono bindings for glib
glib2-devel-2.54.3-lp150.2.6.x86_64.rpm Development files for glib, a general-purpose utility library
glib2-devel-32bit-2.54.3-lp150.2.6.x86_64.rpm Development files for glib, a general-purpose utility library
glib2-devel-static-2.54.3-lp150.2.6.x86_64.rpm Static libraries for glib, a general-purpose utility library
glib2-lang-2.54.3-lp150.2.6.noarch.rpm Translations for package glib2
glib2-tools-2.54.3-lp150.2.6.x86_64.rpm Tools from glib2, a general-purpose utility library
glib2-tools-32bit-2.54.3-lp150.2.6.x86_64.rpm Tools from glib2, a general-purpose utility library
glibc-2.26-lp150.10.13.x86_64.rpm Standard Shared Libraries (from the GNU C Library)
glibc-32bit-2.26-lp150.10.13.x86_64.rpm Standard Shared Libraries (from the GNU C Library)
glibc-devel-2.26-lp150.10.13.x86_64.rpm Include Files and Libraries Mandatory for Development
glibc-devel-32bit-2.26-lp150.10.13.x86_64.rpm Include Files and Libraries Mandatory for Development
Advertisement
Advertisement