ipvsadm-1.29-lp150.340.1.x86_64.rpm


Advertisement

Description

ipvsadm - A Utility for Administering the Linux Virtual Server

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Network Utilities all
Package name ipvsadm
Package version 1.29
Package release lp150.340.1
Package architecture x86_64
Package type rpm
Installed size 72.98 KB
Download size 47.40 KB
Official Mirror ftp.gwdg.de
ipvsadm is a utility for administering the IP virtual server services
offered by the Linux kernel with Linux Virtual Server support.

Alternatives

Package Version Architecture Repository
ipvsadm-1.29-lp150.2.5.x86_64.rpm 1.29 x86_64 openSUSE Oss
ipvsadm - - -

Requires

Name Value
/bin/bash -
coreutils -
diffutils -
fillup -
grep -
libc.so.6(GLIBC_2.7)(64bit) -
libnl-3.so.200()(64bit) -
libnl-3.so.200(libnl_3)(64bit) -
libnl-genl-3.so.200()(64bit) -
libnl-genl-3.so.200(libnl_3)(64bit) -
libpopt.so.0()(64bit) -
libpopt.so.0(LIBPOPT_0)(64bit) -
systemd -

Provides

Name Value
config(ipvsadm) = 1.29-lp150.340.1
ipvsadm = 1.29-lp150.340.1
ipvsadm(x86-64) = 1.29-lp150.340.1
ipvsadm-1.29 -

Download

Type URL
Binary Package ipvsadm-1.29-lp150.340.1.x86_64.rpm
Source Package ipvsadm-1.29-lp150.340.1.src.rpm

Install Howto

  1. Add the openSUSE Network Utilities repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/network:/utilities/openSUSE_Leap_15.0/ opensuse-network-utilities
  2. Install ipvsadm rpm package:
    # zypper install ipvsadm

Files

Path
/etc/ipvsadm.rules
/sbin/ipvsadm
/sbin/ipvsadm-restore
/sbin/ipvsadm-save
/usr/lib/systemd/system/ipvsadm.service
/usr/sbin/rcipvsadm
/usr/share/doc/packages/ipvsadm/README
/usr/share/fillup-templates/sysconfig.ipvsadm
/usr/share/man/man8/ipvsadm-restore.8.gz
/usr/share/man/man8/ipvsadm-save.8.gz
/usr/share/man/man8/ipvsadm.8.gz

Changelog

2017-11-23 - rbrown@suse.com
- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)
2017-01-05 - p.drouand@gmail.com
- Update to version 1.29
* No changelog available
2016-12-20 - mt@suse.de
- fixed systemd service file to restore correct config file at
start (/etc/ipvsadm.rules) and do not break boot-time config
at stop (bsc#1013581).
2015-12-01 - p.drouand@gmail.com
- Update to version 1.28
* No changelog available
- Update download Url
- Remove obsolete patches
* 03_libnl-3-linking.patch
* ipvsadm-1.26-ipvs_dests_parse_cb-memory-corruption.diff
* ipvsadm-1.26-wrong-error-with--ops-option.bnc847005.diff
- Update ipvsadm-1.26-print_largenum.diff > ipvsadm-print_largenum.diff
2014-05-28 - crrodriguez@opensuse.org
- 03_libnl-3-linking.patch from debian, allow use of libnl3
instead of libnl1
2014-05-21 - jsegitz@novell.com
- added necessary macros for systemd files
2014-02-13 - mt@suse.de
- Fix segfault when running 'ipvsadm -Ln' caused by buffer overrun
in ipvs_dests_parse_cb() function (bnc#775051), by Tim Serong.
[+ ipvsadm-1.26-ipvs_dests_parse_cb-memory-corruption.diff]
- Fix wrong error message when using ipvsadm with option "--ops"
(bnc#847005), by Paul Zirnik.
[+ ipvsadm-1.26-wrong-error-with--ops-option.bnc847005.diff]
2013-10-28 - p.drouand@gmail.com
- Add systemd support and drop sysvinit support
- Remove AUTHORS section
- Remove redundant %clean section
2011-09-16 - jengelh@medozas.de
- Select libnl-1_1-devel
2011-02-08 - mt@suse.de
- Updated to ipvsadm-1.26 (for kernel 2.6.28-rc3 or later)
adding IPv6 support, netlink interface and code cleanups.
- Adopted patches and spec file, switched to use new netlink
interface and popt (getopt support dropped).
- Fixed rpmlint warnings in the init script and spec file.

See Also

Package Description
jig-1.0-lp150.1.1.noarch.rpm Console based Jabber Client
jigdo-0.7.3-lp150.17.1.x86_64.rpm Jigsaw Download
jwhois-4.0-lp150.1.1.x86_64.rpm Alternative whois client
kismet-2016_07_R1-lp150.44.2.x86_64.rpm An 802.11 Wireless Network Sniffer
knock-0.7-lp150.303.2.x86_64.rpm A Port-Knocking Client
knockd-0.7-lp150.303.2.x86_64.rpm A port-knocking server
lft-3.32-lp150.2.2.x86_64.rpm Alternative Traceroute and Whois Toolkit for Network (reverse) Engineers
libaria2-0-1.34.0-lp150.150.1.x86_64.rpm Shared library for aria2
libcli-devel-1.9.7+git.20161026-lp150.5.1.x86_64.rpm Cisco-like telnet command-line library
libcli1_9-1.9.7+git.20161026-lp150.5.1.x86_64.rpm Cisco-like telnet command-line library
libconfig-devel-0.3.3-lp150.1.1.x86_64.rpm Configuration File Parsing Library
libconfig0-0.3.3-lp150.1.1.x86_64.rpm Configuration File Parsing Library
libdnet-devel-1.12-lp150.26.1.x86_64.rpm Development files for libdnet
libdnet-python-1.12-lp150.26.1.x86_64.rpm Python bindings for libdnet
libdnet1-1.12-lp150.26.1.x86_64.rpm Library for Portable Interface to Low-Level Networking Routines
Advertisement
Advertisement