suil-plugin-x11-in-qt5-0.10.0-lp150.21.1.x86_64.rpm


Advertisement

Description

suil-plugin-x11-in-qt5 - Shared object for Qt5 hosts displaying X11 LV2 GUIs

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Multimedia Libs all
Package name suil-plugin-x11-in-qt5
Package version 0.10.0
Package release lp150.21.1
Package architecture x86_64
Package type rpm
Installed size 19.59 KB
Download size 17.54 KB
Official Mirror ftp.gwdg.de
Module plugin for:
* Qt5 hosts displaying x11 LV2 GUIs using suil

Alternatives

Package Version Architecture Repository
suil-plugin-x11-in-qt5-0.10.0-lp150.22.1.x86_64.rpm 0.10.0 x86_64 openSUSE Multimedia Apps
suil-plugin-x11-in-qt5-0.10.0-lp150.2.1.x86_64.rpm 0.10.0 x86_64 openSUSE Oss
suil-plugin-x11-in-qt5 - - -

Requires

Name Value
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.9)(64bit) -
libQt5Widgets.so.5()(64bit) -
libQt5Widgets.so.5(Qt_5)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libsuil-0-0 = 0.10.0
python-qt5 -

Provides

Name Value
libsuil_x11_in_qt5.so()(64bit) -
suil-plugin-x11-in-qt5 = 0.10.0-lp150.21.1
suil-plugin-x11-in-qt5(x86-64) = 0.10.0-lp150.21.1

Download

Type URL
Binary Package suil-plugin-x11-in-qt5-0.10.0-lp150.21.1.x86_64.rpm
Source Package suil-0.10.0-lp150.21.1.src.rpm

Install Howto

  1. Add the openSUSE Multimedia Libs repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/multimedia:/libs/openSUSE_Leap_15.0/ opensuse-multimedia-libs
  2. Install suil-plugin-x11-in-qt5 rpm package:
    # zypper install suil-plugin-x11-in-qt5

Files

Path
/usr/lib64/suil-0/libsuil_x11_in_qt5.so
/usr/share/doc/packages/suil-plugin-x11-in-qt5/COPYING
/usr/share/doc/packages/suil-plugin-x11-in-qt5/README

Changelog

2018-02-18 - jengelh@inai.de
- Fix SRPM group.
2018-02-15 - aloisio@gmx.com
- Fixed supplements lines
2018-02-14 - aloisio@gmx.com
- Update to version 0.10.0
* Add support for X11 in Gtk3
* Add support for Qt5 in Gtk2
* Add suil_init() to support early initialization and passing
any necessary information that may be needed in the future
(thanks Stefan Westerfeld)
* Fix minor memory errors
* Fix building with X11 against custom LV2 install path (thanks
Robin Gareus)
version 0.8.4
* Configure based on compiler target OS for cross-compilation
* Add Cocoa in Gtk wrapper (patch from Robin Gareus)
* Various Windows fixes (patches from Robin Gareus)
* Center X11 UIs in Gtk (patch from Robin Gareus)
* Fix initial size of resizable X11 UIs in Gtk (patch from
Robin Gareus)
* Bubble X11 key events up to Gtk parent (patch from Filipe
Coelho)
* Add Gtk2 and X11 in Qt5 wrappers (patch from Rui Nuno Capela)
* Fix compilation with -Wl,--no-undefined
* Fix a few minor/unlikely memory errors
* Gracefully handle failure to open wrapper
* Only report suil_ui_supported() if necessary wrapper is
compiled in
* Upgrade to waf 1.8.14
- Dropped qt4 plugins
- Split plugins into separate packages so that only actually
required libraries are pulled in
2015-12-12 - davejplater@gmail.com
- Packaged plugin modules in plugins package
2014-08-09 - Rui Nuno Capela <rncbc@rncbc.org> - 0.8.2-10
- New upstream release.
suil (0.8.2) stable;
* Fix embedding several Qt UIs in Gtk
* Add configure options to disable all Gtk or Qt support
* Upgrade to waf 1.7.16

See Also

Package Description
taglib-1.11.1-lp150.91.1.x86_64.rpm Audio Meta-Data Library
tinycompress-devel-1.1.6-lp150.1.1.x86_64.rpm Include Files and Libraries mandatory for Development
tinycompress-utils-1.1.6-lp150.1.1.x86_64.rpm Utility programs for ALSA compressed API
toxcore-0.0.0+git20160124.61f8e65-lp150.1.9.x86_64.rpm The future of online communications
toxcore-devel-0.0.0+git20160124.61f8e65-lp150.1.9.x86_64.rpm Development headers for toxcore
twolame-0.3.13-lp150.5.5.x86_64.rpm An optimised MPEG Audio Layer 2 (MP2) encoder
typelib-1_0-GES-1_0-1.14.2-lp150.54.1.x86_64.rpm GStreamer Editing Services - Libraries
typelib-1_0-Gst-1_0-1.14.2-lp150.119.2.x86_64.rpm Streaming-Media Framework Runtime -- Introspection bindings
typelib-1_0-GstAllocators-1_0-1.14.2-lp150.116.2.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins -- Introspection bindings
typelib-1_0-GstApp-1_0-1.14.2-lp150.116.2.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins -- Introspection bindings
typelib-1_0-GstAudio-1_0-1.14.2-lp150.116.2.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins -- Introspection bindings
typelib-1_0-GstGL-1_0-1.14.2-lp150.116.2.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins -- Introspection bindings
typelib-1_0-GstInsertBin-1_0-1.14.2-lp150.246.2.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins -- Introspection bindings
typelib-1_0-GstMpegts-1_0-1.14.2-lp150.246.2.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins -- Introspection bindings
typelib-1_0-GstPbutils-1_0-1.14.2-lp150.116.2.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins -- Introspection bindings
Advertisement
Advertisement