speex-1.2-lp150.47.8.x86_64.rpm


Advertisement

Description

speex - An Open Source, Patent Free Speech Codec

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Multimedia Libs all
Package name speex
Package version 1.2
Package release lp150.47.8
Package architecture x86_64
Package type rpm
Installed size 60.88 KB
Download size 31.06 KB
Official Mirror ftp.gwdg.de
Speex is a patent free audio codec designed especially for voice
(unlike Vorbis which targets general audio) signals and providing good
narrowband and wideband quality. This project aims to be complementary
to the Vorbis codec.

Alternatives

Package Version Architecture Repository
speex-1.2-lp150.1.12.x86_64.rpm 1.2 x86_64 openSUSE Oss
speex - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libogg.so.0()(64bit) -
libspeex.so.1()(64bit) -
libspeexdsp.so.1()(64bit) -

Provides

Name Value
speex = 1.2-lp150.47.8
speex(x86-64) = 1.2-lp150.47.8

Download

Type URL
Binary Package speex-1.2-lp150.47.8.x86_64.rpm
Source Package speex-1.2-lp150.47.8.src.rpm

Install Howto

  1. Add the openSUSE Multimedia Libs repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/multimedia:/libs/openSUSE_Leap_15.0/ opensuse-multimedia-libs
  2. Install speex rpm package:
    # zypper install speex

Files

Path
/usr/bin/speexdec
/usr/bin/speexenc
/usr/share/doc/packages/speex/AUTHORS
/usr/share/doc/packages/speex/COPYING
/usr/share/doc/packages/speex/ChangeLog
/usr/share/doc/packages/speex/NEWS
/usr/share/doc/packages/speex/README
/usr/share/doc/packages/speex/TODO
/usr/share/man/man1/speexdec.1.gz
/usr/share/man/man1/speexenc.1.gz

Changelog

2017-02-19 - tom.mbrt@googlemail.com
- Update to stable 1.2 release
2015-08-22 - bwiedemann@suse.com
- make speex-devel require speexdsp-devel to be backward compatible
2015-03-11 - jengelh@inai.de
- Use the tilde versioning scheme; we are no longer bound to use
the old hacks.
2015-02-28 - tchvatal@suse.com
- Move libname up and set it just once, easier for later on.
2015-02-23 - mpluskal@suse.com
- Split package to two separate packages
* speexdsp contains libraries
* speex contains tools
- Update to 1.2rc2
* This release splits the speex codec library and the speex DSP
library into separate source trees. Both projects received
build-system improvements, bugfixes, and cleanup. The speex
codec's VBR tuning was improved, while the speexdsp resampler
got some NEON optimizations.
- Remove obsolete patch
* speex-1.0.5-warning-fix.diff
2013-04-05 - idonmez@suse.com
- Add Source URL, see https://en.opensuse.org/SourceUrls
2011-11-24 - coolo@suse.com
- add libtool as buildrequire to avoid implicit dependency
2010-09-03 - cristian.rodriguez@opensuse.org
- Do not include build date in binaries...
2010-06-25 - dmueller@suse.de
- obsolete old -XXbit packages
2010-01-14 - chris@computersalat.de
- fix build for SLE_10
autoreconf for suse_version >= 1100
- spec
o sort TAGS
o macros
rm > {__rm}
version > {version} ....

See Also

Package Description
speex-devel-1.2-lp150.47.8.x86_64.rpm Development package for SpeeX
speexdsp-devel-1.2~rc3-lp150.18.8.x86_64.rpm Development package for SpeeX
sratom-devel-0.6.2-lp150.10.1.x86_64.rpm Development files for libsratom
srt-1.3.1-lp150.12.1.x86_64.rpm Secure Reliable Transport (SRT)
srt-devel-1.3.1-lp150.12.1.x86_64.rpm Development files for the Secure Reliable Transport (SRT) library
suil-devel-0.10.0-lp150.21.1.x86_64.rpm Development files for the suil library
suil-plugin-gtk2-in-qt5-0.10.0-lp150.21.1.x86_64.rpm Shared object for GTK2 hosts displaying Qt5 LV2 GUIs
suil-plugin-qt5-in-gtk2-0.10.0-lp150.21.1.x86_64.rpm Shared object for Qt5 hosts displaying GTK2 LV2 GUIs
suil-plugin-x11-0.10.0-lp150.21.1.x86_64.rpm Shared object for X11 LV2 GUIs
suil-plugin-x11-in-gtk2-0.10.0-lp150.21.1.x86_64.rpm Shared object for GTK2 hosts displaying X11 LV2 GUIs
suil-plugin-x11-in-gtk3-0.10.0-lp150.21.1.x86_64.rpm Shared object for GTK3 hosts displaying X11 LV2 GUIs
suil-plugin-x11-in-qt5-0.10.0-lp150.21.1.x86_64.rpm Shared object for Qt5 hosts displaying X11 LV2 GUIs
taglib-1.11.1-lp150.91.1.x86_64.rpm Audio Meta-Data Library
tinycompress-devel-1.1.6-lp150.1.1.x86_64.rpm Include Files and Libraries mandatory for Development
tinycompress-utils-1.1.6-lp150.1.1.x86_64.rpm Utility programs for ALSA compressed API
Advertisement
Advertisement