libwebrtc_audio_processing-devel-static-0.3-lp150.26.12.x86_64.rpm


Advertisement

Description

libwebrtc_audio_processing-devel-static - Real-Time Communication Library for Web Browsers

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Multimedia Libs all
Package name libwebrtc_audio_processing-devel-static
Package version 0.3
Package release lp150.26.12
Package architecture x86_64
Package type rpm
Installed size 7.95 MB
Download size 2.76 MB
Official Mirror ftp.gwdg.de
WebRTC is an open source project that enables web browsers with Real-Time
Communications (RTC) capabilities via simple Javascript APIs. The WebRTC
components have been optimized to best serve this purpose.
WebRTC implements the W3C's proposal for video conferencing on the web.

Alternatives

Package Version Architecture Repository
libwebrtc_audio_processing-devel-static-0.3-lp150.1.17.x86_64.rpm 0.3 x86_64 openSUSE Oss
libwebrtc_audio_processing-devel-static - - -

Requires

Name Value
libwebrtc_audio_processing-devel = 0.3

Provides

Name Value
libwebrtc_audio_processing-devel-static = 0.3-lp150.26.12
libwebrtc_audio_processing-devel-static(x86-64) = 0.3-lp150.26.12

Download

Type URL
Binary Package libwebrtc_audio_processing-devel-static-0.3-lp150.26.12.x86_64.rpm
Source Package webrtc-audio-processing-0.3-lp150.26.12.src.rpm

Install Howto

  1. Add the openSUSE Multimedia Libs repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/multimedia:/libs/openSUSE_Leap_15.0/ opensuse-multimedia-libs
  2. Install libwebrtc_audio_processing-devel-static rpm package:
    # zypper install libwebrtc_audio_processing-devel-static

Files

Path
/usr/lib64/libwebrtc_audio_processing.a

Changelog

2017-01-12 - olaf@aepfle.de
- Add baselibs.conf for gstreamer-plugins-bad-32bit
2016-06-25 - oholecek@suse.com
- Remove webrtc-aarch64.patch, no longer needed
- Adapt the rest of webrtc- patches to new arch naming
2016-06-23 - oholecek@suse.com
- Remove unneeded explicit version dependency for automake
2016-06-22 - oholecek@suse.com
- Update to 0.3
* build: enforce linking with --no-undefined, add explicit -lpthread
* build: Make sure files with SSE2 code are compiled with -msse2
- Remove no-undefined.patch
- Remove webrtc-audio-processing-0.2-x86_msse2.patch
2016-06-20 - oholecek@suse.com
- Add no-undefined.patch patch
https://cgit.freedesktop.org/pulseaudio/webrtc-audio-processing/patch/?id=d58164e4d87854233564b59e76259b72e21507f6
- Add big_endian_support_2.patch  https://bugs.freedesktop.org/show_bug.cgi?id=95738
- Adapt webrtc-audio-processing-0.2-x86_msse2.patch to new version
- Adapt big_endian_support.patch to new version
2016-05-30 - oholecek@suse.com
- Add webrtc-audio-processing-0.2-x86_msse2.patch patch fixing 386 build
https://lists.freedesktop.org/archives/pulseaudio-discuss/2016-May/026294.html
- Add big_endian_support.patch
https://bugs.freedesktop.org/show_bug.cgi?id=95738
- New automake version dependency >= 1.5
2016-05-26 - oholecek@suse.com
- Update to 0.2:
Contains API breaking changes.
Upstream changes include:
* Rewritten AGC and voice activity detection
* Intelligibility enhancer
* Extended AEC filter
* Beamformer
* Transient suppressor
* ARM, NEON and MIPS optimisations (MIPS optimisations are not hooked up)
API changes:
* We no longer include a top-level audio_processing.h. The webrtc tree format
is used, so use webrtc/modules/audio_processing/include/audio_processing.h
* The top-level module_common_types.h has also been moved to
webrtc/modules/interface/module_common_types.h
* C++11 support is now required while compiling client code
* AudioProcessing::Create() does not take any arguments any more
* AudioProcessing::Destroy() is gone, use standard C++ "delete" instead
* Stream parameters are now configured via StreamConfig and ProcessingConfig
rather than set_sample_rate(), set_num_channels(), etc.
* AudioFrame field names have changed
* Use config API for newer audio processing options
* Use ProcessReverseStream() instead of AnalyzeReverseStream(), particularly
when using the intelligibility enhancer
* GainControl::set_analog_level_limits() is broken. The AGC implementation
hard codes 0-255 as the volume range
Other notes:
* The new audio processing parameters are not all tested, and a few are not
enabled upstream (in Chromium) either
* The rewritten AGC appears to be less sensitive, and it might make sense to
initialise the capture volume to something reasonable (33% or 50%, for
example) to make sure there is sufficient energy in the stream to trigger
the AGC mechanism
- Adapted all 3 arch patches
2013-03-07 - idonmez@suse.com
- Add patch webrtc-aarch64.patch from algraf to add aarch64 support
2012-12-19 - ro@suse.de
- add s390 and s390x to known platforms
by adding webrtc-s390x.patch
2012-07-03 - dvaleev@suse.com
- add ppc64 to known platforms

See Also

Package Description
libwebrtc_audio_processing1-0.3-lp150.26.12.x86_64.rpm Real-Time Communication Library for Web Browsers
libwebvfx1-0.44+git20180223-lp150.111.1.x86_64.rpm Video effects engine based on web technologies
libxcam-devel-1.0.0-lp150.6.5.x86_64.rpm Development files for libxcam
libxcam1-1.0.0-lp150.6.5.x86_64.rpm Image processing library for extended camera features and video analysis
libxmp-devel-4.4.1-lp150.65.8.x86_64.rpm Development files for libxmp, a MOD/S3M/IT/etc. module player library
libxmp4-4.4.1-lp150.65.8.x86_64.rpm Module Player library for MOD, S3M, IT and others
libxspf-devel-1.2.0-lp150.38.5.x86_64.rpm Brings XSPF playlist read and write support to C++ apps
libxspf4-1.2.0-lp150.38.5.x86_64.rpm Provides XSPF playlist reading and writing support
libyami-devel-1.3.0+20180629.0067a64-lp150.21.2.x86_64.rpm Development files for libyami
libyami1-1.3.0+20180629.0067a64-lp150.21.2.x86_64.rpm Library components for libyami
libzbar-devel-0.10_2013_02_28-lp150.7.2.x86_64.rpm Development environment for the ZBar library
libzbar0-0.10_2013_02_28-lp150.7.2.x86_64.rpm Bar code reading library
libzbarqt-devel-0.10_2013_02_28-lp150.7.2.x86_64.rpm Development environment for the ZBar Qt bindings library
libzbarqt0-0.10_2013_02_28-lp150.7.2.x86_64.rpm ZBar Qt bindings
libzen-devel-0.4.37-lp150.8.5.x86_64.rpm Include files to develop for libzen
Advertisement
Advertisement