libltc-devel-1.3.0-lp150.8.2.x86_64.rpm


Advertisement

Description

libltc-devel - Linear/longitudinal timecode library

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Multimedia Libs all
Package name libltc-devel
Package version 1.3.0
Package release lp150.8.2
Package architecture x86_64
Package type rpm
Installed size 40.01 KB
Download size 30.91 KB
Official Mirror ftp.gwdg.de
Linear (or Longitudinal) Timecode (LTC) is an encoding of SMPTE timecode
data as a Manchester-Biphase encoded audio signal. The audio signal is
commonly recorded on a VTR track or other storage media.
libltc provides functionality to encode and decode LTC audio from/to SMPTE
or EBU timecode, including SMPTE date support.

Alternatives

Package Version Architecture Repository
libltc-devel-1.1.4-lp150.1.4.x86_64.rpm 1.1.4 x86_64 openSUSE Oss
libltc-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libltc11 = 1.3.0

Provides

Name Value
libltc-devel = 1.3.0-lp150.8.2
libltc-devel(x86-64) = 1.3.0-lp150.8.2
pkgconfig(ltc) = 1.3.0

Download

Type URL
Binary Package libltc-devel-1.3.0-lp150.8.2.x86_64.rpm
Source Package libltc-1.3.0-lp150.8.2.src.rpm

Install Howto

  1. Add the openSUSE Multimedia Libs repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/multimedia:/libs/openSUSE_Leap_15.0/ opensuse-multimedia-libs
  2. Install libltc-devel rpm package:
    # zypper install libltc-devel

Files

Path
/usr/include/ltc.h
/usr/lib64/libltc.so
/usr/lib64/pkgconfig/ltc.pc
/usr/share/man/man3/ltc.h.3.gz

Changelog

2018-07-12 - mpluskal@suse.com
- Update to version 1.3.0
* fix potential offset overflow (user provided relative position)
* add link examples and bindings/wrapper code to documentation
* documentation spelling fixes
* fix endianess detection (gcc-4.4 compat)
* improve realtime safety, don't even print errors
- Drop oxygen buildrequirement and libltc_doxyfile_no_timestamp.patch
2016-02-21 - jengelh@inai.de
- Avoid building static libs since they get removed anyway.
Requires uses one equals sign.
2016-02-12 - mpluskal@suse.com
- Do not ship static library
- Update dependencies/provides
* add pkg-config
* remove manual provides
- Cleanup spec file
2014-06-14 - virtuousfox@gmail.com
- Update to 1.1.4
2014-05-16 (v1.1.4) Robin Gareus <robin@gareus.org>
* rework endianess detection
* fix compile on systems w/o endian.h
* remove obsolte autotools macros

See Also

Package Description
libltc11-1.3.0-lp150.8.2.x86_64.rpm Linear/longitudinal timecode library
libmad-devel-0.15.1b-lp150.13.1.x86_64.rpm Development package for libmad, an MP3 decoding library
libmad0-0.15.1b-lp150.13.1.x86_64.rpm An MPEG audio decoder library
libmatroska-devel-1.4.9-lp150.81.1.x86_64.rpm Library to Deal with Matroska Files
libmatroska6-1.4.9-lp150.81.1.x86_64.rpm Library to Deal with Matroska Files
libmediainfo-devel-18.05-lp150.26.1.x86_64.rpm Include files and libraries for development
libmediainfo0-18.05-lp150.26.1.x86_64.rpm Supplies technical and tag information about a video or audio file
libmikmod-devel-3.3.7-lp150.54.9.x86_64.rpm Development files for MikMod Sound Library
libmikmod3-3.3.7-lp150.54.9.x86_64.rpm MikMod Sound Library
libmjpegutils-2_0-0-2.0.0-lp150.90.2.x86_64.rpm MJPEG Video Capture and Processing Tools
libmjpegutils-devel-2.0.0-lp150.90.2.x86_64.rpm MJPEG Video Capture and Processing Tools
libmlt++-devel-6.10.0-lp150.111.2.x86_64.rpm Development files for MLT's C++ language API
libmlt++3-6.10.0-lp150.111.2.x86_64.rpm C++ library API for the MLT multimedia framework
libmlt-devel-6.10.0-lp150.111.2.x86_64.rpm Development files for MLT's C language API
libmlt6-6.10.0-lp150.111.2.x86_64.rpm C library API for the MLT multimedia framework
Advertisement
Advertisement