libgpod4-0.8.3-lp150.70.1.x86_64.rpm


Advertisement

Description

libgpod4 - Library to Manipulate Songs and Playlists Stored on an iPod

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Multimedia Libs all
Package name libgpod4
Package version 0.8.3
Package release lp150.70.1
Package architecture x86_64
Package type rpm
Installed size 665.61 KB
Download size 237.50 KB
Official Mirror ftp.gwdg.de
libgpod is a library meant to abstract access to iPod content. It
provides an API to retrieve the list of files and
playlists stored on an iPod, modify them, and save them back to the iPod.

Alternatives

Package Version Architecture Repository
libgpod4-0.8.3-lp150.2.27.x86_64.rpm 0.8.3 x86_64 openSUSE Oss
libgpod4 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.14)(64bit) -
libgdk_pixbuf-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgmodule-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libimobiledevice.so.6()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libplist.so.3()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libsqlite3.so.0()(64bit) -
libxml2.so.2()(64bit) -
libxml2.so.2(LIBXML2_2.4.30)(64bit) -
libxml2.so.2(LIBXML2_2.6.0)(64bit) -
libz.so.1()(64bit) -
libz.so.1(ZLIB_1.2.0)(64bit) -

Provides

Name Value
libgpod = 0.8.3
libgpod.so.4()(64bit) -
libgpod4 = 0.8.3-lp150.70.1
libgpod4(x86-64) = 0.8.3-lp150.70.1

Download

Type URL
Binary Package libgpod4-0.8.3-lp150.70.1.x86_64.rpm
Source Package libgpod-0.8.3-lp150.70.1.src.rpm

Install Howto

  1. Add the openSUSE Multimedia Libs repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/multimedia:/libs/openSUSE_Leap_15.0/ opensuse-multimedia-libs
  2. Install libgpod4 rpm package:
    # zypper install libgpod4

Files

Path
/usr/lib64/libgpod.so.4
/usr/lib64/libgpod.so.4.3.2
/usr/share/doc/packages/libgpod4/AUTHORS
/usr/share/doc/packages/libgpod4/COPYING
/usr/share/doc/packages/libgpod4/ChangeLog
/usr/share/doc/packages/libgpod4/NEWS
/usr/share/doc/packages/libgpod4/README
/usr/share/doc/packages/libgpod4/README.SysInfo

Changelog

2018-06-11 - bjorn.lie@gmail.com
- Change bcond_without mono to bcond_with mono, no longer build
mono support/sub-package by default.
2018-01-23 - jengelh@inai.de
- Fix groups of SRPM and documentation. Make doc noarch.
Trim bias from description.
2018-01-23 - tchvatal@suse.com
- Conditionalize python2 module build as it is not compatible with
python3 at all and we do not need it by default
* This allows to build in python3 only enviroment
- Run over a bit with spec-cleaner
2015-10-23 - tuukka.pasanen@ilmi.fi
- Added patch that prevents segfault when using newer iPod and iPhone (< iOS 5)
0002-323-Segmentation-fault-when-opening-ipod.patch
- Added patch that corrects few strings
0001-Fix-spelling-errors-in-comments-and-strings-using-co.patch
- Added patch that corrects compiling with newer libplist
0003-Fixed-PList-deprication.patch
2015-06-21 - crrodriguez@opensuse.org
- Use libusb-1_0-devel as BuildRequires not libusb-devel
as the old libusb compatibility layer is not used.
2015-03-24 - dvlaeev@suse.com
- Change bcond back again.. It turned out to be that mono bindings
are wanted by the openSUSE community.
2015-03-20 - dvlaeev@suse.com
- Build without Mono by default
2015-01-26 - dimstar@opensuse.org
- Add libgpod-swig-3.0.patch: Fix build with SWIG 3.0.
2013-12-22 - zaitor@opensuse.org
- Update to version 0.8.3:
+ Add support for libimobiledevice 1.1.5.
+ Remove use of some deprecated glib functions.
+ Fix various issues found using clang/cppcheck.
+ Improve robustness of the iphone callout.
- Drop libgpod-libimobiledevice-fix.patch, fixed upstream.
- Stop passing --enable-udev to configure, now default enabled.
- Remove conditional BuildRequires for obsolete openSUSE versions
(11.2 and older, no longer supported as evergreen either).
- Stop passing --with-hal-callouts-dir=%{_libexecdir}/hal and
and --disable-udev only needed for obsolete openSUSE versions.
2013-07-15 - coolo@suse.com
- fix build in factory by porting to new libimobiledevice api

See Also

Package Description
libgroove-devel-4.3.0-lp150.6.2.x86_64.rpm Development files for libgroove
libgroove4-4.3.0-lp150.6.2.x86_64.rpm A library to streaming audio processing
libgroovefingerprinter-devel-4.3.0-lp150.6.2.x86_64.rpm Development files for groovefingerprinter
libgroovefingerprinter4-4.3.0-lp150.6.2.x86_64.rpm A library to acoustid fingerprinter for libgroove
libgrooveloudness-devel-4.3.0-lp150.6.2.x86_64.rpm Development files for libgrooveloudness
libgrooveloudness4-4.3.0-lp150.6.2.x86_64.rpm A library to loudness scanner for libgroove
libgrooveplayer-devel-4.3.0-lp150.6.2.x86_64.rpm Development files for libgrooveplayer
libgrooveplayer4-4.3.0-lp150.6.2.x86_64.rpm A library to hardware audio playback for libgroove
libgsm-devel-1.0.14-lp150.45.5.x86_64.rpm GSM 06.10 Lossy Speech Compressor Library and Utilities
libgsm-utils-1.0.14-lp150.45.5.x86_64.rpm GSM 06.10 Lossy Speech Compressor Library and Utilities
libgsm1-1.0.14-lp150.45.5.x86_64.rpm GSM 06.10 Lossy Speech Compressor Library and Utilities
libgstadaptivedemux-1_0-0-1.14.4-lp150.249.1.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins
libgstallocators-1_0-0-1.14.4-lp150.120.1.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins
libgstapp-1_0-0-1.14.4-lp150.120.1.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins
libgstaudio-1_0-0-1.14.4-lp150.120.1.x86_64.rpm GStreamer Streaming-Media Framework Plug-Ins
Advertisement
Advertisement