libdvdread4-6.0.0-lp150.35.3.x86_64.rpm


Advertisement

Description

libdvdread4 - Library for Reading DVD Video Images

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Multimedia Libs all
Package name libdvdread4
Package version 6.0.0
Package release lp150.35.3
Package architecture x86_64
Package type rpm
Installed size 142.98 KB
Download size 64.96 KB
Official Mirror ftp.gwdg.de
This package contains shared libraries for accessing DVD images (this
package does not contain DeCSS algorithms).

Alternatives

Package Version Architecture Repository
libdvdread4-6.0.0-lp150.36.2.x86_64.rpm 6.0.0 x86_64 VLC
libdvdread4-6.0.0-lp150.1.2.x86_64.rpm 6.0.0 x86_64 openSUSE Oss
libdvdread4 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.14)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -

Provides

Name Value
libdvdread = 6.0.0
libdvdread.so.4()(64bit) -
libdvdread4 = 6.0.0-lp150.35.3
libdvdread4(x86-64) = 6.0.0-lp150.35.3

Obsoletes

Name Value
libdvdread <= 0.9.7

Download

Type URL
Binary Package libdvdread4-6.0.0-lp150.35.3.x86_64.rpm
Source Package libdvdread-6.0.0-lp150.35.3.src.rpm

Install Howto

  1. Add the openSUSE Multimedia Libs repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/multimedia:/libs/openSUSE_Leap_15.0/ opensuse-multimedia-libs
  2. Install libdvdread4 rpm package:
    # zypper install libdvdread4

Files

Path
/usr/lib64/libdvdread.so.4
/usr/lib64/libdvdread.so.4.2.0
/usr/share/doc/packages/libdvdread4/AUTHORS
/usr/share/doc/packages/libdvdread4/COPYING
/usr/share/doc/packages/libdvdread4/NEWS
/usr/share/doc/packages/libdvdread4/README

Changelog

2018-01-27 - j.lorenzen@kabelmail.de
- Update to version 6.0.0:
* restrict the number of symbols to be exposed to the
shared-object
* remove dvdinput_error function
* improve compatibility with some DVDs (notably the eOne ones)
* fix write after free in ifoFree functions
* fix possible buffer overflow in open
* additional checks on DVDReadBytes arguments
* fix leaks
- Removed libdvdread-no-internal-crypto.patch because it's not
applied anymore.
2015-09-24 - mpluskal@suse.com
- Add gpg signature
- Use more explicit dependencies
- Make build more verbose
- Clenup spec file with spec-cleaner
2015-03-28 - joerg.lorenzen@ki.tng.de
- Update to version 5.0.3:
* Cache IFO and BUP files (only for ImageFiles) in order to reduce
the number of read/seek access
* Fix compilation warnings for OS/2
2015-01-30 - joerg.lorenzen@ki.tng.de
- Update to version 5.0.2:
* Add DVDOpenStream to open a dvd from a set of callbacks
2015-01-27 - joerg.lorenzen@ki.tng.de
- Update to version 5.0.1:
* support DragonFly BSD bswap
* new md5 implementation, under LGPL
* fix partial reads
* fix warnings and code cleanup
2014-12-17 - joerg.lorenzen@ki.tng.de
- Update to version 5.0.0:
* added support for Android
* fix build support for OS/2
* fix crashes in IFO parsing (Shark Week The Great Bites Collection)
2014-07-18 - dimstar@opensuse.org
- Update to version 4.9.9 (5.0 Release Candidate)
+ 3 years worth of development; please see NEWS file in package.
- Drop libdvdread-strict-aliasing.patch: no longer required.
- Move AUTHORS, COPYING, NEWS and README to the library package.
2012-07-31 - crrodriguez@opensuse.org
- Use openssl for crypto, we have too many duplicated
implementations of common digest algos
- Autotools fixes.
2011-12-03 - pascal.bleser@opensuse.org
- update to 4.2.0:
* fixed ARM memory alignment issue
* added a missing DVDFileStat function
* exposed the dvd_stat_t struct in header
* fixed libdvdread closing stdin if it can't open the file/device
* fixed a segfault in UDFFileEntry on some badly mastered DVDs
* fixed big-endian builds
* provide BUP file support for more issues
* move UDFReadBlocksRaw declaration to dvdread_internal.h
* fixed double free of parental management information
* fixed crash when PTT is too short
* fixed segfault when reading certain DVDs, for example "Thor"
2011-11-13 - coolo@suse.com
- add libtool as explicit buildrequire to avoid implicit dependency from prjconf

See Also

Package Description
libebml-devel-1.3.6-lp150.76.1.x86_64.rpm Development files for the EBML file parser library
libebml4-1.3.6-lp150.76.1.x86_64.rpm Library to parse EBML files
libebur128-1-1.2.4-lp150.7.1.x86_64.rpm A library implementing the EBU R128 loudness standard
libebur128-devel-1.2.4-lp150.7.1.x86_64.rpm Development files for libebur128
libexempi-devel-2.4.5-lp150.36.4.x86_64.rpm Development files for the Exempi XMP support library
libexempi3-2.4.5-lp150.36.4.x86_64.rpm XMP support library
libffado-devel-2.4.0-lp150.89.1.x86_64.rpm Development files for ffado
libffado2-2.4.0-lp150.89.1.x86_64.rpm FireWire 1394 support for audio devices
libffms2-4-2.23.1-lp150.4.11.x86_64.rpm Wrapper library around libffmpeg
libffms2-devel-2.23.1-lp150.4.11.x86_64.rpm Wrapper library around libffmpeg
libfftw3-3-3.3.6-lp150.82.1.x86_64.rpm Discrete Fourier Transform (DFT) C Subroutine Library
libfftw3-gnu-hpc-3.3.6-lp150.82.1.x86_64.rpm Dependency package for fftw3_3_3_6-gnu-hpc
libfftw3-gnu-mpich-hpc-3.3.6-lp150.82.1.x86_64.rpm Dependency package for fftw3_3_3_6-gnu-mpich-hpc
libfftw3-gnu-mvapich2-hpc-3.3.6-lp150.82.1.x86_64.rpm Dependency package for fftw3_3_3_6-gnu-mvapich2-hpc
libfftw3-gnu-openmpi1-hpc-3.3.6-lp150.82.1.x86_64.rpm Dependency package for fftw3_3_3_6-gnu-openmpi1-hpc
Advertisement
Advertisement