fftw3-gnu-openmpi3-hpc-devel-3.3.6-lp150.81.1.x86_64.rpm


Advertisement

Description

fftw3-gnu-openmpi3-hpc-devel - Dependency package for fftw3_3_3_6-gnu-openmpi3-hpc-devel

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE Multimedia Libs all
Package name fftw3-gnu-openmpi3-hpc-devel
Package version 3.3.6
Package release lp150.81.1
Package architecture x86_64
Package type rpm
Installed size 111 B
Download size 15.87 KB
Official Mirror ftp.gwdg.de
The package fftw3_3_3_6-gnu-openmpi3-hpc-devel provides the dependency to get the latest version of fftw3

Alternatives

Package Version Architecture Repository
fftw3-gnu-openmpi3-hpc-devel-3.3.6-lp150.10.1.x86_64.rpm 3.3.6 x86_64 openSUSE Education
fftw3-gnu-openmpi3-hpc-devel-3.3.6-lp150.3.3.x86_64.rpm 3.3.6 x86_64 openSUSE Oss
fftw3-gnu-openmpi3-hpc-devel - - -

Requires

Name Value
fftw3_3_3_6-gnu-openmpi3-hpc-devel = 3.3.6

Provides

Name Value
fftw3-gnu-openmpi3-hpc-devel = 3.3.6-lp150.81.1
fftw3-gnu-openmpi3-hpc-devel(x86-64) = 3.3.6-lp150.81.1

Obsoletes

Name Value
fftw3-gnu-openmpi3-hpc-devel < 3.3.6

Download

Type URL
Binary Package fftw3-gnu-openmpi3-hpc-devel-3.3.6-lp150.81.1.x86_64.rpm
Source Package fftw3_3_3_6-gnu-openmpi3-hpc-3.3.6-lp150.81.1.src.rpm

Install Howto

  1. Add the openSUSE Multimedia Libs repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/multimedia:/libs/openSUSE_Leap_15.0/ opensuse-multimedia-libs
  2. Install fftw3-gnu-openmpi3-hpc-devel rpm package:
    # zypper install fftw3-gnu-openmpi3-hpc-devel

Files

Path
/usr/share/doc/packages/fftw3-gnu-openmpi3-hpc-devel/README.fftw3_3_3_6-gnu-openmpi3-hpc-devel

Changelog

2018-05-31 - antoine.belvire@opensuse.org
- Fix %install_info_delete usage.
2018-02-26 - eich@suse.com
- Add support for openmpi2 for the HPC build (FATE#325089).
2018-02-22 - nmoreychaisemartin@suse.com
- Switch to openmpi2 instead of openmpi (bsc#1082302),
apart from ppc64 as openmpi2 does not support it.
2018-01-22 - eich@suse.com
- Fix typo in flavor gnu7-hpc settings.
2018-01-19 - eich@suse.com
- Change the name of the MPI version of the module file directory
to pfftw3 to distinguish it from the 'serial' one (boo#1075933).
2018-01-12 - eich@suse.com
- Disable the openmpi3 flavor in some products.
2018-01-05 - eich@suse.com
- Add gcc7 as additional compiler flavor for HPC on SLES.
- Fix library package requires - use HPC macro (boo#1074890).
- Add support for mpich and openmpi3 for HPC.
2017-11-14 - eich@suse.com
- Fix library package dependencies - limit certain
dependencies to HPC packages.
2017-11-12 - eich@suse.com
- Fix HPC library requires package and modules file.
2017-11-07 - eich@suse.com
- update to 3.3.6-pl2
* Bugfix: MPI Fortran-03 headers were missing in FFTW 3.3.6-pl1.
* Bugfix: FFTW 3.3.6 had the wrong libtool version number, and generated
shared libraries of the form libfftw3.so.2.6.6 instead of
libfftw3.so.3.*.
* The fftw_make_planner_thread_safe() API introduced in 3.3.5 didn't
work, and this 3.3.6 fixes it.  Sorry about that.
* compilation fixes for IBM XLC
* compilation fixes for threads on Windows
* fix SIMD autodetection on amd64 when (_MSC_VER > 1500)

See Also

Package Description
fftw3-mpi-devel-3.3.6-lp150.81.1.x86_64.rpm Discrete Fourier Transform (DFT) C subroutine library
fftw3-openmp-devel-3.3.6-lp150.81.1.x86_64.rpm Discrete Fourier Transform (DFT) C subroutine library
fftw3-threads-devel-3.3.6-lp150.81.1.x86_64.rpm Discrete Fourier Transform (DFT) C subroutine library
fftw3_3_3_6-gnu-hpc-devel-3.3.6-lp150.81.1.x86_64.rpm Include Files and Libraries mandatory for Development
fftw3_3_3_6-gnu-hpc-devel-static-3.3.6-lp150.81.1.x86_64.rpm Static libraries for fftw3
fftw3_3_3_6-gnu-mpich-hpc-devel-3.3.6-lp150.81.1.x86_64.rpm Include Files and Libraries mandatory for Development
fftw3_3_3_6-gnu-mpich-hpc-devel-static-3.3.6-lp150.81.1.x86_64.rpm Static libraries for fftw3
fftw3_3_3_6-gnu-mvapich2-hpc-devel-3.3.6-lp150.81.1.x86_64.rpm Include Files and Libraries mandatory for Development
fftw3_3_3_6-gnu-mvapich2-hpc-devel-static-3.3.6-lp150.81.1.x86_64.rpm Static libraries for fftw3
fftw3_3_3_6-gnu-openmpi1-hpc-devel-3.3.6-lp150.81.1.x86_64.rpm Include Files and Libraries mandatory for Development
fftw3_3_3_6-gnu-openmpi1-hpc-devel-static-3.3.6-lp150.81.1.x86_64.rpm Static libraries for fftw3
fftw3_3_3_6-gnu-openmpi2-hpc-devel-3.3.6-lp150.81.1.x86_64.rpm Include Files and Libraries mandatory for Development
fftw3_3_3_6-gnu-openmpi2-hpc-devel-static-3.3.6-lp150.81.1.x86_64.rpm Static libraries for fftw3
fftw3_3_3_6-gnu-openmpi3-hpc-devel-3.3.6-lp150.81.1.x86_64.rpm Include Files and Libraries mandatory for Development
fftw3_3_3_6-gnu-openmpi3-hpc-devel-static-3.3.6-lp150.81.1.x86_64.rpm Static libraries for fftw3
Advertisement
Advertisement