libjreen1-1.2.1-lp150.13.1.x86_64.rpm


Advertisement

Description

libjreen1 - Qt-based Jabber/XMPP library

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE KDE Extra all
Package name libjreen1
Package version 1.2.1
Package release lp150.13.1
Package architecture x86_64
Package type rpm
Installed size 1.41 MB
Download size 423.08 KB
Official Mirror ftp.gwdg.de
Jreen is an extensible Qt-based asynchronious Jabber library.

Alternatives

Package Version Architecture Repository
libjreen1-1.2.1-lp150.1.3.x86_64.rpm 1.2.1 x86_64 openSUSE Oss
libjreen1 - - -

Requires

Name Value
/sbin/ldconfig -
libQtCore.so.4()(64bit) -
libQtNetwork.so.4()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgsasl.so.7()(64bit) -
libgsasl.so.7(LIBGSASL_1.1)(64bit) -
libspeex.so.1()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libz.so.1()(64bit) -

Provides

Name Value
libjreen.so.1()(64bit) -
libjreen1 = 1.2.1-lp150.13.1
libjreen1(x86-64) = 1.2.1-lp150.13.1

Download

Type URL
Binary Package libjreen1-1.2.1-lp150.13.1.x86_64.rpm
Source Package libjreen-1.2.1-lp150.13.1.src.rpm

Install Howto

  1. Add the openSUSE KDE Extra repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/KDE:/Extra/openSUSE_Leap_15.0/ opensuse-kde-extra
  2. Install libjreen1 rpm package:
    # zypper install libjreen1

Files

Path
/usr/lib64/libjreen.so.1
/usr/lib64/libjreen.so.1.2.1
/usr/share/doc/packages/libjreen1/AUTHORS
/usr/share/doc/packages/libjreen1/COPYING
/usr/share/doc/packages/libjreen1/ChangeLog

Changelog

2017-02-05 - jengelh@inai.de
- Rename %soname to %sover to better reflect its use
- Update descriptions and RPM group
2015-11-16 - tittiatcoke@gmail.com
- Update to 1.2.1
* No upstream changelog
2014-10-22 - hrvoje.senjan@gmail.com
- Update to 1.2.0
* No upstream changelog
- Drop update-to-latest-git-fixes.patch, merged upstream
2014-07-27 - hrvoje.senjan@gmail.com
- Move back to standard macros for filelists: libjreen doesn't use
kde4 buildsystem
2013-12-12 - hrvoje.senjan@gmail.com
- Added update-to-latest-git-fixes.patch: fixes build failure with
cmake 2.8.12 and adds Qt5 support
- Added speex-devel, libidn-devel and libgsasl-devel BuildRequires
- Droped libqca2-devel (Build)Requires
- Pass DJREEN_FORCE_QT4=ON to CMake, as the buildsystem now defaults
to Qt 5
- Use kde macros
2013-01-07 - dev@dominik-schmidt.de
- Update to version 1.1.1
* Added support for XEP-224: Attentions
* Fixed roster update receiving on some servers
2012-04-18 - magist3r@gmail.com
- Update to version 1.1.0
* Added PGP payloads
* Added support for Message Forwarding
* Added MetaContacts support
* Added experimental Jingle support
* Fixed authorization with SCRAM-SHA1
* Fixed sending of IQ's on connect
- Changes in version 1.0.6
* Fixed parsing of PubSub payload
* Fixed serializing of PubSub payload
2012-04-01 - dev@dominik-schmidt.de
- Update to version 1.0.5
* Fixed parsing of message's thread attribute
- Changes in 1.0.4
* Added support for in-band registration
* Added ability to force/deny compression/encryption
* Added CAPTCHA support
* Fixed IQ requests to yourself
* Fixed handling of messages' types in MessageSession
2012-03-14 - dev@dominik-schmidt.de
- Update to version 1.0.3
* Added Logger implementation
* Fixed QJDns initialization issue
- Changes in 1.0.2
* Added support for ProxyFactory
* Added immunity to invalid stanzas
* Added localization support for incoming stanzas
* Fixed QJDns initialization behaviour
2011-12-08 - saschpe@suse.de
- Spec file cleanup:
* Removed unneeded rpmlintrc, outdated %clean section and inherent
Buildrequires

See Also

Package Description
libkdevplatform52-5.2.4-lp150.43.1.x86_64.rpm Libraries for Integrated Development Environments
libkdstatemachineeditor_core1_2_3-1.2.3-lp150.13.1.x86_64.rpm KDAB State Machine Editor core library
libkdstatemachineeditor_view1_2_3-1.2.3-lp150.13.1.x86_64.rpm KDAB State Machine Editor view library
libkgraphviewer3-2.4.3-lp150.1.1.x86_64.rpm Graphviz dot graph file viewer
libkpmcore7-3.3.0-lp150.16.1.x86_64.rpm KDE Partition Manager core library
libktorrent-devel-2.1-lp150.2.1.x86_64.rpm Development files for libktorrent
libktorrent-lang-2.1-lp150.2.1.noarch.rpm Translations for package libktorrent
libkvkontakte-devel-5.0.0-lp150.2.1.x86_64.rpm Development file for libkvkontakte
libkvkontakte-lang-5.0.0-lp150.2.1.noarch.rpm Languages for package libkvkontakte
liblensfun1-0.3.2-lp150.28.1.x86_64.rpm Library files for lensfun/lensfun-devel
libloudmouth-1-0-1.5.3-lp150.2.1.x86_64.rpm Jabber Client Library Written in C
libmediawiki-devel-5.37.0-lp150.7.1.x86_64.rpm Development files for libmediawiki
libmuparser2_2_5-2.2.5-lp150.27.1.x86_64.rpm Library to evaluate strings as mathematical functions
libopencv3_4-3.4.1-lp150.117.2.x86_64.rpm Libraries to use OpenCV computer vision
libowncloudsync-devel-2.5.0-lp150.38.1.x86_64.rpm Development files for the ownCloud synchronization library
Advertisement
Advertisement