libKF5Vkontakte2-5.0.0-lp150.2.1.x86_64.rpm


Advertisement

Description

libKF5Vkontakte2 - Library for asynchronous interaction with vkontakte.ru social network

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE KDE Extra all
Package name libKF5Vkontakte2
Package version 5.0.0
Package release lp150.2.1
Package architecture x86_64
Package type rpm
Installed size 239.77 KB
Download size 64.03 KB
Official Mirror ftp.gwdg.de
libkvkontakte is a KDE C++ library for asynchronous interaction with
vkontakte.ru social network via its open API.

Alternatives

Package Version Architecture Repository
libKF5Vkontakte2-5.0.0-lp150.1.8.x86_64.rpm 5.0.0 x86_64 openSUSE Oss
libKF5Vkontakte2 - - -

Requires

Name Value
/sbin/ldconfig -
libKF5CoreAddons.so.5()(64bit) -
libKF5I18n.so.5()(64bit) -
libKF5KIOCore.so.5()(64bit) -
libKF5WebKit.so.5()(64bit) -
libKF5WidgetsAddons.so.5()(64bit) -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.9)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Network.so.5()(64bit) -
libQt5Network.so.5(Qt_5)(64bit) -
libQt5WebKitWidgets.so.5()(64bit) -
libQt5WebKitWidgets.so.5(Qt_5)(64bit) -
libQt5Widgets.so.5()(64bit) -
libQt5Widgets.so.5(Qt_5)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -

Provides

Name Value
libKF5Vkontakte.so.2()(64bit) -
libKF5Vkontakte2 = 5.0.0-lp150.2.1
libKF5Vkontakte2(x86-64) = 5.0.0-lp150.2.1

Download

Type URL
Binary Package libKF5Vkontakte2-5.0.0-lp150.2.1.x86_64.rpm
Source Package libkvkontakte-5.0.0-lp150.2.1.src.rpm

Install Howto

  1. Add the openSUSE KDE Extra repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/KDE:/Extra/openSUSE_Leap_15.0/ opensuse-kde-extra
  2. Install libKF5Vkontakte2 rpm package:
    # zypper install libKF5Vkontakte2

Files

Path
/usr/lib64/libKF5Vkontakte.so.2
/usr/lib64/libKF5Vkontakte.so.5.0.0
/usr/share/doc/packages/libKF5Vkontakte2/COPYING
/usr/share/doc/packages/libKF5Vkontakte2/COPYING.LGPL-2
/usr/share/doc/packages/libKF5Vkontakte2/COPYING.LIB

Changelog

2017-08-31 - wbauer@tmo.at
- Update to Qt5/KF5-based version 5.0.0:
* Bugfixes
- Drop cmake_fix.patch, merged upstream
2015-10-05 - asterios.dramis@gmail.com
- Update to version 4.12.0:
NEW FEATURES:
* Add new class VkApi to manage authentication
OTHER CHANGES:
* Relicensed all the code to LGPLv2.1+
* Use method account.getAppPermissions instead of deprecated
method getUserSettings
* Add enum AppPermissions::Value for application permissions, to
replace string lists
* VkontakteJob: Do not pass empty auth token to VK API
* autotests: Request only necessary VK app permissions in each
unit test
* autotests: Prefer QList::at(0) over QList::first() to avoid
deep copying
- Added a patch (cmake_fix.patch) to fix cmake error about
LINK_INTERFACE_LIBRARIES properties and policy CMP0022.
2015-05-26 - tittiatcoke@gmail.com
- Update to version 4.11.0
Bugfixes:
- DigiKam crash when vkontakte plugin failed to upload images
(bko#345358)
OTHER CHANGES:
- Deprecate class GetVariableJob, please use UserInfoJob
instead
- Add unit tests for UserInfoJob and UserInfoFullJob
- Add unit tests for job classes working with photo albums
- NotesListJob: Fix setting of user ID with current
VK API version
- Add unit tests for job classes working with notes
- Follow VK API changes (renamed methods to
database.get[...]ById)
- Deprecate unused classes GetInfoJob and GroupListJob
- VkontakteJobs: Make more members private
- Retry HTTP request after a delay on error "Too many requests
per second"
- Rewrite HTTP multipart request using QHttpMultiPart
- UserInfoJob: Use VK API method users.get instead of getProfiles
- Use vk.com instead of vkontakte.ru everywhere
- Drop the separate COPYING* files as that upstream now includes
the correct licensing files
2011-11-24 - asterios.dramis@gmail.com
- Changed License to GPL-2.0+ since some files compiled in the lib are GPL
(bnc#730195).
- Added GPL and LGPL license copies.
2011-10-16 - asterios.dramis@gmail.com
- Initial release (version 1.0.0).

See Also

Package Description
libKPropertyCore3-4-3.1.0-lp150.18.15.x86_64.rpm Core library for the Property editing framework
libKPropertyWidgets3-4-3.1.0-lp150.18.15.x86_64.rpm Editor Widget library for the property editing framework
libKReport3-4-3.1.0-lp150.25.256.x86_64.rpm The library for the Report Creation and generation Framework
libQtAV1-1.12.0-lp150.13.2.x86_64.rpm Qt multimedia framework library
libQtAVWidgets1-1.12.0-lp150.13.2.x86_64.rpm QtAV Widgets module
libSoQt20-1.5.0-lp150.2.1.x86_64.rpm SoQt is a library which provides the glue between Coin and Qt
libalkimia-devel-7.0-lp150.2.1.x86_64.rpm Development Files for libalkimia
libalkimia-devel-7.0.2-lp150.8.1.x86_64.rpm Development Files for libalkimia
libalkimia5-7-7.0-lp150.2.1.x86_64.rpm Library with common classes and functionality used by finance applications
libalkimia5-7-7.0.2-lp150.8.1.x86_64.rpm Library with common classes and functionality used by finance applications
libalkimia5-devel-7.0-lp150.2.1.x86_64.rpm Development Files for libalkimia5
libalkimia5-devel-7.0.2-lp150.8.1.x86_64.rpm Development Files for libalkimia5
libalkimia7-7.0-lp150.2.1.x86_64.rpm Library with common classes and functionality used by finance applications
libalkimia7-7.0.2-lp150.8.1.x86_64.rpm Library with common classes and functionality used by finance applications
libdcmtk3_6-3.6.3-lp150.62.1.x86_64.rpm DICOM Toolkit
Advertisement
Advertisement