lensfun-tools-0.3.2-lp150.28.1.x86_64.rpm


Advertisement

Description

lensfun-tools - Tools for managing lensfun data

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE KDE Extra all
Package name lensfun-tools
Package version 0.3.2
Package release lp150.28.1
Package architecture x86_64
Package type rpm
Installed size 21.30 KB
Download size 39.92 KB
Official Mirror ftp.gwdg.de
This package contains tools to fetch lens database updates and manage lens
adapters in lensfun.

Alternatives

Package Version Architecture Repository
lensfun-tools-0.3.2-lp150.3.4.x86_64.rpm 0.3.2 x86_64 openSUSE Oss
lensfun-tools - - -

Requires

Name Value
/usr/bin/env -
/usr/bin/python3 -
lensfun-data -
python3-lensfun = 0.3.2

Provides

Name Value
lensfun-tools = 0.3.2-lp150.28.1
lensfun-tools(x86-64) = 0.3.2-lp150.28.1

Download

Type URL
Binary Package lensfun-tools-0.3.2-lp150.28.1.x86_64.rpm
Source Package lensfun-0.3.2-lp150.28.1.src.rpm

Install Howto

  1. Add the openSUSE KDE Extra repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/KDE:/Extra/openSUSE_Leap_15.0/ opensuse-kde-extra
  2. Install lensfun-tools rpm package:
    # zypper install lensfun-tools

Files

Path
/usr/bin/g-lensfun-update-data
/usr/bin/lensfun-add-adapter
/usr/bin/lensfun-update-data
/usr/share/man/man1/g-lensfun-update-data.1.gz
/usr/share/man/man1/lensfun-add-adapter.1.gz
/usr/share/man/man1/lensfun-update-data.1.gz

Changelog

2017-11-30 - dimstar@opensuse.org
- Pass -DPYTHON_EXECUTABLE=%{_bindir}/python3 to cmake: ensure the
entire build uses python3.
2017-10-24 - asn@cryptomilk.org
- Add lensfun_fix_memory_leak.patch to add a virtual destructor to
avoid a memory leaks.
2017-07-20 - wbauer@tmo.at
- Add 0060-Various-CMake-patches-from-the-mailing-list.patch (taken
from Fedora) to only enable SSE/SSE2 on x86(_64), and only
compile those files with -msse/-msse2 that have specific SSE(2)
assembly code that's only used when SSE/SSE2 is actually
available on runtime
- Don't set the BUILD_FOR_SSE(2) compile options at all, they were
ON by default and above patch determines them automatically
depending on the architecture
2017-07-17 - tchvatal@suse.com
- Drop sse2 conditional, p4 is oldest supported by opensuse anyway
- Use %cmake macros to produce the package instead of hand
written approach
- Enable tests and add patch lensfun-test-database.patch
- Add patch lensfun-respect-DESTDIR.patch for py code to respect
destdir
- Split tools to separate subpackage tools
- Install properly python3 bindings
2016-05-05 - Mathias.Homann@opensuse.org
- update to version 0.3.2
Incremented binary version number
Improved vignetting interpolation
Internal code cleanups
Custom install directories can be configured by CMAKE_INSTALL_XXX variables (CMake GNUInstallDirs)
New LENSFUN_WINDOWS_DATADIR CMake variable for better windows compatibility
Support for parallel installation of different database versions
New interchangeable lenses:
Canon EF-S 10-18mm f/4.5-5.6 IS STM
Canon EF-S 24mm f/2.8 STM
Canon EF 24-70mm f/4L IS USM
Canon FDn 50mm 1:1.8
Canon FDn 24mm 1:2.8
Contax G Planar T* 2/35
Fujifilm XC 16-50mm f/3.5-5.6 OIS II
Fujifilm XC 50-230mm f/4.5-6.7 OIS II
Leica D Vario-Elmar 14-150mm f/3.5-5.6 Asph. OIS
Minolta MD Rokkor 50mm 1:1.4
1 Nikkor 18.5mm f/1.8
1 Nikkor 32mm f/1.2
Nikkor AF-S 20mm f/1.8G ED
Nikon Lens Series E 28mm f/2.8
Nikon Lens Series E 50mm f/1.8
Nikkor AF-S 85mm f/1.4G
Nikon Lens Series E 100mm f/2.8
Nikkor AF 105mm f/2.8D Micro
Nikkor AF-S 300mm f/4E PF ED VR
Olympus M.Zuiko Digital ED 7-14mm f/2.8 Pro
Olympus M.Zuiko Digital ED 8mm f/1.8 Fisheye Pro
Olympus 9mm Body Cap Lens Fisheye
Samyang 12mm f/2.8 Fish-Eye ED AS NCS
Samyang 35mm T1.5 Cine Lens
Sigma 70-300mm F4-5.6 DG Macro
Sony FE 28mm f/2
Sony FE 24-70mm f/4 ZA OSS
Sony FE 55mm f/1.8 ZA
Tamron 18-200mm f/3.5-6.3 Di III VC
Tamron SP AF 70-200mm f/2.8 Di LD (IF) Macro
Vivitar Series 1 70-210mm 1:3.5 SN 22...
Voigtländer Ultron 40mm f/2 SL-II Aspherical
New compact cameras:
AEE MagiCam SD19 (action cam)
Canon IXUS 125 HS
Canon PowerShot G7 X
Canon PowerShot S100
Canon PowerShot S110
Canon PowerShot SX130 IS
Canon PowerShot SX510 HS
GoPro HERO4 Silver
LG G4
Nikon Coolpix P7000
Panasonic DMC-FZ150
Panasonic DMC-LF1
Panasonic DMC-TZ71
Sony RX100 IV
New interchangable lens cameras:
Sony Alpha 7 II
Sony Alpha 77 II
Pentax K-3 II
Pentax K-S1
Pentax K-S2
Samsung NX mini
Additional/updated data for:
Canon EF-S 18-135mm f/3.5-5.6 IS STM
Canon EF 24mm f/2.8
Canon EF 24-70mm f/2.8L USM
Canon EF 50mm f/1.8 II
Nikon AF-S Nikkor 18-135mm f/3.5-5.6G DX IF-ED
Nikon AF-S Nikkor 20mm f/1.8G ED
Nikon AF Nikkor 20mm f/2.8D
Nikon AF-S Nikkor 50mm f/1.4G
Nikon AF-S Nikkor 50mm f/1.8G
Nikon AF-S Nikkor 28-300mm f/3.5-5.6G ED VR
Nikon AF-S Zoom-Nikkor 16-35mm f/4G ED VR
Nikon AF DX Fisheye-Nikkor 10.5mm f/2.8G ED
Samsung NX 45mm f/1.8 2D/3D
Sigma 12-24mm f/4.5-5.6 EX DG
Sony DT 16-50mm f/2.8 SSM
smc Pentax-A 28mm 1:2.8
Sony FE 24-70mm f/4 ZA OSS
Panasonic DMC-LX100
Canon PowerShot G7 X

See Also

Package Description
libKDb3-4-3.1.0-lp150.28.1.x86_64.rpm The library for the Database Connectivity and Creation Framework
libKF5MediaWiki5-5.37.0-lp150.7.1.x86_64.rpm Interface for MediaWiki based web services
libKF5Torrent6-2.1-lp150.2.1.x86_64.rpm Torrent Downloading Library
libKF5Vkontakte2-5.0.0-lp150.2.1.x86_64.rpm Library for asynchronous interaction with vkontakte.ru social network
libKPropertyCore3-4-3.1.0-lp150.18.15.x86_64.rpm Core library for the Property editing framework
libKPropertyWidgets3-4-3.1.0-lp150.18.15.x86_64.rpm Editor Widget library for the property editing framework
libKReport3-4-3.1.0-lp150.25.257.x86_64.rpm The library for the Report Creation and generation Framework
libQtAV1-1.12.0-lp150.13.2.x86_64.rpm Qt multimedia framework library
libQtAVWidgets1-1.12.0-lp150.13.2.x86_64.rpm QtAV Widgets module
libSoQt20-1.5.0-lp150.2.1.x86_64.rpm SoQt is a library which provides the glue between Coin and Qt
libalkimia-devel-7.0-lp150.2.1.x86_64.rpm Development Files for libalkimia
libalkimia-devel-7.0.2-lp150.8.1.x86_64.rpm Development Files for libalkimia
libalkimia5-7-7.0-lp150.2.1.x86_64.rpm Library with common classes and functionality used by finance applications
libalkimia5-7-7.0.2-lp150.8.1.x86_64.rpm Library with common classes and functionality used by finance applications
libalkimia5-devel-7.0-lp150.2.1.x86_64.rpm Development Files for libalkimia5
Advertisement
Advertisement