kio_recoll-1.24.1-lp150.3.1.x86_64.rpm


Advertisement

Description

kio_recoll - KIO slave for the Recoll full text search tool

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE KDE Extra all
Package name kio_recoll
Package version 1.24.1
Package release lp150.3.1
Package architecture x86_64
Package type rpm
Installed size 2.38 MB
Download size 802.33 KB
Official Mirror ftp.gwdg.de
Recoll is a personal full text search tool for Unix/Linux.
This package provides the kio-slave

Alternatives

Package Version Architecture Repository
kio_recoll - - -

Requires

Name Value
libKF5KIOCore.so.5()(64bit) -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.9)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.1)(64bit) -
libstdc++.so.6(CXXABI_1.3.5)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.14)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.17)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.18)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.22)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libxapian.so.30()(64bit) -
libz.so.1()(64bit) -
libz.so.1(ZLIB_1.2.0)(64bit) -
recoll = 1.24.1

Provides

Name Value
kio_recoll = 1.24.1-lp150.3.1
kio_recoll(x86-64) = 1.24.1-lp150.3.1
kio_recoll4 < 1.24.1

Obsoletes

Name Value
kio_recoll4 < 1.24.1

Download

Type URL
Binary Package kio_recoll-1.24.1-lp150.3.1.x86_64.rpm
Source Package kio_recoll-1.24.1-lp150.3.1.src.rpm

Install Howto

  1. Add the openSUSE KDE Extra repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/KDE:/Extra/openSUSE_Leap_15.0/ opensuse-kde-extra
  2. Install kio_recoll rpm package:
    # zypper install kio_recoll

Files

Path
/usr/lib64/qt5/plugins/kio_recoll.so
/usr/share/kio_recoll/help.html
/usr/share/kio_recoll/welcome.html
/usr/share/kservices5/recoll.protocol
/usr/share/kservices5/recollf.protocol

Changelog

2018-05-26 - christophe@krop.fr
- Update to 1.24.1:
* New snippets generation method.
* Fixed clicks on orthographic suggestions with Qt5.
* All input handlers should now be compatible with Python3, but
still use Python2.
Check the ChangeLog for the complete list of changes.
2017-03-25 - tittiatcoke@gmail.com
- Update to 1.23.1
- Input handler for ODF flat XML file formats.
- Configuration: some list configuration variables, namely
skippedNames, noContentSuffixes, and xallexcepts, have acquired
variants suffixed with + or - for adding or removing values from
the default value, which is a longish list, which hence does not
need to be copied for modification any more.
- New nomd5types variable for listing types of files for which we
should not compute an MD5 hash (used for duplicates detection).
See the manual for details. The default list excludes the audio
file types.
- Unicode BOM detection for text files
- Allow using full CSS style for term highlighting, not just color.
- execm input handlers now have an alternate method to set metadata
fields, easier than HTML meta fields.
2016-12-07 - tittiatcoke@gmail.com
- Update to 1.22.4
* Main features in 1.22.x
- It is now possible to define synonyms groups, used only at
query-time to expand the query terms to their defined synonyms.
- Many shell-script input handlers have been converted to Python
and are now persistent. Most are compatible with Python3.
- The Unix/Linux build system has been converted to use the
autotools in a fairly standard way.
- Make dehyphenation (co-worker->coworker in addition to the
normal terms) optional, active by default.
- For people using the Firefox web page indexer add-on: a new
tool in the GUI to list and delete entries from the Web cache.
- Improved index statistics in the GUI, and improved display
while the indexer is working.
* Bugfixes:
- Fix advanced search 'start search' button doing nothing
under qt5.
- Fix html escaping with newer versions of pdftotext.
- Small bug fix in the text splitter: which resulted in missing
results when matching a file name extension using.
- Added suffix associations for .java and .sql, to fix problems
caused by the switch from 'file' to 'xdg-mime'.
- Sidestep bus error in qt exit code by calling _exit() instead
of exit() in GUI exit code.
- GUI, advanced search: fix crash which occurred when restoring
clause list bigger than the default size (6 clauses).
2016-04-07 - tittiatcoke@gmail.com
- Update to 1.21.6
* KDE Frameworks5 compatibility for the KIO slave
* New Query parser
* Filters are executed in a different way for better performance
- Added kio_recoll4 package to provide a KIO slave for Konqueror
which is still KDE4 based

See Also

Package Description
kio_sysinfo-12.3-lp150.5.1.x86_64.rpm System Information KIO-Slave
kipi-plugins-5.9.0-lp150.189.2.x86_64.rpm KDE Plug-Ins for Image Manipulation
kipi-plugins-lang-5.9.0-lp150.189.2.noarch.rpm Translations for package digikam
kmarkdownwebview-0.5.3-lp150.16.1.x86_64.rpm KPart for rendering Markdown content
kmarkdownwebview-lang-0.5.3-lp150.16.1.noarch.rpm Translations for package kmarkdownwebview
kmetronome-1.0.0-lp150.1.1.x86_64.rpm Qt5 MIDI Metronome using ALSA Sequencer
kmplayer-0.12.0b-lp150.3.1.x86_64.rpm Simple Frontend for MPlayer/FFMpeg/Phonon and Video Player Plugin for Konqueror
kmplayer-lang-0.12.0b-lp150.3.1.noarch.rpm Translations for package kmplayer
kmymoney-5.0.1-lp150.54.1.x86_64.rpm A Personal Finance Manager by KDE
kmymoney-devel-5.0.1-lp150.54.1.x86_64.rpm Development Files for KMyMoney
kmymoney-lang-5.0.1-lp150.54.1.noarch.rpm Translations for package kmymoney
knemo-0.7.7git.20170520T005915~f3afe2e-lp150.20.1.x86_64.rpm The KDE Network Monitor
knemo-lang-0.7.7git.20170520T005915~f3afe2e-lp150.20.1.noarch.rpm Translations for package knemo
knights-2.5.0-lp150.1.1.x86_64.rpm A simple chess board for KDE 4
knights-lang-2.5.0-lp150.1.1.noarch.rpm Translations for package knights
Advertisement
Advertisement