saxon9-9.4.0.7-lp150.58.1.noarch.rpm


Advertisement

Description

saxon9 - The SAXON XSLT Processor from Michael Kay

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE JAVA all
Package name saxon9
Package version 9.4.0.7
Package release lp150.58.1
Package architecture noarch
Package type rpm
Installed size 2.24 MB
Download size 2.06 MB
Official Mirror ftp.gwdg.de
The most recent version of the open-source implementation of XSLT 2.0 and XPath
2.0, and XQuery 1.0. This provides the "basic" conformance level of these
languages: in effect, this provides all the features of the languages except
schema-aware processing. This version reflects the syntax of the final XSLT
2.0, XQuery 1.0, and XPath 2.0 Recommendations of 23 January 2007 as amended in
the second editions of those specifications where appropriate.

Alternatives

Package Version Architecture Repository
saxon9-9.4.0.7-lp150.2.15.noarch.rpm 9.4.0.7 noarch openSUSE Oss
saxon9 - - -

Requires

Name Value
bea-stax -
bea-stax-api -
java-headless -
javapackages-tools -

Provides

Name Value
jaxp_transform_impl = 9.4.0.7
mvn(net.sf.saxon:saxon) = 9.4.0.7
mvn(net.sf.saxon:saxon:pom:) = 9.4.0.7
saxon9 = 9.4.0.7-lp150.58.1
saxon9-dom = 9.4.0.7
saxon9-jdom = 9.4.0.7
saxon9-sql = 9.4.0.7
saxon9-xom = 9.4.0.7
saxon9-xpath = 9.4.0.7

Obsoletes

Name Value
saxon9-dom < 9.4.0.7
saxon9-jdom < 9.4.0.7
saxon9-sql < 9.4.0.7
saxon9-xom < 9.4.0.7
saxon9-xpath < 9.4.0.7

Download

Type URL
Binary Package saxon9-9.4.0.7-lp150.58.1.noarch.rpm
Source Package saxon9-9.4.0.7-lp150.58.1.src.rpm

Install Howto

  1. Add the openSUSE JAVA repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/Java:/packages/openSUSE_Leap_15.0/ opensuse-java
  2. Install saxon9 rpm package:
    # zypper install saxon9

Files

Path
/etc/alternatives/jaxp_transform_impl.jar
/usr/share/java/jaxp_transform_impl.jar
/usr/share/java/saxon9.jar
/usr/share/maven-metadata/saxon9.xml
/usr/share/maven-poms/JPP-saxon9.pom

Changelog

2017-09-18 - fstrba@suse.com
- We don't need to specify -Xdoclint:none, since doclint is
disabled by default
2017-09-10 - fstrba@suse.com
- Specify java source and target level 1.6 in order to allow
building with jdk9
- Disable doclint when building the documentation, since jdk9's
javadoc bails out on errors
2017-05-19 - dziolkowski@suse.com
- New build dependency: javapackages-local
2015-03-18 - tchvatal@suse.com
- Fix build with new javapackages-tools
2014-07-11 - tchvatal@suse.com
- Fix update-alternatives code here.
2014-06-27 - tchvatal@suse.com
- No need to depend on java-javadoc, resolves conflict on SLE11
2013-09-11 - mvyskocil@suse.com
- use add_maven_depmap from javapackages-tools
2013-09-09 - tchvatal@suse.com
- Move from jpackage-utils to javapackage-tools
2013-07-12 - toms@opensuse.org
-  Added Recommends for saxon9-scripts and xml-commons-resolver
Usually Saxon9 is used by invocation from a Shell, thus it
is more convenient to have the corresponding script installed
already.
Additionally, XML tools like Saxon needs also XML catalog support
for mapping URIs to local paths (especially useful for DocBook users)
2013-04-05 - idonmez@suse.com
- Add Source URL, see https://en.opensuse.org/SourceUrls

See Also

Package Description
saxon9-demo-9.4.0.7-lp150.58.1.noarch.rpm Demos for saxon9
saxon9-javadoc-9.4.0.7-lp150.58.1.noarch.rpm Javadoc for saxon9
saxon9-manual-9.4.0.7-lp150.58.1.noarch.rpm Manual for saxon9
saxon9-scripts-9.4.0.7-lp150.58.1.noarch.rpm Utility scripts for saxon9
saxpath-1.0_FCS-lp150.56.1.noarch.rpm SAXPath is an event-based API for XPath parsers
schemaspy-5.0.0-lp150.17.1.noarch.rpm Tool for analyzing and graphing database schemas
scirenderer-1.1.0-lp150.13.1.noarch.rpm A Java rendering library based on JoGL
scirenderer-javadoc-1.1.0-lp150.13.1.noarch.rpm Javadoc for scirenderer
servletapi3-3.3.1-lp150.583.1.noarch.rpm Java servlet and JSP implementation classes
servletapi3-javadoc-3.3.1-lp150.583.1.noarch.rpm Javadoc for servletapi3
servletapi4-4.0.4-lp150.586.1.noarch.rpm Java servlet and JSP implementation classes
servletapi4-javadoc-4.0.4-lp150.586.1.noarch.rpm Javadoc for servletapi4
servletapi5-5.0.18-lp150.557.1.noarch.rpm Java servlet and JSP implementation classes
skinlf-6.7-lp150.16.1.noarch.rpm Allows developers to write skinnable application using the Swing toolkit
skinlf-demo-6.7-lp150.16.1.noarch.rpm Examples for skinlf
Advertisement
Advertisement