sat4j-2.3.2-lp150.46.1.noarch.rpm


Advertisement

Description

sat4j - A library of SAT solvers written in Java

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE JAVA all
Package name sat4j
Package version 2.3.2
Package release lp150.46.1
Package architecture noarch
Package type rpm
Installed size 388.67 KB
Download size 348.04 KB
Official Mirror ftp.gwdg.de
The aim of the SAT4J library is to provide an efficient library of SAT
solvers in Java. The SAT4J library targets first users of SAT "black
boxes", those willing to embed SAT technologies into their application
without worrying about the details.

Alternatives

Package Version Architecture Repository
sat4j-2.3.2-lp150.1.3.noarch.rpm 2.3.2 noarch openSUSE Oss
sat4j - - -

Requires

Name Value
java -

Provides

Name Value
sat4j = 2.3.2-lp150.46.1

Download

Type URL
Binary Package sat4j-2.3.2-lp150.46.1.noarch.rpm
Source Package sat4j-2.3.2-lp150.46.1.src.rpm

Install Howto

  1. Add the openSUSE JAVA repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/Java:/packages/openSUSE_Leap_15.0/ opensuse-java
  2. Install sat4j rpm package:
    # zypper install sat4j

Files

Path
/usr/share/java/org.sat4j.core-2.3.2.jar
/usr/share/java/org.sat4j.core.jar
/usr/share/java/org.sat4j.pb-2.3.2.jar
/usr/share/java/org.sat4j.pb.jar

Changelog

2017-09-20 - fstrba@suse.com
- Added patches:
* sat4j-sourcetarget.patch
+ make the java source and target level consistent with what
is specified on command-line
+ specify the UTF-8 encoding of the source files
* sat4j-manifest.patch
+ fix rpmlint warning about Class-path in manifest
+ remove all mentions of Class-path from MANIFEST.MF files
2017-05-21 - tchvatal@suse.com
- Remove un-needed dependencies
2014-06-27 - tchvatal@suse.com
- Fix build on SLE11
2013-09-09 - tchvatal@suse.com
- Move from jpackage-utils to javapackage-tools
2012-10-18 - p.drouand@gmail.com
- Update to 2.3.2 version :
* Bug [SAT-55] Fix memory leak in case of repeated use of Sat4j in an application
* Bug [SAT-60] ClassCastException when a class implements Propagatable but not Constr watches a conflicting literal
* Improvement [SAT-38] Investigate usage of plain CNF rather than custom cardinality of PB constraints
* Improvement [SAT-59] Use package-info.java instead of package.html for package JavaDoc
* Improvement [SAT-67] Concurrent calls to isSatisfiable
* New Feature [SAT-56] Allow the end user to visualize the search of the solvers
* New Feature [SAT-63] Make Java 1.5 binaries instead of 1.4
* New Feature [SAT-71] Add statistics in ManyCore solvers on the solvers that answers
* Sub-task    [SAT-51] Allow usage of Lower Bounding on Sat4j PB command line
2012-06-18 - mvyskocil@suse.cz
- fix a build with jdk7 (-Dtarget)
2009-07-29 - mvyskocil@suse.cz
- Don't use release date to make number of Factory rebuilds smaller
2009-06-02 - mvyskocil@suse.cz
- Initial packaging of sat4j 2.0.3 in openSUSE

See Also

Package Description
saxon6-6.5.5-lp150.39.1.noarch.rpm The SAXON XSLT Processor from Michael Kay
saxon6-aelfred-6.5.5-lp150.39.1.noarch.rpm Java XML parser
saxon6-demo-6.5.5-lp150.39.1.noarch.rpm Demos for saxon6
saxon6-fop-6.5.5-lp150.39.1.noarch.rpm FOP support for saxon6
saxon6-javadoc-6.5.5-lp150.39.1.noarch.rpm Javadoc for saxon6
saxon6-jdom-6.5.5-lp150.39.1.noarch.rpm JDOM support for saxon6
saxon6-manual-6.5.5-lp150.39.1.noarch.rpm Manual for saxon6
saxon6-scripts-6.5.5-lp150.39.1.noarch.rpm Utility scripts for saxon6
saxon8-B.8.8-lp150.252.1.noarch.rpm Java Basic XPath 2.0, XSLT 2.0, and XQuery 1.0 implementation
saxon8-demo-B.8.8-lp150.252.1.noarch.rpm Demos for saxon8
saxon8-dom-B.8.8-lp150.252.1.noarch.rpm DOM support for saxon8
saxon8-javadoc-B.8.8-lp150.252.1.noarch.rpm Javadoc for saxon8
saxon8-jdom-B.8.8-lp150.252.1.noarch.rpm JDOM support for saxon8
saxon8-manual-B.8.8-lp150.252.1.noarch.rpm Manual for saxon8
saxon8-scripts-B.8.8-lp150.252.1.noarch.rpm Utility scripts for saxon8
Advertisement
Advertisement