avalon-logkit-2.1-lp150.50.1.noarch.rpm


Advertisement

Description

avalon-logkit - Java logging toolkit

Property Value
Distribution openSUSE Leap 15.0
Repository openSUSE JAVA all
Package name avalon-logkit
Package version 2.1
Package release lp150.50.1
Package architecture noarch
Package type rpm
Installed size 95.73 KB
Download size 86.79 KB
Official Mirror ftp.gwdg.de
LogKit is a logging toolkit designed for secure performance oriented
logging in applications. To get started using LogKit, it is recomended
that you read the whitepaper and browse the API docs.

Alternatives

Package Version Architecture Repository
avalon-logkit-2.1-lp150.1.13.noarch.rpm 2.1 noarch openSUSE Oss
avalon-logkit - - -

Requires

Name Value
java-headless -
javapackages-tools -
jms -
servlet >= 3.0

Provides

Name Value
avalon-logkit = 2.1-lp150.50.1
mvn(avalon-logkit:avalon-logkit) = 2.1
mvn(avalon-logkit:avalon-logkit:pom:) = 2.1
mvn(logkit:logkit) = 2.1
mvn(logkit:logkit:pom:) = 2.1
mvn(org.apache.avalon.logkit:avalon-logkit) = 2.1
mvn(org.apache.avalon.logkit:avalon-logkit:pom:) = 2.1

Download

Type URL
Binary Package avalon-logkit-2.1-lp150.50.1.noarch.rpm
Source Package avalon-logkit-2.1-lp150.50.1.src.rpm

Install Howto

  1. Add the openSUSE JAVA repository:
    # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/Java:/packages/openSUSE_Leap_15.0/ opensuse-java
  2. Install avalon-logkit rpm package:
    # zypper install avalon-logkit

Files

Path
/usr/share/doc/packages/avalon-logkit/LICENSE.txt
/usr/share/doc/packages/avalon-logkit/NOTICE.txt
/usr/share/java/avalon-logkit.jar
/usr/share/maven-metadata/avalon-logkit.xml
/usr/share/maven-poms/JPP-avalon-logkit.pom

Changelog

2018-05-15 - fstrba@suse.com
- Build with source and target 8 to prepare for a possible removal
of 1.6 compatibility
2017-09-15 - jengelh@inai.de
- RPM group and minor spelling fix. Replacement of
- exec rm by -delete.
2017-09-15 - fstrba@suse.com
- Fix build with jdk9 by specifying java source and target 1.6
- Clean spec file
2017-05-21 - tchvatal@suse.com
- Remove unneeded dependencies
2017-05-19 - pcervinka@suse.com
- New build dependency: javapackages-local
2015-06-04 - dimstar@opensuse.org
- Also adjust Requires to be servlet >= 3.0 instead of servlet30.
2015-06-04 - dimstar@opensuse.org
- BuildRequire servlet >= 3.0 instead of 'servlet30'. Since tomcat
moved to version 8.0, it now provides 'servlet31' (which is fine,
as this is represented as servlet 3.1).
2015-03-18 - tchvatal@suse.com
- Fix build with new javapackages-tools
2014-06-27 - tchvatal@suse.com
- Cleanup with spec-cleaner
- Build on SLE11
2013-09-09 - tchvatal@suse.com
- Move from jpackage-utils to javapackage-tools

See Also

Package Description
avalon-logkit-javadoc-2.1-lp150.50.1.noarch.rpm Javadoc for avalon-logkit
axis-1.4-lp150.592.1.noarch.rpm Apache implementation of the SOAP
axis-manual-1.4-lp150.592.1.noarch.rpm Manual for axis
bcel-5.2-lp150.65.1.noarch.rpm Byte Code Engineering Library
bcel5_3-5.3-lp150.36.1.noarch.rpm Byte Code Engineering Library
bcel5_3-javadoc-5.3-lp150.36.1.noarch.rpm Javadoc for bcel5_3
bea-stax-1.2.0-lp150.63.1.noarch.rpm Streaming API for XML
bea-stax-api-1.2.0-lp150.63.1.noarch.rpm The StAX API
beansbinding-1.2.1-lp150.44.1.noarch.rpm Beans Binding (JSR 295) reference implementation
beansbinding-javadoc-1.2.1-lp150.44.1.noarch.rpm Beans Binding (JSR 295) reference implementation
berkeleydb-5.0.58-lp150.51.1.noarch.rpm Berkeley DB Java Edition
berkeleydb-demo-5.0.58-lp150.51.1.noarch.rpm Berkeley DB Java Edition
berkeleydb-javadoc-5.0.58-lp150.51.1.noarch.rpm Berkeley DB Java Edition
berkeleydb-manual-5.0.58-lp150.51.1.noarch.rpm Berkeley DB Java Edition
bouncycastle-1.60-lp150.59.1.noarch.rpm Bouncy Castle Crypto Package for Java
Advertisement
Advertisement