nvidia-gfxG03-kmp-default-340.107_k4.12.14_lp150.11-lp150.17.1.x86_64.rpm


Advertisement

Description

nvidia-gfxG03-kmp-default - NVIDIA graphics driver kernel module for GeForce 8xxx and newer GPUs

Property Value
Distribution openSUSE Leap 15.0
Repository nVidia drivers all
Package filename nvidia-gfxG03-kmp-default-340.107_k4.12.14_lp150.11-lp150.17.1.x86_64.rpm
Package name nvidia-gfxG03-kmp-default
Package version 340.107_k4.12.14_lp150.11
Package release lp150.17.1
Package architecture x86_64
Package type rpm
Category System/Kernel
Homepage https://www.nvidia.com/object/unix.html
License SUSE-NonFree
Maintainer -
Download size 3.57 MB
Installed size 28.08 MB
This package provides the closed-source NVIDIA graphics driver kernel
module for GeForce 8xxx and newer GPUs.

Alternatives

Package Version Architecture Repository
nvidia-gfxG03-kmp-default - - -

Requires

Name Value
coreutils -
gcc -
grep -
kernel-default-devel -
make -

Provides

Name Value
nvidia-gfxG03-kmp = 340.107
nvidia-gfxG03-kmp = 340.107_k4.12.14_lp150.11
nvidia-gfxG03-kmp-default = 340.107
nvidia-gfxG03-kmp-default = 340.107_k4.12.14_lp150.11-lp150.17.1
nvidia-gfxG03-kmp-default(x86-64) = 340.107_k4.12.14_lp150.11-lp150.17.1

Conflicts

Name Value
nvidia-gfx-kmp -
nvidia-gfxG01-kmp -
nvidia-gfxG02-kmp -

Obsoletes

Name Value
nvidia-gfx-kmp -
nvidia-gfxG01-kmp -
nvidia-gfxG02-kmp -
nvidia-gfxG03-kmp-desktop -
nvidia-gfxG03-kmp-trace -
nvidia-gfxG03-kmp-xen -

Download

Type URL
Mirror http.download.nvidia.com
Binary Package nvidia-gfxG03-kmp-default-340.107_k4.12.14_lp150.11-lp150.17.1.x86_64.rpm
Source Package nvidia-gfxG03-340.107-lp150.17.1.nosrc.rpm

Install Howto

  1. Add the nVidia drivers repository:
    # zypper addrepo http://http.download.nvidia.com/opensuse/leap/15.0/ nvidia
  2. Install nvidia-gfxG03-kmp-default rpm package:
    # zypper install nvidia-gfxG03-kmp-default

Files

Path
/etc/modprobe.d/nvidia-default.conf
/lib/modules/4.12.14-lp150.11-default/
/lib/modules/4.12.14-lp150.11-default/updates/nvidia.ko
/usr/lib/nvidia/alternate-install-present
/usr/lib/nvidia/alternate-install-present-default
/usr/src/kernel-modules/
/usr/src/kernel-modules/nvidia-340.107-default/Makefile
/usr/src/kernel-modules/nvidia-340.107-default/Module.supported
/usr/src/kernel-modules/nvidia-340.107-default/conftest.sh
/usr/src/kernel-modules/nvidia-340.107-default/cpuopsys.h
/usr/src/kernel-modules/nvidia-340.107-default/dkms.conf
/usr/src/kernel-modules/nvidia-340.107-default/g_nvreadme.h
/usr/src/kernel-modules/nvidia-340.107-default/gcc-version-check.c
/usr/src/kernel-modules/nvidia-340.107-default/nv-acpi.c
/usr/src/kernel-modules/nvidia-340.107-default/nv-chrdev.c
/usr/src/kernel-modules/nvidia-340.107-default/nv-cray.c
/usr/src/kernel-modules/nvidia-340.107-default/nv-dma.c
/usr/src/kernel-modules/nvidia-340.107-default/nv-drm.c
/usr/src/kernel-modules/nvidia-340.107-default/nv-frontend.c
/usr/src/kernel-modules/nvidia-340.107-default/nv-frontend.h
/usr/src/kernel-modules/nvidia-340.107-default/nv-gvi.c
/usr/src/kernel-modules/nvidia-340.107-default/nv-i2c.c
/usr/src/kernel-modules/nvidia-340.107-default/nv-kernel.o
/usr/src/kernel-modules/nvidia-340.107-default/nv-linux.h
/usr/src/kernel-modules/nvidia-340.107-default/nv-memdbg.h
/usr/src/kernel-modules/nvidia-340.107-default/nv-mempool.c
/usr/src/kernel-modules/nvidia-340.107-default/nv-misc.h
/usr/src/kernel-modules/nvidia-340.107-default/nv-mmap.c
/usr/src/kernel-modules/nvidia-340.107-default/nv-p2p.c
/usr/src/kernel-modules/nvidia-340.107-default/nv-p2p.h
/usr/src/kernel-modules/nvidia-340.107-default/nv-pat.c
/usr/src/kernel-modules/nvidia-340.107-default/nv-pat.h
/usr/src/kernel-modules/nvidia-340.107-default/nv-procfs.c
/usr/src/kernel-modules/nvidia-340.107-default/nv-proto.h
/usr/src/kernel-modules/nvidia-340.107-default/nv-reg.h
/usr/src/kernel-modules/nvidia-340.107-default/nv-usermap.c
/usr/src/kernel-modules/nvidia-340.107-default/nv-vm.c
/usr/src/kernel-modules/nvidia-340.107-default/nv-vtophys.c
/usr/src/kernel-modules/nvidia-340.107-default/nv.c
/usr/src/kernel-modules/nvidia-340.107-default/nv.h
/usr/src/kernel-modules/nvidia-340.107-default/nv_gpu_ops.h
/usr/src/kernel-modules/nvidia-340.107-default/nv_uvm_interface.c
/usr/src/kernel-modules/nvidia-340.107-default/nv_uvm_interface.h
/usr/src/kernel-modules/nvidia-340.107-default/nverror.h
/usr/src/kernel-modules/nvidia-340.107-default/nvgputypes.h
/usr/src/kernel-modules/nvidia-340.107-default/nvidia-modules-common.mk
/usr/src/kernel-modules/nvidia-340.107-default/nvtypes.h
/usr/src/kernel-modules/nvidia-340.107-default/os-interface.c
/usr/src/kernel-modules/nvidia-340.107-default/os-interface.h
/usr/src/kernel-modules/nvidia-340.107-default/os-mlock.c
/usr/src/kernel-modules/nvidia-340.107-default/os-pci.c
/usr/src/kernel-modules/nvidia-340.107-default/os-registry.c
/usr/src/kernel-modules/nvidia-340.107-default/os-smp.c
/usr/src/kernel-modules/nvidia-340.107-default/os-usermap.c
/usr/src/kernel-modules/nvidia-340.107-default/rmil.h
/usr/src/kernel-modules/nvidia-340.107-default/rmretval.h
/usr/src/kernel-modules/nvidia-340.107-default/xapi-sdk.h

Changelog

2019-08-19 - Stefan Dirsch <sndirsch@suse.com>
- moved exit from %post snippet file to specfile after running
weak-modules2 (boo#1145316)
2019-07-08 - Stefan Dirsch <sndirsch@suse.com>
- kmp-post.sh/kmp-trigger.sh
* exit with error code 1 from %post/%trigger, if kernel module
build/install fails (boo#1131028)
2019-07-02 - Stefan Dirsch <sndirsch@suse.com>
- no longer touch xorg.conf on suse >= sle12
2019-06-13 - Stefan Dirsch <sndirsch@suse.com>
- making use of parallel builds with make's -j option
2018-10-12 - sndirsch@suse.com
- let nvidia-glG03 %post-require xorg-x11-server, since on
Optimus we want to switch back to X.Org's libglx.so (bsc#1111471)
2018-10-12 - sndirsch@suse.com
- let nvidia-glG03 recommend the following packages:
* Mesa-libGL1
* Mesa-libEGL1
* Mesa-libGLESv1_CM1
* Mesa-libGLESv2-2
This is needed for Optimus systems once NVIDIA's GL libs get disabled
(our default); these packages won't get installed when adding NVIDIA's
repository before the installation, which e.g. happens on SLED
(bsc#1111471)
2018-09-23 - sndirsch@suse.com
- no longer alter, i.e. strip NVIDIA's libraries
2018-06-07 - sndirsch@suse.com
- update to version 340.106
* Updated nvidia-installer in the 340.xx legacy driver series to default
to installing the driver without the NVIDIA Unified Memory kernel
module if this module fails to build at installation time. The 340.xx
legacy Unified Memory kernel module is incompatible with recent Linux
kernels, and the GPU hardware generations that the 340.xx legacy driver
series is intended to support do not support Unified Memory.
* Added support for X.Org xserver ABI 24 (xorg-server 1.20).
* Improved nvidia-bug-report.sh to check for kern.log which is the default
kernel log-file location for many Debian-based Linux distributions.
* Fixed a bug which could cause X servers that export a Video Driver
ABI earlier than 0.8 to crash when running X11 applications which
call XRenderAddTraps().
2018-05-23 - sndirsch@suse.com
- generate-service-file.sh: use https instead of ftp ...
- _service: updated via generate-service-file.sh
2018-05-17 - sndirsch@suse.com
- workaround build failure of kernelrelease target on sle12-sp4
(boo#1093333)

See Also

Package Description
nvidia-gfxG04-kmp-default-390.129_k4.12.14_lp150.11-lp150.6.1.x86_64.rpm NVIDIA graphics driver kernel module for GeForce 400 series and newer
nvidia-gfxG05-kmp-default-435.21_k4.12.14_lp150.11-lp150.19.1.x86_64.rpm NVIDIA graphics driver kernel module for GeForce 600 series and newer
nvidia-glG03-340.107-lp150.17.1.x86_64.rpm NVIDIA GL libraries for OpenGL acceleration
nvidia-glG04-390.129-lp150.6.1.x86_64.rpm NVIDIA OpenGL libraries for OpenGL acceleration
nvidia-glG05-435.21-lp150.19.1.x86_64.rpm NVIDIA OpenGL libraries for OpenGL acceleration
nvidia-uvm-gfxG03-kmp-default-340.107_k4.12.14_lp150.11-lp150.17.1.x86_64.rpm NVIDIA Unified Memory kernel module
x11-video-nvidiaG03-340.107-lp150.17.1.x86_64.rpm NVIDIA graphics driver for GeForce 8xxx and newer GPUs
x11-video-nvidiaG04-390.129-lp150.6.1.x86_64.rpm NVIDIA graphics driver for GeForce 400 series and newer
x11-video-nvidiaG05-435.21-lp150.19.1.x86_64.rpm NVIDIA graphics driver for GeForce 600 series and newer
Advertisement
Advertisement