ffmpeg-4-libavformat-devel-4.1.3-lp150.66.1.x86_64.rpm


Advertisement

Description

ffmpeg-4-libavformat-devel - Development files for FFmpeg's stream format library

Property Value
Distribution openSUSE Leap 15.0
Repository Multimedia Libs all
Package filename ffmpeg-4-libavformat-devel-4.1.3-lp150.66.1.x86_64.rpm
Package name ffmpeg-4-libavformat-devel
Package version 4.1.3
Package release lp150.66.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage https://ffmpeg.org/
License LGPL-2.1-or-later AND GPL-2.0-or-later
Maintainer -
Download size 91.25 KB
Installed size 152.67 KB
The libavformat library provides a generic framework for multiplexing
and demultiplexing (muxing and demuxing) audio, video and subtitle
streams. It encompasses multiple muxers and demuxers for multimedia
container formats.
This subpackage contains the headers for FFmpeg libavformat.

Alternatives

Package Version Architecture Repository
ffmpeg-4-libavformat-devel-4.0.2-lp150.19.6.x86_64.rpm 4.0.2 x86_64 Packman
ffmpeg-4-libavformat-devel-4.0.2-lp150.19.5.armv7hl.rpm 4.0.2 armv7hl Packman
ffmpeg-4-libavformat-devel-4.0.2-lp150.19.5.aarch64.rpm 4.0.2 aarch64 Packman
ffmpeg-4-libavformat-devel-4.0.2-lp150.13.1.x86_64.rpm 4.0.2 x86_64 openSUSE Update Oss
ffmpeg-4-libavformat-devel-4.0.1-lp150.10.1.x86_64.rpm 4.0.1 x86_64 openSUSE Update Oss
ffmpeg-4-libavformat-devel-4.0.1-lp150.7.1.x86_64.rpm 4.0.1 x86_64 openSUSE Update Oss
ffmpeg-4-libavformat-devel-4.0.1-lp150.3.1.x86_64.rpm 4.0.1 x86_64 openSUSE Update Test
ffmpeg-4-libavformat-devel-4.0.1-lp150.2.2.x86_64.rpm 4.0.1 x86_64 openSUSE Update Oss
ffmpeg-4-libavformat-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
ffmpeg-4-libavcodec-devel = 4.1.3-lp150.66.1
ffmpeg-4-libavutil-devel = 4.1.3-lp150.66.1
ffmpeg-4-libswresample-devel = 4.1.3-lp150.66.1
libavformat58 = 4.1.3-lp150.66.1
pkgconfig(libavcodec) >= 58.35.100
pkgconfig(libavutil) >= 56.22.100
pkgconfig(libswresample) >= 3.3.100

Provides

Name Value
ffmpeg-4-libavformat-devel = 4.1.3-lp150.66.1
ffmpeg-4-libavformat-devel(x86-64) = 4.1.3-lp150.66.1
libavformat-devel = 4.1.3-lp150.66.1
pkgconfig(libavformat) = 58.20.100

Conflicts

Name Value
ffmpeg-private-devel < 4
ffmpeg-private-devel >= 5
libavcodec-devel < 4
libavcodec-devel >= 5
libavdevice-devel >= 5
libavdevice-devel < 4
libavfilter-devel < 4
libavfilter-devel >= 5
libavformat-devel < 4
libavformat-devel >= 5
libavresample-devel < 4
libavresample-devel >= 5
libavutil-devel >= 5
libavutil-devel < 4
libpostproc-devel < 4
libpostproc-devel >= 5
libswresample-devel < 4
libswresample-devel >= 5
libswscale-devel < 4
libswscale-devel >= 5

Obsoletes

Name Value
libavformat-devel < 4.1.3-lp150.66.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ffmpeg-4-libavformat-devel-4.1.3-lp150.66.1.x86_64.rpm
Source Package ffmpeg-4-4.1.3-lp150.66.1.src.rpm

Install Howto

  1. Add the Multimedia Libs repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/libs/openSUSE_Leap_15.0/ multimedia-libs
  2. Install ffmpeg-4-libavformat-devel rpm package:
    # zypper install ffmpeg-4-libavformat-devel

Files

Path
/usr/include/ffmpeg/
/usr/include/ffmpeg/libavformat/avformat.h
/usr/include/ffmpeg/libavformat/avio.h
/usr/include/ffmpeg/libavformat/version.h
/usr/lib64/libavformat.so
/usr/lib64/pkgconfig/libavformat.pc
/usr/share/man/man3/libavformat.3.gz

Changelog

2019-05-03 - Jan Engelhardt <jengelh@inai.de>
- Throw out svt-av1. The build is unable to complete
in openSUSE:Factory.
2019-05-02 - Martin Li?ka <mliska@suse.cz>
- Use %make_build in order to provide parallel build for tools/*.
And make output verbose.
2019-05-02 - Martin Li?ka <mliska@suse.cz>
- Enable LTO for new SUSE versions (boo#1133123).
2019-04-30 - Hans-Peter Jansen <hpj@urpla.net>
- Update patch 0001-Add-ability-for-ffmpeg-to-run-svt-av1.patch
from upstream
2019-04-02 - seanlew@opensuse.org
- Update to version 4.1.3:
* Updates and bug fixes for codecs, filters and formats.
[boo#1133153, boo#1133155, CVE-2019-11338, CVE-2019-11339]
2019-03-28 - Bjørn Lie <bjorn.lie@gmail.com>
- Update to version 4.1.2:
* Updates and bug fixes for codecs, filters and formats.
2019-03-17 - Bjørn Lie <bjorn.lie@gmail.com>
- Add ffmpeg-avcodec-libdav1d-AV1-decoder-wrapper.patch: Backport
dav1d decoder support for aom (av1) codec. Following this, add
conditional pkgconfig(dav1d) BuildRequires and pass conditional
- -enable-libdav1d to configure. Also add libdav1d to
enable_decoders.
2019-03-09 - Bjørn Lie <bjorn.lie@gmail.com>
- Add a new filter line to rpmlintrc
(addFilter("no-dependency-on ffmpeg-4-lib*")).
2019-03-04 - John Vandenberg <jayvdb@gmail.com>
- Add trivial encoder rawvideo, already enabled in decoders
2019-03-02 - Jan Engelhardt <jengelh@inai.de>
- Unconditionalize bs2b, it exists in openSUSE 13.x too.

See Also

Package Description
ffmpeg-4-libavresample-devel-4.1.3-lp150.66.1.x86_64.rpm Development files for libavresample as present in FFmpeg
ffmpeg-4-libavutil-devel-4.1.3-lp150.66.1.x86_64.rpm Development files for FFmpeg's utility library
ffmpeg-4-libpostproc-devel-4.1.3-lp150.66.1.x86_64.rpm Development files for the FFmpeg post-processing library
ffmpeg-4-libswresample-devel-4.1.3-lp150.66.1.x86_64.rpm Development files for the FFmpeg software resampling library
ffmpeg-4-libswscale-devel-4.1.3-lp150.66.1.x86_64.rpm Development files for FFmpeg's image scaling and colorspace library
ffmpeg-4-private-devel-4.1.3-lp150.66.1.x86_64.rpm Some FFmpeg private headers
ffmsindex-2.23.1-lp150.4.18.x86_64.rpm Wrapper library around libffmpeg
ffnvcodec-devel-8.2.15.7-lp150.13.1.x86_64.rpm FFmpeg version of NVIDIA codec API headers
fftw3-devel-3.3.8-lp150.88.6.x86_64.rpm Include Files and Libraries mandatory for Development
fftw3-gnu-hpc-devel-3.3.8-lp150.88.6.x86_64.rpm Dependency package for fftw3_3_3_8-gnu-hpc-devel
fftw3-gnu-mpich-hpc-devel-3.3.8-lp150.88.6.x86_64.rpm Dependency package for fftw3_3_3_8-gnu-mpich-hpc-devel
fftw3-gnu-mvapich2-hpc-devel-3.3.8-lp150.88.6.x86_64.rpm Dependency package for fftw3_3_3_8-gnu-mvapich2-hpc-devel
fftw3-gnu-openmpi1-hpc-devel-3.3.8-lp150.88.6.x86_64.rpm Dependency package for fftw3_3_3_8-gnu-openmpi1-hpc-devel
fftw3-gnu-openmpi2-hpc-devel-3.3.8-lp150.88.6.x86_64.rpm Dependency package for fftw3_3_3_8-gnu-openmpi2-hpc-devel
fftw3-gnu-openmpi3-hpc-devel-3.3.8-lp150.88.6.x86_64.rpm Dependency package for fftw3_3_3_8-gnu-openmpi3-hpc-devel
Advertisement
Advertisement