suil-plugin-x11-0.10.0-lp150.22.2.x86_64.rpm


Advertisement

Description

suil-plugin-x11 - Shared object for X11 LV2 GUIs

Property Value
Distribution openSUSE Leap 15.0
Repository Multimedia Apps all
Package name suil-plugin-x11
Package version 0.10.0
Package release lp150.22.2
Package architecture x86_64
Package type rpm
Installed size 7.11 KB
Download size 13.98 KB
Official Mirror widehat.opensuse.org
Module plugin for:
* X11 LV2 GUIs using suil

Alternatives

Package Version Architecture Repository
suil-plugin-x11-0.10.0-lp150.21.2.x86_64.rpm 0.10.0 x86_64 Multimedia Libs
suil-plugin-x11-0.10.0-lp150.2.1.x86_64.rpm 0.10.0 x86_64 openSUSE Oss
suil-plugin-x11 - - -

Requires

Name Value
libX11.so.6()(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libsuil-0-0 = 0.10.0

Provides

Name Value
libsuil_x11.so()(64bit) -
suil-plugin-x11 = 0.10.0-lp150.22.2
suil-plugin-x11(x86-64) = 0.10.0-lp150.22.2

Download

Type URL
Binary Package suil-plugin-x11-0.10.0-lp150.22.2.x86_64.rpm
Source Package suil-0.10.0-lp150.22.2.src.rpm

Install Howto

  1. Add the Multimedia Apps repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/multimedia:/apps/openSUSE_Leap_15.0/ multimedia-apps
  2. Install suil-plugin-x11 rpm package:
    # zypper install suil-plugin-x11

Files

Path
/usr/lib64/suil-0/libsuil_x11.so
/usr/share/doc/packages/suil-plugin-x11/COPYING
/usr/share/doc/packages/suil-plugin-x11/README

Changelog

2018-02-18 - jengelh@inai.de
- Fix SRPM group.
2018-02-15 - aloisio@gmx.com
- Fixed supplements lines
2018-02-14 - aloisio@gmx.com
- Update to version 0.10.0
* Add support for X11 in Gtk3
* Add support for Qt5 in Gtk2
* Add suil_init() to support early initialization and passing
any necessary information that may be needed in the future
(thanks Stefan Westerfeld)
* Fix minor memory errors
* Fix building with X11 against custom LV2 install path (thanks
Robin Gareus)
version 0.8.4
* Configure based on compiler target OS for cross-compilation
* Add Cocoa in Gtk wrapper (patch from Robin Gareus)
* Various Windows fixes (patches from Robin Gareus)
* Center X11 UIs in Gtk (patch from Robin Gareus)
* Fix initial size of resizable X11 UIs in Gtk (patch from
Robin Gareus)
* Bubble X11 key events up to Gtk parent (patch from Filipe
Coelho)
* Add Gtk2 and X11 in Qt5 wrappers (patch from Rui Nuno Capela)
* Fix compilation with -Wl,--no-undefined
* Fix a few minor/unlikely memory errors
* Gracefully handle failure to open wrapper
* Only report suil_ui_supported() if necessary wrapper is
compiled in
* Upgrade to waf 1.8.14
- Dropped qt4 plugins
- Split plugins into separate packages so that only actually
required libraries are pulled in
2015-12-12 - davejplater@gmail.com
- Packaged plugin modules in plugins package
2014-08-09 - Rui Nuno Capela <rncbc@rncbc.org> - 0.8.2-10
- New upstream release.
suil (0.8.2) stable;
* Fix embedding several Qt UIs in Gtk
* Add configure options to disable all Gtk or Qt support
* Upgrade to waf 1.7.16

See Also

Package Description
suil-plugin-x11-in-gtk2-0.10.0-lp150.22.2.x86_64.rpm Shared object for GTK2 hosts displaying X11 LV2 GUIs
suil-plugin-x11-in-gtk3-0.10.0-lp150.22.2.x86_64.rpm Shared object for GTK3 hosts displaying X11 LV2 GUIs
suil-plugin-x11-in-qt5-0.10.0-lp150.22.2.x86_64.rpm Shared object for Qt5 hosts displaying X11 LV2 GUIs
supercollider-3.8.0-lp150.2.14.x86_64.rpm Programming environment for audio synthesis and composition
supercollider-ambiem-3.6-lp150.2.3.noarch.rpm Ambisonics classes for SuperCollider
supercollider-cruciallib-3.6-lp150.2.3.noarch.rpm Higher level interfaces for managing musical objects
supercollider-devel-3.8.0-lp150.2.14.x86_64.rpm Development files for SuperCollider
supercollider-dewdrop-3.6-lp150.2.3.noarch.rpm DewDrop external collection for SuperCollider
supercollider-emacs-3.8.0-lp150.2.14.x86_64.rpm SuperCollider support for Emacs
supercollider-gedit-3.8.0-lp150.2.14.x86_64.rpm SuperCollider support for GEdit
supercollider-mathlib-3.6-lp150.2.3.noarch.rpm Useful classes for SuperCollider
supercollider-quarks-3.6-lp150.2.3.noarch.rpm Local Quarks repository for SuperCollider
supercollider-reduniverse-3.6-lp150.2.3.noarch.rpm Sonification and visualization of dynamic systems
supercollider-sc3-plugins-3.6-lp150.7.10.x86_64.rpm Collection of SuperCollider plugins
supercollider-vim-3.8.0-lp150.2.14.x86_64.rpm SuperCollider support for Vim
Advertisement
Advertisement