ktexteditor-5.58.0-lp150.185.1.x86_64.rpm


Advertisement

Description

ktexteditor - Embeddable text editor component

Property Value
Distribution openSUSE Leap 15.0
Repository KDE Frameworks 5 all
Package filename ktexteditor-5.58.0-lp150.185.1.x86_64.rpm
Package name ktexteditor
Package version 5.58.0
Package release lp150.185.1
Package architecture x86_64
Package type rpm
Category System/GUI/KDE
Homepage https://www.kde.org
License LGPL-2.1-or-later
Maintainer -
Download size 1.23 MB
Installed size 3.74 MB
KTextEditor provides a text editor component that can be embedded in
applications, either as a KPart or using the KF5::TextEditor library.

Alternatives

Package Version Architecture Repository
ktexteditor-5.58.0git.20190502T151313~743cbe13-ku.84.1.x86_64.rpm 5.58.0git.20190502T151313~743cbe13 x86_64 KDE Frameworks Unstable
ktexteditor-5.45.0-lp150.1.1.x86_64.rpm 5.45.0 x86_64 openSUSE Oss
ktexteditor - - -

Requires

Name Value
/sbin/ldconfig -
libKF5Archive.so.5()(64bit) -
libKF5AuthCore.so.5()(64bit) -
libKF5Codecs.so.5()(64bit) -
libKF5Completion.so.5()(64bit) -
libKF5ConfigCore.so.5()(64bit) -
libKF5ConfigGui.so.5()(64bit) -
libKF5ConfigWidgets.so.5()(64bit) -
libKF5CoreAddons.so.5()(64bit) -
libKF5GuiAddons.so.5()(64bit) -
libKF5I18n.so.5()(64bit) -
libKF5IconThemes.so.5()(64bit) -
libKF5ItemViews.so.5()(64bit) -
libKF5JobWidgets.so.5()(64bit) -
libKF5KIOCore.so.5()(64bit) -
libKF5KIOWidgets.so.5()(64bit) -
libKF5Parts.so.5()(64bit) -
libKF5SonnetCore.so.5()(64bit) -
libKF5SonnetUi.so.5()(64bit) -
libKF5SyntaxHighlighting.so.5()(64bit) -
libKF5TextWidgets.so.5()(64bit) -
libKF5WidgetsAddons.so.5()(64bit) -
libKF5XmlGui.so.5()(64bit) -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.12)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5PrintSupport.so.5()(64bit) -
libQt5PrintSupport.so.5(Qt_5)(64bit) -
libQt5Qml.so.5()(64bit) -
libQt5Qml.so.5(Qt_5)(64bit) -
libQt5Widgets.so.5()(64bit) -
libQt5Widgets.so.5(Qt_5)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libeditorconfig.so.0()(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.4)(64bit) -
libgit2.so.26()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.18)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
syntax-highlighting >= 5.58

Provides

Name Value
ktexteditor = 5.58.0-lp150.185.1
ktexteditor(x86-64) = 5.58.0-lp150.185.1
libKF5TextEditor.so.5()(64bit) -

Obsoletes

Name Value
libKF5TextEditor4 -
libKF5TextEditor5 -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ktexteditor-5.58.0-lp150.185.1.x86_64.rpm
Source Package ktexteditor-5.58.0-lp150.185.1.src.rpm

Install Howto

  1. Add the KDE Frameworks 5 repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/KDE:/Frameworks5/openSUSE_Leap_15.0/ kde-frameworks-5
  2. Install ktexteditor rpm package:
    # zypper install ktexteditor

Files

Path
/etc/xdg/ktexteditor.categories
/usr/lib64/libKF5TextEditor.so.5
/usr/lib64/libKF5TextEditor.so.5.58.0
/usr/lib64/qt5/plugins/
/usr/lib64/qt5/plugins/kf5/
/usr/lib64/qt5/plugins/kf5/parts/katepart.so
/usr/share/doc/packages/ktexteditor/README.md
/usr/share/katepart5/
/usr/share/katepart5/script/README.md
/usr/share/kdevappwizard/
/usr/share/kdevappwizard/templates/ktexteditor-plugin.tar.bz2
/usr/share/kservices5/katepart.desktop
/usr/share/kservicetypes5/ktexteditor.desktop
/usr/share/kservicetypes5/ktexteditorplugin.desktop
/usr/share/licenses/ktexteditor/COPYING.GPL-2
/usr/share/licenses/ktexteditor/COPYING.LGPL-2
/usr/share/licenses/ktexteditor/COPYING.LIB

Changelog

2019-05-15 - lbeltrame@kde.org
- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Too many changes to list here
2019-04-14 - lbeltrame@kde.org
- Update to 5.57.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.57.0.php
- Changes since 5.56.0:
* Too many changes to list here
2019-03-10 - lbeltrame@kde.org
- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Remove override keyword
* Use isEmpty here
* Remove deprecated method
* try to improve painting height for text lines - bug 403868 avoid to cut _
and other parts still broken: double height things  like mixed
english/arab, see bug 404713 (kde#403868)
* Use QTextFormat::TextUnderlineStyle instead of QTextFormat::FontUnderline (kde#399278)
* Make it possible to show all spaces in the document (kde#381267, kde#342811)
* Do not print indent lines
* KateSearchBar: Show also search has wrapped hint in nextMatchForSelection() aka Ctrl-H
* katetextbuffer: refactor TextBuffer::save() to better separate code paths
* Use AuthCore instead of Auth
* Remove dead code
* Explicitly link against KAuth
* Refactor KateViewInternal::mouseDoubleClickEvent(QMouseEvent *e)
* Improvements to completion
* Add TODO KF6 note
* Set the color scheme to Printing for Print Preview (kde#391678)
- Refreshed patches:
* 0001-Disable-KAuth-integration.patch
2019-02-15 - alarrosa@suse.com
- Downgrade the Qt version requirement to build with 5.9
2019-02-10 - lbeltrame@kde.org
- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* skip cppstyle indentation test for !t 5.12.0 which has a broken regex implementation in JS
* KateSpellCheckDialog: Remove action "Spellcheck Selection"
* Update JavaScript library underscore.js to version 1.9.1
* Fix bug 403422: Allow changing the marker size again (kde#403422)
* Consistently use override, not Q_DECL_OVERRIDE
* SearchBar: Add Cancel button to stop long running tasks
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
* Review KateGotoBar
* ViewInternal: Fix 'Go to matching bracket' in override mode
* Delete copy constructor and assignment operator from public vim/ classes
* delete copy constructor and assignment operator of some internal classes
* Use HTTPS, if available, in links visible to users
* Review KateStatusBar
* ViewConfig: Add option to paste at cursor position by mouse (kde#363492)
* Use the nicer K_PLUGIN_CLASS_WITH_JSON
* Remove Qt version check

See Also

Package Description
ktexteditor-devel-5.58.0-lp150.185.1.x86_64.rpm Header files for ktexteditor, an embeddable text editor component
ktexteditor-lang-5.58.0-lp150.185.1.noarch.rpm Translations for package ktexteditor
ktextwidgets-devel-5.58.0-lp150.168.1.x86_64.rpm KDE Text editing widgets: Build Environment
kunitconversion-devel-5.58.0-lp150.169.1.x86_64.rpm Converting physical units: Build Environment
kwallet-devel-5.58.0-lp150.193.1.x86_64.rpm Safe desktop-wide storage for passwords
kwallet-tools-5.58.0-lp150.193.1.x86_64.rpm Safe desktop-wide storage for passwords
kwallet-tools-lang-5.58.0-lp150.193.1.x86_64.rpm Safe desktop-wide storage for passwords
kwalletd5-5.58.0-lp150.193.1.x86_64.rpm Safe desktop-wide storage for passwords
kwalletd5-lang-5.58.0-lp150.193.1.noarch.rpm Translations for package kwallet
kwayland-5.58.0-lp150.175.1.x86_64.rpm KDE Wayland library
kwayland-devel-5.58.0-lp150.175.1.x86_64.rpm KDE Wayland library: Build Environment
kwayland-integration-5.15.90-lp150.160.1.x86_64.rpm Integration plugins for various KDE frameworks for wayland windowing system
kwidgetsaddons-devel-5.58.0-lp150.184.1.x86_64.rpm Large set of desktop widgets: Build Environment
kwin5-5.15.90-lp150.296.1.x86_64.rpm KDE Window Manager
kwin5-devel-5.15.90-lp150.296.1.x86_64.rpm KDE Window Manager - development files
Advertisement
Advertisement