gammaray-devel-2.10.0-lp150.40.5.x86_64.rpm


Advertisement

Description

gammaray-devel - Introspection/Debugging Tool for Qt Applications

Property Value
Distribution openSUSE Leap 15.0
Repository KDE 5 all
Package filename gammaray-devel-2.10.0-lp150.40.5.x86_64.rpm
Package name gammaray-devel
Package version 2.10.0
Package release lp150.40.5
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage http://www.kdab.com/gammaray
License GPL-2.0-or-later
Maintainer -
Download size 91.95 KB
Installed size 296.58 KB
Gamma Ray is a comprehensive collection of high level introspection
and debugging utilities specifically tailored for the various
frameworks in Qt. Development files.

Alternatives

Package Version Architecture Repository
gammaray-devel-2.10.0-lp150.37.13.x86_64.rpm 2.10.0 x86_64 KDE Extra
gammaray-devel-2.10.0-ku.40.1.x86_64.rpm 2.10.0 x86_64 KDE Unstable
gammaray-devel-2.9.0-lp150.1.9.x86_64.rpm 2.9.0 x86_64 openSUSE Oss
gammaray-devel - - -

Requires

Name Value
gammaray = 2.10.0

Provides

Name Value
cmake(GammaRay) = 2.10.0
gammaray-devel = 2.10.0-lp150.40.5
gammaray-devel(x86-64) = 2.10.0-lp150.40.5

Download

Type URL
Mirror widehat.opensuse.org
Binary Package gammaray-devel-2.10.0-lp150.40.5.x86_64.rpm
Source Package gammaray-2.10.0-lp150.40.5.src.rpm

Install Howto

  1. Add the KDE 5 repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/KDE:/Qt5/openSUSE_Leap_15.0/ kde-5
  2. Install gammaray-devel rpm package:
    # zypper install gammaray-devel

Files

Path
/usr/include/gammaray/
/usr/include/gammaray/client/clientconnectionmanager.h
/usr/include/gammaray/client/gammaray_client_export.h
/usr/include/gammaray/client/processtracker.h
/usr/include/gammaray/common/commonutils.h
/usr/include/gammaray/common/endpoint.h
/usr/include/gammaray/common/enumdefinition.h
/usr/include/gammaray/common/enumrepository.h
/usr/include/gammaray/common/enumvalue.h
/usr/include/gammaray/common/gammaray_common_export.h
/usr/include/gammaray/common/metatypedeclarations.h
/usr/include/gammaray/common/modelroles.h
/usr/include/gammaray/common/objectbroker.h
/usr/include/gammaray/common/objectid.h
/usr/include/gammaray/common/objectidfilterproxymodel.h
/usr/include/gammaray/common/objectmodel.h
/usr/include/gammaray/common/paths.h
/usr/include/gammaray/common/probecontrollerinterface.h
/usr/include/gammaray/common/propertycontrollerinterface.h
/usr/include/gammaray/common/protocol.h
/usr/include/gammaray/common/sourcelocation.h
/usr/include/gammaray/common/translator.h
/usr/include/gammaray/core/enumrepositoryserver.h
/usr/include/gammaray/core/enumutil.h
/usr/include/gammaray/core/gammaray_core_export.h
/usr/include/gammaray/core/metaobject.h
/usr/include/gammaray/core/metaobjectrepository.h
/usr/include/gammaray/core/metaproperty.h
/usr/include/gammaray/core/objectdataprovider.h
/usr/include/gammaray/core/objectmodelbase.h
/usr/include/gammaray/core/objecttypefilterproxymodel.h
/usr/include/gammaray/core/probe.h
/usr/include/gammaray/core/probecontroller.h
/usr/include/gammaray/core/propertycontroller.h
/usr/include/gammaray/core/propertycontrollerextension.h
/usr/include/gammaray/core/signalspycallbackset.h
/usr/include/gammaray/core/singlecolumnobjectproxymodel.h
/usr/include/gammaray/core/toolfactory.h
/usr/include/gammaray/core/typetraits.h
/usr/include/gammaray/core/util.h
/usr/include/gammaray/core/varianthandler.h
/usr/include/gammaray/launcher/attachdialog.h
/usr/include/gammaray/launcher/connectpage.h
/usr/include/gammaray/launcher/gammaray_launcher_export.h
/usr/include/gammaray/launcher/gammaray_launcher_ui_export.h
/usr/include/gammaray/launcher/launcher.h
/usr/include/gammaray/launcher/launcherfinder.h
/usr/include/gammaray/launcher/launcherwindow.h
/usr/include/gammaray/launcher/launchoptions.h
/usr/include/gammaray/launcher/networkdiscoverymodel.h
/usr/include/gammaray/launcher/probeabi.h
/usr/include/gammaray/launcher/probeabidetector.h
/usr/include/gammaray/launcher/probefinder.h
/usr/include/gammaray/ui/clientdecorationidentityproxymodel.h
/usr/include/gammaray/ui/clienttoolmanager.h
/usr/include/gammaray/ui/gammaray_ui_export.h
/usr/include/gammaray/ui/propertyeditordelegate.h
/usr/include/gammaray/ui/propertywidget.h
/usr/include/gammaray/ui/propertywidgettab.h
/usr/include/gammaray/ui/tooluifactory.h
/usr/include/gammaray/ui/uiintegration.h
/usr/include/gammaray/ui/uiresources.h
/usr/include/gammaray/ui/uistatemanager.h
/usr/lib64/libgammaray_client.so
/usr/lib64/libgammaray_common-qt5_12-x86_64.so
/usr/lib64/libgammaray_core-qt5_12-x86_64.so
/usr/lib64/libgammaray_kitemmodels-qt5_12-x86_64.so
/usr/lib64/libgammaray_kuserfeedback.so
/usr/lib64/libgammaray_launcher.so
/usr/lib64/libgammaray_launcher_ui.so
/usr/lib64/libgammaray_ui-qt5_12-x86_64.so
/usr/lib64/cmake/GammaRay/GammaRayConfig.cmake
/usr/lib64/cmake/GammaRay/GammaRayConfigVersion.cmake
/usr/lib64/cmake/GammaRay/GammaRayMacros.cmake
/usr/lib64/cmake/GammaRay/GammaRayTarget-relwithdebinfo.cmake
/usr/lib64/cmake/GammaRay/GammaRayTarget.cmake
/usr/lib64/qt5/mkspecs/modules/qt_GammaRayClient.pri
/usr/lib64/qt5/mkspecs/modules/qt_GammaRayCommon.pri
/usr/lib64/qt5/mkspecs/modules/qt_GammaRayCore.pri
/usr/lib64/qt5/mkspecs/modules/qt_GammaRayKItemModels.pri
/usr/lib64/qt5/mkspecs/modules/qt_GammaRayLauncher.pri
/usr/lib64/qt5/mkspecs/modules/qt_GammaRayLauncherUi.pri
/usr/lib64/qt5/mkspecs/modules/qt_GammaRayUi.pri
/usr/share/licenses/gammaray-devel/LICENSE.BSD3.txt
/usr/share/licenses/gammaray-devel/LICENSE.GPL.txt
/usr/share/licenses/gammaray-devel/LICENSE.US.txt
/usr/share/licenses/gammaray-devel/LICENSE.txt

Changelog

2019-04-10 - Christophe Giboudeaux <christophe@krop.fr>
- Add fix-build-with-qt-5.13.patch
2019-04-02 - Christophe Giboudeaux <christophe@krop.fr>
- Remove the vtk-tcl dependency.
2019-02-28 - wbauer@tmo.at
- Update to 2.10.0:
* Increase CMake requirement to version 3.1 on all platforms.
* Add object navigation to the paint analyzer.
* Reduce network load by moving more property model features to
the client side.
* Port object hierarchy visualizer plugin to Qt 5.
* Add new system information plugin, which supersedes the
standard paths plugin.
* Use application palette rather than style palette in the style
inspector.
* Improve gdb injector performance.
* Reduce performance impact of the widget paint analyzer in
Windows debug builds.
* Improve Qt Quick item picking in case of zero-sized parent
elements.
* Provide access to QAbstractItemModel role name mapping.
* Add QtPositioning plugin allowing to monitor and simulate geo
localization.
* Add NMEA geo localization playback.
* Add support for generic functor property accessors.
* Add property access for mime data and clipboard types.
* Add infrastructure to override generic property access, such as
Qt Quick anchor properties.
* Add custom property access for Qt Quick anchors properties to
no longer trigger their on-demand creation.
* Add generic problem reporter infrastructure, and port some
existing checks to it.
- Drop patches merged upstream:
* fix-build-qt-5.12.patch
* fix-build-qt-5.12-again.patch
2018-11-14 - Christophe Giboudeaux <christophe@krop.fr>
- Remove unneeded build dependencies.
2018-10-05 - fabian@ritter-vogt.de
- Add patches to fix build against Qt 5.12:
* fix-build-qt-5.12.patch
* fix-build-qt-5.12-again.patch
2018-10-04 - fabian@ritter-vogt.de
- Update to 2.9.1:
* Fix crash in in-process mode with networking disabled.
* Fix compilation with Qt 5.12.
* Update Android toolchain file.
* Allow to disable QtScript dependency.
* Fix crash on zero-sized paint operations.
* Fix plugin deployment on Android.
* Fix crash in Qt Quick inspector when encountering invalid bounding rects.
* Fix activating the Qt3D plugin when attaching to a Qt3D application at runtime.
* Fix out-of-bounds framebuffer read in Qt Quick remote view for some non-integer scaling factors.
- Use %license

See Also

Package Description
gnuplot-5.2.6-lp150.3.18.x86_64.rpm Function Plotting Utility and more
gnuplot-doc-5.2.6-lp150.3.18.noarch.rpm Documentation of GNUplot
gpgme-1.13.0-lp150.3.2.x86_64.rpm Programmatic library interface to GnuPG
grantlee5-5.1.0-lp150.15.1.x86_64.rpm Qt string template library
grantlee5-devel-5.1.0-lp150.15.1.x86_64.rpm Include Files and Libraries Mandatory for Development with Grantlee
gstreamer-plugins-qt5-1.2.0-lp150.21.7.x86_64.rpm C++/Qt bindings for GStreamer
gstreamer-plugins-qt5-devel-1.2.0-lp150.21.7.x86_64.rpm Include files and libraries mandatory for development
kdstatemachineeditor-devel-1.2.5-lp150.27.3.x86_64.rpm Introspection/Debugging Tool for Qt Applications
libAppStreamQt-devel-0.12.6-lp150.4.2.x86_64.rpm Header files for AppStream's Qt5 bindings
libAppStreamQt2-0.12.6-lp150.4.2.x86_64.rpm Qt5 bindings for AppStream
libPythonQt-Qt5-Python3-3-3.2-lp150.4.8.x86_64.rpm Dynamic Python binding for the Qt framework
libPythonQt_QtAll-Qt5-Python3-3-3.2-lp150.4.8.x86_64.rpm Dynamic Python binding for the Qt framework
libQt53DAnimation-devel-5.12.3-lp150.1.1.x86_64.rpm Development files for the Qt 5 3D Animation library
libQt53DAnimation5-5.12.3-lp150.1.1.x86_64.rpm Qt 5 3D Addon
libQt53DCore-devel-5.12.3-lp150.1.1.x86_64.rpm Development files for the Qt 5 Core 3D library
Advertisement
Advertisement