gnu-inetlib-1.1-lp150.487.1.noarch.rpm


Advertisement

Description

gnu-inetlib - Library of clients for common internet protocols

Property Value
Distribution openSUSE Leap 15.0
Repository JAVA all
Package name gnu-inetlib
Package version 1.1
Package release lp150.487.1
Package architecture noarch
Package type rpm
Installed size 135.28 KB
Download size 130.06 KB
Official Mirror widehat.opensuse.org
GNU inetlib is a library of clients for common internet protocols. The
following protocols are currently supported: Hypertext Transfer
Protocol (HTTP) File Transfer Protocol (FTP) Simple Mail Transfer
Protocol (SMTP) Internet Message Access Protocol (IMAP) Post Office
Protocol (POP) Network News Transfer Protocol (NNTP) Lightweight
Directory Access Protocol (LDAP) (alpha) Gopher Finger The inetlib
library is similar in intent to the Python internet protocols library -
the API is as close as possible to the intent of the underlying
protocol design. This allows for very efficient coding of user agents.
Additionally, inetlib includes URLStreamHandler implementations for
some of the protocols. These can be used to add support for the
corresponding URL scheme to the java.net.URL class.

Alternatives

Package Version Architecture Repository
gnu-inetlib-1.1-lp150.1.3.noarch.rpm 1.1 noarch openSUSE Oss
gnu-inetlib - - -

Provides

Name Value
gnu-inetlib = 1.1-lp150.487.1
inetlib -

Download

Type URL
Binary Package gnu-inetlib-1.1-lp150.487.1.noarch.rpm
Source Package gnu-inetlib-1.1-lp150.487.1.src.rpm

Install Howto

  1. Add the JAVA repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/Java:/packages/openSUSE_Leap_15.0/ java
  2. Install gnu-inetlib rpm package:
    # zypper install gnu-inetlib

Files

Path
/usr/share/java/inetlib.jar

Changelog

2018-05-17 - fstrba@suse.com
- Build with source and target 8 to prepare for a possible removal
of 1.6 compatibility
2017-09-14 - fstrba@suse.com
- Build with java source and target 1.6
- Do not require buiding with java-gcj-compat
2014-10-07 - tchvatal@suse.com
- Clean it up with spec-cleaner too
2014-10-06 - jengelh@inai.de
- Remove ancient spec tags and sections
2009-07-28 - mvyskocil@suse.cz
- Fixed build with new gcc/gjc
2007-05-02 - dbornkessel@suse.de
- added unzip to BuildRequires
2007-01-11 - dbornkessel@suse.de
- first version (dependency for tomcat55)

See Also

Package Description
gnu-jaf-1.1.1-lp150.40.1.noarch.rpm GNU implementation of the JavaBeans Activation Framework
gnu-regexp-1.1.4-lp150.574.6.noarch.rpm Java NFA regular expression engine
gnu-regexp-demo-1.1.4-lp150.574.6.noarch.rpm Java NFA regular expression engine (demo and samples)
gnu-regexp-javadoc-1.1.4-lp150.574.6.noarch.rpm Java NFA regular expression engine (documentation)
gradle-local-5.3.0-lp150.70.1.noarch.rpm Local mode for Gradle
gradle-open-api-3.2.1-lp150.17.1.noarch.rpm Open API definition for gradle
guava20-20.0-lp150.3.6.noarch.rpm Google Core Libraries for Java
guava20-javadoc-20.0-lp150.3.6.noarch.rpm Javadoc for guava20
guava20-testlib-20.0-lp150.3.6.noarch.rpm The guava-testlib artifact
hamcrest-1.3-lp150.60.1.noarch.rpm Library of matchers for building test expressions
hamcrest-1.3-lp150.61.31.noarch.rpm Library of matchers for building test expressions
hamcrest-demo-1.3-lp150.60.1.noarch.rpm Demo files for hamcrest
hamcrest-demo-1.3-lp150.61.31.noarch.rpm Demo files for hamcrest
hamcrest-javadoc-1.3-lp150.60.1.noarch.rpm Javadoc for hamcrest
hamcrest-javadoc-1.3-lp150.61.31.noarch.rpm Javadoc for hamcrest
Advertisement
Advertisement