gtkpod-devel-2.1.5-lp150.38.1.x86_64.rpm


Advertisement

Description

gtkpod-devel - A platform independent GUI for the AppleĀ® iPodĀ® - Development Files

Property Value
Distribution openSUSE Leap 15.0
Repository GNOME Apps all
Package filename gtkpod-devel-2.1.5-lp150.38.1.x86_64.rpm
Package name gtkpod-devel
Package version 2.1.5
Package release lp150.38.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage http://gtkpod.sourceforge.net/
License GPL-2.0+
Maintainer -
Download size 32.61 KB
Installed size 41.59 KB
This package contains development headers for libgtkpod
gtkpod is a Platform-Independent GUI for the Apple iPod using GTK2. It
allows you to upload songs and play lists to your iPod. It supports ID3
tag editing with multiple charsets for ID3 tags, detects duplicate
songs, allows offline modification of the database with later
synchronization, and more.

Alternatives

Package Version Architecture Repository
gtkpod-devel-2.1.5-lp150.1.7.x86_64.rpm 2.1.5 x86_64 openSUSE Oss
gtkpod-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libatomicparsley0 = 2.1.5
libgtkpod1 = 2.1.5
pkgconfig(gdl-3.0) >= 3.0.0
pkgconfig(glib-2.0) >= 2.28.6
pkgconfig(gmodule-2.0) -
pkgconfig(gthread-2.0) >= 2.28.6
pkgconfig(gtk+-3.0) >= 3.0.0
pkgconfig(libanjuta-3.0) >= 3.0.0
pkgconfig(libgpod-1.0) >= 0.7.0

Provides

Name Value
gtkpod-devel = 2.1.5-lp150.38.1
gtkpod-devel(x86-64) = 2.1.5-lp150.38.1
pkgconfig(libgtkpod-1.1.0) = 2.1.5

Download

Type URL
Mirror widehat.opensuse.org
Binary Package gtkpod-devel-2.1.5-lp150.38.1.x86_64.rpm
Source Package gtkpod-2.1.5-lp150.38.1.src.rpm

Install Howto

  1. Add the GNOME Apps repository:
    # zypper addrepo http://widehat.opensuse.org/opensuse/repositories/GNOME:/Apps/openSUSE_Leap_15.0/ gnome-apps
  2. Install gtkpod-devel rpm package:
    # zypper install gtkpod-devel

Files

Path
/usr/include/gtkpod/
/usr/include/gtkpod/gtkpod/AtomicParsley.h
/usr/include/gtkpod/gtkpod/AtomicParsleyBridge.h
/usr/include/gtkpod/gtkpod/gp_itdb.h
/usr/include/gtkpod/gtkpod/gtkpod_app_iface.h
/usr/lib64/libatomicparsley.so
/usr/lib64/libgtkpod.so
/usr/lib64/pkgconfig/libgtkpod-1.1.0.pc

Changelog

2017-02-03 - zaitor@opensuse.org
- Drop pkgconfig(webkitgtk-3.0) BuildRequires: No longer depend on
old inscure webkitgtk3.
2015-06-11 - dimstar@opensuse.org
- Update to version 2.1.5:
+ Improvements:
- Port to GStreamer 1.0.
- Upgrade sjcd plugin to use latest sound juicer code.
- Refactor deprecated GtkTable replacing with GtkGrid.
+ Bugsfixes:
- Fixes the setting display of the repository file settings.
- Update install instructions and documentation.
- Replace BuildRequires for port to GStreamer 1.0:
+ Drop pkgconfig(gstreamer-0.10), pkgconfig(gstreamer-base-0.10),
pkgconfig(gstreamer-interfaces-0.10),
pkgconfig(gstreamer-pbutils-0.10) and
pkgconfig(gstreamer-plugins-base-0.10).
+ Add pkgconfig(gstreamer-1.0), pkgconfig(gstreamer-base-1.0),
pkgconfig(gstreamer-plugins-base-1.0) and
pkgconfig(gstreamer-pbutils-1.0).
- Replace pkgconfig(libmusicbrainz4) BuildRequires with
pkgconfig(libmusicbrainz5), following upstreams port.
- Add pkgconfig(iso-codes) BuildRequires to detect iso3166 support
during build.
- Add pkgconfig(libdiscid) BuildRequires: new dependency.
2013-09-07 - dimstar@opensuse.org
- Update to version 2.1.4:
+ Bugfixes:
- Playlist display and coverart display.
- Fix showing tracks of selected artist on 64-bit systems.
- Handle attempts to create duplicate-named playlist.
+ Improvements:
- Update to support anjuta releases up to 3.9.1.
- Update clutter, glib and gtk deprecations and updates the
glib minimum version to 2.31 which was released in 2011.
- Drop gtkpod-gdl362.patch: fixed upstream.
- Drop gtkpod-anjuta-3.8.0.patch: fixed upstream.
2013-05-08 - dimstar@opensuse.org
- Replace gtkpod-gdl362.patch with what upstream commited, as
commit 47a3bc.
- Add gtkpod-anjuta-3.8.0.patch: fix build with anjuta 3.8.0.
2013-01-06 - dimstar@opensuse.org
- Update to version 2.1.3:
+ Improvements:
- Solve the confusing sorting of the track display. Track
display sort order is only applied if the tm_autostore
preference has been set. Otherwise sorting of tracks in a
playlist is completely manual through a set of radio buttons,
as well as selecting the column names.
- Reduce number of selection changed callbacks making track
selection more efficient.
- Make it easier for the user to retry entering a valid
playlist name.
- Fix to cater for changing API in anjuta version 3.5.3+.
+ Bug fixes:
- Avoid filter tab categories having null values by including a
default value.
- Ensure files with an upper case file extension are loaded
correctly.
- Selection of bugs identified in atomic parsley library.
- Fix setting the default width of main window.
- Do not accept empty names for smart playlists.
- Fix segfault when using playcount spin buttons.
- Fix multiple icons appearing when toggling plugins in
preferences window.
- Fix m4a track length value calculated in atomic parsely
library.
- Fix for potential crashes when deleting all tracks.
+ Updated translations.
- Drop gtkpod-buffer-overflow.patch and gtkpod-anjuta36.patch:
fixed upstream.
- Drop libtool BuildRequires and call to autogen.sh, as we don't
carry any patch touching the build system.
2012-11-26 - dimstar@opensuse.org
- Add gtkpod-gdl362.patch: Fix build with gdl 3.6.2.
2012-10-13 - dimstar@opensuse.org
- Add gtkpod-anjuta36.patch: Adapt to Anjuta 3.6 API change.
- Add ldconfig call to post/postun of libatomicparsley0 subpackage.

See Also

Package Description
gtkpod-lang-2.1.5-lp150.38.1.noarch.rpm Translations for package gtkpod
gtranslator-2.91.7-lp150.73.1.x86_64.rpm A GNOME po file editor with many bells and whistles
gtranslator-devel-2.91.7-lp150.73.1.x86_64.rpm A GNOME po file editor with many bells and whistles
gtranslator-lang-2.91.7-lp150.73.1.noarch.rpm Translations for package gtranslator
gwget-1.0.4-lp150.15.1.x86_64.rpm GTK+ Front-End to wget
gwget-lang-1.0.4-lp150.15.1.noarch.rpm Translations for package gwget
homebank-5.2.3-lp150.43.1.x86_64.rpm Application to manage personal accounts
homebank-lang-5.2.3-lp150.43.1.noarch.rpm Translations for package homebank
hyena-0.5-lp150.20.1.x86_64.rpm Library for .NET applications
infinoted-0.7.1-lp150.56.1.x86_64.rpm Server for Collaborative Document Edition
jhbuild-3.30.0~20190220-lp150.64.1.x86_64.rpm Tool to build GNOME
jhbuild-lang-3.30.0~20190220-lp150.64.1.noarch.rpm Translations for package jhbuild
jhbuild-recommended-deps-3.30.0~20190220-lp150.64.1.x86_64.rpm Recommended dependencies to use jhbuild
kazam-1.0.6-lp150.1.1.noarch.rpm A screencasting program created with design in mind
kazam-lang-1.0.6-lp150.1.1.noarch.rpm Translations for package kazam
Advertisement
Advertisement