libvlc-qt0_10-0.10.0-6.14.i586.rpm


Advertisement

Description

libvlc-qt0_10 - Qt and libvlc connector library

Distribution: openSUSE 13.2
Repository: Packman all
Package name: libvlc-qt0_10
Package version: 0.10.0
Package release: 6.14
Package architecture: i586
Package type: rpm
Installed size: 153.38 KB
Download size: 47.57 KB
Official Mirror: packman.inode.at
VLC-Qt is a free library used to connect Qt and libvlc libraries. It contains core classes for main media playback and also some GUI classes for faster media player development.

Alternatives

Provides

  • libvlc-qt = 0.10.0
  • libvlc-qt.so.0.10
  • libvlc-qt0_10 = 0.10.0-6.14
  • libvlc-qt0_10(x86-32) = 0.10.0-6.14

Obsoletes

  • libvlc-qt < 0.10.0

    Download

    Source package: libvlc-qt-0.10.0-6.14.src.rpm

    Install Howto

    1. Add the Packman repository:
      # zypper addrepo http://packman.inode.at/suse/openSUSE_13.2/ packman
    2. Install libvlc-qt0_10 rpm package:
      # zypper install libvlc-qt0_10

    Files

    • /usr/lib/libvlc-qt.so.0.10
    • /usr/lib/libvlc-qt.so.0.10.0

    Changelog

    2015-11-08 - avvissu@yandex.ru - Build with qt5 on openSUSE 42.1: add %%Leap_verSP

    2015-04-24 - joerg.lorenzen@ki.tng.de - Fixed spec file to apply patches and set option WITH_X11 to ON for build against qt4.

    2015-04-23 - avvissu@yandex.ru - Build with Qt4 for SLE12

    2015-04-22 - sor.alexei@meowr.ru - Rename libvlc-qt-0.10.0-fix-file-contains-date-and-time.patch to libvlc-qt_no-date-time.patch. - Rename libvlc-qt_qApp.patch to libvlc-qt_qapplication.patch and extend to Qt4. - Build for 13.1 with Qt4 instead of Qt5: future versions of libvlc-qt will support only Qt 5.2+ while building with Qt5. - Correct license to LGPL-3.0+: upstream sources say "either version 3 of the License, or (at your option) any later version". - Spec cleanup.

    2015-04-21 - aloisio@gmx.com - Added libvlc-qt_qApp.patch to fix 13.1 build

    2015-04-16 - antoine.belvire@laposte.net - Update to version 0.10.0: * Full Qt5 QML support * Ability to set VLC plugin path * VLC 2.2 support * Stats support (issue #28) * Debug/Release postfix in library filenames (issue #29) * Fix: Make VlcError::errmsg() return QString, not void (issue #48) * Fix: Add remaining pkgconfig files (issue #51) * See /usr/share/doc/packages/libvlc-qt-doc/CHANGELOG for changes introduced with 0.9.0 - Enable parallel build this time - Remove libvlc-qt-0.8.0-fix-file-contains-date-and-time.patch - Add libvlc-qt-0.10.0-fix-file-contains-date-and-time.patch - Clean spec file (see https://en.opensuse.org/openSUSE:Specfile_guidelines) * remove Russian translations * remove Packager tag * add license files and changelog to doc

    2013-02-15 - svalx@svalx.net - Updated to version 0.8.0: * Separate library into modules: core, widgets and qml * Introduce position() and setPosition() methods * Fix pause method and introduce togglePause method * Removed mouse and fullscreen functions from WidgetVideo * Fix: Use proper track ids * Fix: Install pkg-config file to correct path (issue #12) * Fix: Don't use exit() (issue #13) - Remove libvlc-qt-0.7.0-define-library-suffix.patch - fixed in upstream. - Separate package for libvlc-qt-widgets library. - Disable parallel build - not supported 0.8.0.

    2012-12-20 - svalx@svalx.net - Add libvlc-qt-0.7.0-define-library-suffix.patch -- define shared library path suffix if not defined and suffix for pkgconfig

    2012-12-19 - svalx@svalx.net - Initial package.

    Advertisement
    Advertisement