curl-7.42.1-25.1.x86_64.rpm


Advertisement

Description

curl - A Tool for Transferring Data from URLs

Distribution: openSUSE 13.2
Repository: openSUSE Update all
Package name: curl
Package version: 7.42.1
Package release: 25.1
Package architecture: x86_64
Package type: rpm
Installed size: 327.71 KB
Download size: 154.91 KB
Official Mirror: ftp.gwdg.de
Curl is a client to get documents and files from or send documents to a server using any of the supported protocols (HTTP, HTTPS, FTP, FTPS, TFTP, DICT, TELNET, LDAP, or FILE). The command is designed to work without user interaction or any kind of interactivity.

Alternatives

Provides

  • curl = 7.42.1-25.1
  • curl(x86-64) = 7.42.1-25.1

    Download

    Source package: curl-7.42.1-25.1.src.rpm

    Install Howto

    Install curl rpm package:

    # zypper install curl

    Files

    • /usr/bin/curl
    • /usr/share/doc/packages/curl/BUGS
    • /usr/share/doc/packages/curl/FAQ
    • /usr/share/doc/packages/curl/FEATURES
    • /usr/share/doc/packages/curl/MANUAL
    • /usr/share/doc/packages/curl/README
    • /usr/share/doc/packages/curl/README.curl_off_t
    • /usr/share/doc/packages/curl/RELEASE-NOTES
    • /usr/share/doc/packages/curl/RESOURCES
    • /usr/share/doc/packages/curl/TODO
    • /usr/share/doc/packages/curl/TheArtOfHttpScripting
    • /usr/share/man/man1/curl.1.gz

    Changelog

    2016-08-24 - pjanouch@suse.de - Add curl-bsc991746.patch (bsc#991746) fixing a performance regression with FTP

    2016-08-05 - pjanouch@suse.de - Add curl-CVE-2016-5419.patch (bsc#991389 CVE-2016-5419) - Add curl-CVE-2016-5420.patch (bsc#991390 CVE-2016-5420) - Add curl-CVE-2016-5421.patch (bsc#991391 CVE-2016-5421)

    2016-05-05 - alarrosa@suse.com - Add 0001-Fix-invalid-Network-is-unreachable-errors.patch. Fixes "Network is unreachable" errors in valid situations when ipv6 is not available but ipv4 is working fine. This also fixes the same error from happening in applications using libcurl4 (like zypper). (bsc#915846)

    2016-01-21 - vcizek@suse.com - fix CVE-2016-0755 (bsc#962983) * libcurl NTLM credentials not-checked for proxy connection re-use * http://curl.haxx.se/docs/adv_20160127A.html * add curl-CVE-2016-0755.patch

    2016-01-21 - vcizek@suse.com - unexpire cookie in test 46 (bsc#962996) * add 0001-test46-update-cookie-expire-time.patch

    2015-06-17 - mvetter@suse.com - Applying patch to fix CVE-2015-3237 (bsc#934502)

    2015-06-17 - mvetter@suse.com - Applying patch to fix CVE-2015-3236 (bsc#934501)

    2015-06-11 - vcizek@suse.com - enable metalink support (boo#851126)

    2015-04-29 - vcizek@suse.com - update to 7.42.1 * fixes CVE-2015-3153 (bnc#928533) - sensitive HTTP server headers also sent to proxies - rename curl-devel to libcurl-devel in baselibs.conf

    2015-04-22 - vcizek@suse.com - update to 7.42.0 * refresh libcurl-ocloexec.patch - fixes security vulnerabilities: * CVE-2015-3143 (bnc#927556) - Re-using authenticated connection when unauthenticated * CVE-2015-3144 (bnc#927608) - host name out of boundary memory access * CVE-2015-3145 (bnc#927607) - cookie parser out of boundary memory access * CVE-2015-3148 (bnc#927746) - Negotiate not treated as connection-oriented

    Advertisement
    Advertisement