ima-evm-utils-devel - IMA/EVM control utility --development files

Distribution: openSUSE 13.2
Repository: openSUSE Security all
Package name: ima-evm-utils-devel
Package version: 1.0
Package release: 19.1
Package architecture: x86_64
Package type: rpm
Installed size: 7.82 KB
Download size: 7.72 KB
Official Mirror:
This package contains the header files and the utilities for ima-evm-utils.




  • ima-evm-utils-devel = 1.0-19.1
  • ima-evm-utils-devel(x86-64) = 1.0-19.1

    Install Howto

    1. Add the openSUSE Security repository:
      # zypper addrepo opensuse-security
    2. Install ima-evm-utils-devel rpm package:
      # zypper install ima-evm-utils-devel


    • /usr/include/imaevm.h
    • /usr/lib64/
    • /usr/share/doc/packages/ima-evm-utils-devel/
    • /usr/share/doc/packages/ima-evm-utils-devel/
    • /usr/share/doc/packages/ima-evm-utils-devel/


    2015-12-02 - - Update to version 1.0 * Recursive hashing * Immutable EVM signatures (experimental) * Command 'ima_clear' to remove xattrs * Support for passing password to the library * Support for asking password safely from the user

    2015-01-21 - - Update to version 0.9 * Updated README * man page generated and added to the package * Use additional SMACK xattrs for EVM signature generation * Signing functions moved to libimaevm for external use (RPM) * Fixed setting of correct hash header - Add additional requirements; asciidoc, docbook-xsl-stylesheets, libattr-devel and libxslt-tools - Remove COPYING from sources; upstream provides one now - Remove automake.patch; "test" directory isn't provided by upstream anymore - Remove ima-evm-utils-xattr.patch; libimaevm0 does link against libattr now - Split package in three subpackage * libimaevm0: contains shared library * -devel: contains header and examples files * evmctl: the kernel signing tool - Add ima-evm-utils-fix-docbook-xsl-directory.patch; fix path where Make is looking for docbook.xsl

    2014-10-12 - - ima-evm-utils-xattr.patch: libattr is never linked, things still work because glibc provides the same interface, switch the includes to the glibc headers and remove the build dependency.

    2013-08-13 - - Initial packaging of IMA EVM tool. - automake.patch: fix for newer automake - supply COPYING for LGPL-2.1+, as package only has an empty one.