gstreamer-validate-1.10.3-14.1.i586.rpm


Advertisement

Description

gstreamer-validate - Validate GStreamer Pipelines

Distribution: openSUSE 13.2
Repository: openSUSE Multimedia Libs all
Package name: gstreamer-validate
Package version: 1.10.3
Package release: 14.1
Package architecture: i586
Package type: rpm
Installed size: 1.50 MB
Download size: 305.31 KB
Official Mirror: ftp.gwdg.de
The goal of GstValidate is to be able to detect when elements are not behaving as expected and report it to the user so he knows how things are supposed to work inside a GstPipeline. In the end, fixing issues found by the tool will ensure that all elements behave all together in the expected way. The easiest way of using GstValidate is to use one of its command-line tools, located at tools/ directory. It is also possible to monitor GstPipelines from any application by using the LD_PRELOAD gstvalidate lib. The third way of using it is to write your own application that links and uses libgstvalidate.

Alternatives

Provides

  • gstreamer-validate = 1.10.3-14.1
  • gstreamer-validate(x86-32) = 1.10.3-14.1
  • libgstvalidateplugin-1.0.so.0

    Install Howto

    1. Add the openSUSE Multimedia Libs repository:
      # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/multimedia:/libs/openSUSE_13.2/ opensuse-multimedia-libs
    2. Install gstreamer-validate rpm package:
      # zypper install gstreamer-validate

    Files

    • /usr/bin/gst-validate-1.0
    • /usr/bin/gst-validate-images-check-1.0
    • /usr/bin/gst-validate-launcher
    • /usr/bin/gst-validate-media-check-1.0
    • /usr/bin/gst-validate-transcoding-1.0
    • /usr/lib/gst-validate-launcher/
    • /usr/lib/gst-validate-launcher/python/
    • /usr/lib/gst-validate-launcher/python/launcher/RangeHTTPServer.py
    • /usr/lib/gst-validate-launcher/python/launcher/RangeHTTPServer.pyc
    • /usr/lib/gst-validate-launcher/python/launcher/RangeHTTPServer.pyo
    • /usr/lib/gst-validate-launcher/python/launcher/__init__.py
    • /usr/lib/gst-validate-launcher/python/launcher/__init__.pyc
    • /usr/lib/gst-validate-launcher/python/launcher/__init__.pyo
    • /usr/lib/gst-validate-launcher/python/launcher/baseclasses.py
    • /usr/lib/gst-validate-launcher/python/launcher/baseclasses.pyc
    • /usr/lib/gst-validate-launcher/python/launcher/baseclasses.pyo
    • /usr/lib/gst-validate-launcher/python/launcher/config.py
    • /usr/lib/gst-validate-launcher/python/launcher/config.pyc
    • /usr/lib/gst-validate-launcher/python/launcher/config.pyo
    • /usr/lib/gst-validate-launcher/python/launcher/httpserver.py
    • /usr/lib/gst-validate-launcher/python/launcher/httpserver.pyc
    • /usr/lib/gst-validate-launcher/python/launcher/httpserver.pyo
    • /usr/lib/gst-validate-launcher/python/launcher/loggable.py
    • /usr/lib/gst-validate-launcher/python/launcher/loggable.pyc
    • /usr/lib/gst-validate-launcher/python/launcher/loggable.pyo
    • /usr/lib/gst-validate-launcher/python/launcher/main.py
    • /usr/lib/gst-validate-launcher/python/launcher/main.pyc
    • /usr/lib/gst-validate-launcher/python/launcher/main.pyo
    • /usr/lib/gst-validate-launcher/python/launcher/reporters.py
    • /usr/lib/gst-validate-launcher/python/launcher/reporters.pyc
    • /usr/lib/gst-validate-launcher/python/launcher/reporters.pyo
    • /usr/lib/gst-validate-launcher/python/launcher/utils.py
    • /usr/lib/gst-validate-launcher/python/launcher/utils.pyc
    • /usr/lib/gst-validate-launcher/python/launcher/utils.pyo
    • /usr/lib/gst-validate-launcher/python/launcher/vfb_server.py
    • /usr/lib/gst-validate-launcher/python/launcher/vfb_server.pyc
    • /usr/lib/gst-validate-launcher/python/launcher/vfb_server.pyo
    • /usr/lib/gst-validate-launcher/python/launcher/apps/__init__.py
    • /usr/lib/gst-validate-launcher/python/launcher/apps/__init__.pyc
    • /usr/lib/gst-validate-launcher/python/launcher/apps/__init__.pyo
    • /usr/lib/gst-validate-launcher/python/launcher/apps/gstvalidate.py
    • /usr/lib/gst-validate-launcher/python/launcher/apps/gstvalidate.pyc
    • /usr/lib/gst-validate-launcher/python/launcher/apps/gstvalidate.pyo
    • /usr/lib/gstreamer-1.0/libgstvalidateplugin-1.0.so.0
    • /usr/lib/gstreamer-1.0/libgstvalidateplugin-1.0.so.0.1003.0
    • /usr/lib/gstreamer-1.0/validate/
    • /usr/share/doc/packages/gstreamer-validate/COPYING
    • /usr/share/doc/packages/gstreamer-validate/ChangeLog
    • /usr/share/doc/packages/gstreamer-validate/README
    • /usr/share/gstreamer-1.0/
    • /usr/share/gstreamer-1.0/validate/gst.supp
    • /usr/share/gstreamer-1.0/validate/gstvalidate.supp
    • /usr/share/gstreamer-1.0/validate/valgrind.config
    • /usr/share/gstreamer-1.0/validate/scenarios/adaptive_video_framerate.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/adaptive_video_framerate_size.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/adaptive_video_size.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/alternate_fast_backward_forward.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/change_state_intensive.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/disable_subtitle_track_while_paused.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/fast_backward.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/fast_forward.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/force_key_unit.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/pause_resume.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/play_15s.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/reverse_playback.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/scrub_backward_seeking.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/scrub_backward_seeking_full.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/scrub_forward_seeking.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/scrub_forward_seeking_full.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/seek_backward.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/seek_forward.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/seek_forward_backward.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/seek_with_stop.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/setup_sink_props_max_lateness.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/simple_seeks.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/switch_audio_track.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/switch_audio_track_while_paused.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/switch_subtitle_track.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/switch_subtitle_track_while_paused.scenario
    • /usr/share/gstreamer-1.0/validate/scenarios/trick_mode_seeks.scenario

    Changelog

    2017-01-30 - zaitor@opensuse.org - Update to version 1.10.3: + Bugs fixed: bgo#776280.

    2016-12-03 - zaitor@opensuse.org - Update to version 1.10.2: + Minor bugfixes.

    2016-11-27 - zaitor@opensuse.org - Update to version 1.10.1: + Meson update. - Changes from version 1.10.0: + Bugs fixed: bgo#772439, bgo#772543. - Add pkgconfig(json-glib-1.0) BuildRequires: New dependency.

    2016-08-24 - zaitor@opensuse.org - Update to version 1.8.3 (boo#996937): + Fix Validate plugin paths mixup. + No execute ON_ADDITION if a previous action is executed playback_time. - Drop gstreamer-validate-correctplugindir.patch: Fixed upstream.

    2016-06-15 - zaitor@opensuse.org - Update to version 1.8.2: + configure: Properly set the current validate testsuite to 1.8. + validate: Stop using deprecated method.

    2016-06-13 - novell@mirell.de - Add gstreamer-validate-correctplugindir.patch from upstream to fix Pitivi startup on some systems.

    2016-04-21 - zaitor@opensuse.org - Update to version 1.8.1: + bgo#764192: gst-validate build error on Mac OS X due to missing linking to GIO.

    2016-03-26 - zaitor@opensuse.org - Update to version 1.8.0: + Hardware-accelerated zero-copy video decoding on Android + New video capture source for Android using the android.hardware.Camera API. + Windows Media reverse playback support (ASF/WMV/WMA). + New tracing system provides support for more sophisticated debugging tools. + New high-level GstPlayer playback convenience API. + Initial support for the new Vulkan API, see Matthew Waters' blog post for more details. + Improved Opus audio codec support: Support for more than two channels; MPEG-TS demuxer/muxer can now handle Opus; sample-accurate encoding/decoding/transmuxing with Ogg, Matroska, ISOBMFF (Quicktime/MP4), and MPEG-TS as container; new codec utility functions for Opus header and caps handling in pbutils library. The Opus encoder/decoder elements were also moved to gst-plugins-base (from -bad), and the opus RTP depayloader/payloader to -good. + GStreamer VAAPI module now released and maintained as part of the GStreamer project. + Asset proxy support in the GStreamer Editing Services. - Add explicit pkgconfig(gee-1.0) BuildRequires following upstreams configure. - Replace gobject-introspection-devel for pkgconfig(gobject-introspection-1.0) BuildRequires.

    2015-11-26 - dimstar@opensuse.org - Initial package, version 1.6.0.

    Advertisement
    Advertisement