loudmouth-devel-1.5.3-2.1.x86_64.rpm


Advertisement

Description

loudmouth-devel - Jabber Client Library Written in C

Distribution: openSUSE 13.2
Repository: openSUSE KDE Extra all
Package name: loudmouth-devel
Package version: 1.5.3
Package release: 2.1
Package architecture: x86_64
Package type: rpm
Installed size: 34.92 KB
Download size: 13.11 KB
Official Mirror: ftp.gwdg.de
Loudmouth is a lightweight and easy-to-use C library for programming with the Jabber protocol. It's designed to be easy to get started with and yet extensible to let you do anything the Jabber protocol allows.

Requires

Provides

  • loudmouth-devel = 1.5.3-2.1
  • loudmouth-devel(x86-64) = 1.5.3-2.1
  • pkgconfig(loudmouth-1.0) = 1.5.3

    Download

    Install Howto

    1. Add the openSUSE KDE Extra repository:
      # zypper addrepo http://ftp.gwdg.de/pub/opensuse/repositories/KDE:/Extra/openSUSE_13.2/ opensuse-kde-extra
    2. Install loudmouth-devel rpm package:
      # zypper install loudmouth-devel

    Files

    • /usr/include/loudmouth-1.0/
    • /usr/include/loudmouth-1.0/loudmouth/lm-connection.h
    • /usr/include/loudmouth-1.0/loudmouth/lm-error.h
    • /usr/include/loudmouth-1.0/loudmouth/lm-message-handler.h
    • /usr/include/loudmouth-1.0/loudmouth/lm-message-node.h
    • /usr/include/loudmouth-1.0/loudmouth/lm-message.h
    • /usr/include/loudmouth-1.0/loudmouth/lm-proxy.h
    • /usr/include/loudmouth-1.0/loudmouth/lm-ssl.h
    • /usr/include/loudmouth-1.0/loudmouth/lm-utils.h
    • /usr/include/loudmouth-1.0/loudmouth/loudmouth.h
    • /usr/lib64/libloudmouth-1.so
    • /usr/lib64/pkgconfig/loudmouth-1.0.pc

    Changelog

    2017-07-13 - olaf@aepfle.de - Remove gnutls requirement from devel pkg, openssl is used - Remove double glib2 requirement, pkgconfig handles this already

    2016-02-28 - mrueckert@suse.de - update to 1.5.3 - Switch to SHA256 fingerprints. - Do not load system certificates if trusted certs are explicitly provided. - Improve automake/autoconf support.

    2016-02-18 - mrueckert@suse.de - update to 1.5.2 - openssl: always fill the fingerprint field of LmSSL - try generic cc before testing for gcc - remove libresolv relict - include the right gssapi.h - Add libasyncns to Libs.private - Add the new API to the reference documentation - update Url field to point to the github project instead of the unrelated website

    2015-11-10 - mrueckert@suse.de - update to 1.5.1 and switch to the mcabber branch: - This Loudmouth release is compatible with current Glib/GTK libraries - The internal asyncns copy has been removed - The security has been improved in several ways: - Certificates: added checking of SAN(s) when CN does not match and fixed CN wildcard handling - SSL 2 and 3 have been deactivated; TLS 1.1 and 1.2 have been activated - Use the default cipher suite of GnuTLS - New API: Implementation of lm_ssl_set_ca and lm_ssl_set_cipher_list This enables the application to choose additional CA certificates to trust as well as the cipher suites which are used by OpenSSL or GnuTLS - Many resolver and parser issues have been fixed For details on the branch switch see: https://github.com/mcabber/loudmouth/issues/13 - enable gssapi support. new BR: krb5-devel - enable IDN support: new BR: pkgconfig(libidn) - drop patches: loudmouth-drop-stanzas-on-fail.patch loudmouth-fix-async-resolving.patch loudmouth-fix-sasl-md5-digest-uri.patch loudmouth-glib.patch loudmouth-use-pkg-config-for-gnutls.patch

    2015-04-14 - meissner@suse.com - build against openssl-devel, to avoid fixing the gnutls 3.4.0 breakage.

    2012-05-21 - badshah400@gmail.com - Use libgnutls-devel BuildRequires instead of gnutls-devel for openSUSE > 12.1: gnutls-devel has been removed from Factory.

    2011-12-04 - dimstar@opensuse.org - Change Source to point to our local file: The upstream server is currently unavailable and this stops us from checkins to Factory.

    2011-11-27 - dimstar@opensuse.org - Add loudmouth-glib.patch: Fix build with glib 2.31. - Clean spec file using spec-cleaner.

    2011-11-23 - coolo@suse.com - add libtool as buildrequire to avoid implicit dependency

    2010-02-12 - vuntz@opensuse.org - Add patches from Debian: + loudmouth-fix-sasl-md5-digest-uri.patch: use the right URI for SASL md5 digest. + loudmouth-fix-async-resolving.patch: do not check for sync DNS failures when using async DNS. + loudmouth-drop-stanzas-on-fail.patch: ignore stanza that we can't parse. + loudmouth-use-pkg-config-for-gnutls.patch: use pkg-config to detect gnutls. Fix build on Factory. - Remove AutoReqProv: it's default now. - Use makeinstall macro. - Remove .la files.

    Advertisement
    Advertisement