nvidia-computeG02-304.135-41.1.x86_64.rpm


Advertisement

Description

nvidia-computeG02 - NVIDIA driver for computing with GPGPU

Distribution: openSUSE 13.2
Repository: nVidia drivers all
Package name: nvidia-computeG02
Package version: 304.135
Package release: 41.1
Package architecture: x86_64
Package type: rpm
Installed size: 28.22 MB
Download size: 9.03 MB
Official Mirror: http.download.nvidia.com
NVIDIA driver for computing with GPGPUs using CUDA or OpenCL

Alternatives

Provides

  • libOpenCL.so.1
  • libOpenCL.so.1()(64bit)
  • libcuda.so.1
  • libcuda.so.1()(64bit)
  • libnvidia-ml.so.1()(64bit)
  • libnvidia-opencl.so.1()(64bit)
  • nvidia-computeG02 = 304.135-41.1
  • nvidia-computeG02(x86-64) = 304.135-41.1
  • x11-video-nvidiaG02:/usr/lib/libcuda.so

    Download

    Source package: x11-video-nvidiaG02-304.135-41.1.nosrc.rpm

    Install Howto

    1. Add the nVidia drivers repository:
      # zypper addrepo http://http.download.nvidia.com/opensuse/13.2/ nvidia
    2. Install nvidia-computeG02 rpm package:
      # zypper install nvidia-computeG02

    Files

    • /etc/OpenCL/
    • /etc/OpenCL/vendors/nvidia.icd
    • /usr/bin/nvidia-smi
    • /usr/lib/libOpenCL.so
    • /usr/lib/libOpenCL.so.1
    • /usr/lib/libOpenCL.so.1.0.0
    • /usr/lib/libcuda.so
    • /usr/lib/libcuda.so.1
    • /usr/lib/libcuda.so.304.135
    • /usr/lib64/libOpenCL.so
    • /usr/lib64/libOpenCL.so.1
    • /usr/lib64/libOpenCL.so.1.0.0
    • /usr/lib64/libcuda.so
    • /usr/lib64/libcuda.so.1
    • /usr/lib64/libcuda.so.304.135
    • /usr/lib64/libnvidia-ml.so
    • /usr/lib64/libnvidia-ml.so.1
    • /usr/lib64/libnvidia-ml.so.304.135
    • /usr/lib64/libnvidia-opencl.so.1
    • /usr/lib64/libnvidia-opencl.so.304.135

    Changelog

    2017-02-16 - sndirsch@suse.com - update to driver release 304.135 * Added support for X.Org xserver ABI 23 (xorg-server 1.19) * Fixed a bug that allowed nvidia-installer to attempt loading kernel modules that were built against non-running kernels.

    2016-12-13 - sndirsch@suse.com - update to driver release 304.134 * Added support for X.Org xserver ABI 23 (xorg-server 1.19) * Fixed a bug that allowed nvidia-installer to attempt loading kernel modules that were built against non-running kernels.

    2016-09-26 - sndirsch@suse.com - update to driver release 304.132 * Added /var/log/dmesg to the list of paths which are searched by nvidia-bug-report.sh for kernel messages. * Fixed a bug that caused kernel panics when using the NVIDIA driver on v4.5 and newer Linux kernels built with CONFIG_DEBUG_VM_PGFLAGS. * Updated nvidia-installer to support ncurses version 6.x.

    2015-11-27 - sndirsch@suse.com - update-alternatives for libglx.so: * make sure nvidia becomes the default (in case the link group is/was still in manual mode)

    2015-11-12 - sndirsch@suse.com - update to driver release 304.131 * Fixed a bug that could cause texture corruption in some OpenGL applications when video memory is exhausted by a combination of simultaneously running graphical and compute workloads. * Added support for X.Org xserver ABI 20 (xorg-server 1.18).

    2015-09-03 - sndirsch@suse.com - update to driver release 304.128 * Removed libvdpau and libvdpau_trace from the NVIDIA driver package. VDPAU is not supported on the legacy hardware supported on the release 304 legacy driver branch. The libvdpau_nvidia vendor library is still included, so users who wish to use VDPAU with newer hardware that still works with release 304 drivers may install libvdpau from packages provided by the OS vendor where available, or from the source code available at: http://people.freedesktop.org/~aplattner/vdpau/ * Updated nvidia-installer to use modprobe(8) when leaving the NVIDIA kernel module loaded after installation, instead of insmod(8) or libkmod. This allows the kernel module to honor any configuration directives that apply to it in /etc/modprobe.d when it is loaded. * Fixed a bug that allowed console messages from the Linux kernel to be drawn over the user interface of nvidia-installer. - supersedes 304.125-kernel-4.0.patch

    2015-09-01 - sndirsch@suse.com - U_Use-secure_getenv-3-to-improve-security.patch * VUL-0: CVE-2015-5198: libvdpau: incorrect check for security transition (bnc#943967) * VUL-0: CVE-2015-5199: libvdpau: directory traversal in dlopen (bnc#943968) * VUL-0: CVE-2015-5200: libvdpau: vulnerability in trace functionality (bnc#943969)

    2015-06-16 - sndirsch@suse.com - added Obsoletes/Conflicts for G01 and older (bnc#802624)

    2015-06-15 - sndirsch@suse.com - avoid accidental removal of G<n+1> alternative (bnc#802624)

    2015-02-02 - sndirsch@suse.com - added missing legacy pci_ids file

    Advertisement
    Advertisement